aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2010-08-17 04:08:20 +0800
committerarved <arved@FreeBSD.org>2010-08-17 04:08:20 +0800
commit1490b12bfa8b3aedf543b55621a1a7ca1e5e2092 (patch)
tree3dd4959873c3a230fc20f4f80dc47d4cb7ed407c
parent92c36ff1d6ab5ca16b2ec6335c7010bfde1aa680 (diff)
downloadfreebsd-ports-gnome-1490b12bfa8b3aedf543b55621a1a7ca1e5e2092.tar.gz
freebsd-ports-gnome-1490b12bfa8b3aedf543b55621a1a7ca1e5e2092.tar.zst
freebsd-ports-gnome-1490b12bfa8b3aedf543b55621a1a7ca1e5e2092.zip
Try not to install slice files
Reported by: QAT
-rw-r--r--devel/py-ice/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/py-ice/Makefile b/devel/py-ice/Makefile
index 0170aac2b58a..b7fdf564dc58 100644
--- a/devel/py-ice/Makefile
+++ b/devel/py-ice/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Ice
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.zeroc.com/download/Ice/3.4/ \
http://www.dirk.sh/dirk/Ice/
@@ -26,6 +27,7 @@ INSTALL_WRKSRC= ${WRKSRC}/py
LIB_VRS= ${PORTVERSION:S|.||g:C|1$||}
PLIST_SUB= LIB_VERSION="${PORTVERSION}" LIB_VRS="${LIB_VRS}"
+MAKE_ENV= ICE_HOME="${LOCALBASE}/share/Ice"
CFLAGS+= -ftemplate-depth-128 -fPIC -DPIC -Wall -D_REENTRANT ${PTHREAD_CFLAGS}
.if defined(DEBUG)
@@ -53,6 +55,11 @@ post-patch:
s|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g; \
s|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/py/config/Make.rules
+ ${REINPLACE_CMD} 's|.(ice_dir).slice|${LOCALBASE}/share/Ice|g; \
+ s|.(prefix).slice|${LOCALBASE}/share/Ice|g' \
+ ${WRKSRC}/py/config/Make.rules.mak \
+ ${WRKSRC}/config/Make.common.rules.mak \
+ ${WRKSRC}/config/Make.common.rules
post-install:
${ECHO} "Ice" > ${PYTHON_SITELIBDIR}/Ice.pth