aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-11-27 23:01:40 +0800
committeralane <alane@FreeBSD.org>2002-11-27 23:01:40 +0800
commit15ecd934e409462bb0cc1a79844ce83a9661431e (patch)
treeeb6dcfb2b04b3d4628a5a2d06c0594a2696ba1fc
parent54c69c1a6f1442be642400071337c67084748551 (diff)
downloadfreebsd-ports-gnome-15ecd934e409462bb0cc1a79844ce83a9661431e.tar.gz
freebsd-ports-gnome-15ecd934e409462bb0cc1a79844ce83a9661431e.tar.zst
freebsd-ports-gnome-15ecd934e409462bb0cc1a79844ce83a9661431e.zip
Fix autoconf usage. Port is still broken, though. It's missing linking in
whatever has all the mpz_ functions (libgmp?). But that's not autoconf's fault. Approved by: kris
-rw-r--r--lang/mozart/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/lang/mozart/Makefile b/lang/mozart/Makefile
index 685a21f3b295..d8d54a8b403b 100644
--- a/lang/mozart/Makefile
+++ b/lang/mozart/Makefile
@@ -30,6 +30,7 @@ USE_BISON= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_XLIB= yes
+USE_AUTOCONF_VER= 213
# magic wand: set INSTALL to some absurd value, or else
# mozart's configure will not find the right install
# when configuring as root.
@@ -52,9 +53,12 @@ pre-extract:
@${ECHO}
post-patch:
- cd ${WRKSRC}/contrib/gtk && autoconf213 -l ${WRKSRC}
- cd ${WRKSRC}/platform/emulator && autoconf213 -l ${WRKSRC}
- cd ${WRKSRC}/platform/tools/gump/ozflex && autoconf213 -l ${WRKSRC}
+ cd ${WRKSRC}/contrib/gtk \
+ && ${AUTOCONF} ${AUTOCONF_ARGS} -l ${WRKSRC}
+ cd ${WRKSRC}/platform/emulator \
+ && ${AUTOCONF} ${AUTOCONF_ARGS} -l ${WRKSRC}
+ cd ${WRKSRC}/platform/tools/gump/ozflex \
+ && ${AUTOCONF} ${AUTOCONF_ARGS} -l ${WRKSRC}
post-install:
.if !defined(NOPORTDOCS)