aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 17:55:03 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 17:55:03 +0800
commit1622a642b366e1e34f23c36648942934ae421b9e (patch)
tree33b4b728e2ed21d34966095bfecee6d72e4f47a3
parent9936c8e8cd33c07d7de4267972f40bae77ec6885 (diff)
downloadfreebsd-ports-gnome-1622a642b366e1e34f23c36648942934ae421b9e.tar.gz
freebsd-ports-gnome-1622a642b366e1e34f23c36648942934ae421b9e.tar.zst
freebsd-ports-gnome-1622a642b366e1e34f23c36648942934ae421b9e.zip
[patch] graphics/osgedit 0.3.0 -> 0.4.1
This port is broken on stable as mentioned in the named PR. This patch fixes this problem by updating the port to the latest version. PR: ports/56548 Submitted by: Simon Barner <barner@in.tum.de>
-rw-r--r--graphics/osgedit/Makefile10
-rw-r--r--graphics/osgedit/distinfo2
-rw-r--r--graphics/osgedit/files/patch-Makefile.in19
-rw-r--r--graphics/osgedit/files/patch-po::Makefile.in.in11
-rw-r--r--graphics/osgedit/files/patch-src::editable::entities::edstateset.cc8
-rw-r--r--graphics/osgedit/files/patch-src::editable::view::gtkedmatrix.cc7
-rw-r--r--graphics/osgedit/pkg-plist4
7 files changed, 48 insertions, 13 deletions
diff --git a/graphics/osgedit/Makefile b/graphics/osgedit/Makefile
index ecf998c3a1cd..6efe236ef4ae 100644
--- a/graphics/osgedit/Makefile
+++ b/graphics/osgedit/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= osgedit
-PORTVERSION= 0.3.0
-PORTREVISION= 2
+PORTVERSION= 0.4.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -30,11 +29,4 @@ CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
-post-extract:
-# This port has bogus config.{sub,guess} symlinks that point to where these
-# files presumably live on the author's machine. It causes the automatic
-# replacement code to fail unless we replace them with files.
- @${RM} ${WRKSRC}/config.guess ${WRKSRC}/config.sub; \
- ${TOUCH} ${WRKSRC}/config.guess ${WRKSRC}/config.sub
-
.include <bsd.port.mk>
diff --git a/graphics/osgedit/distinfo b/graphics/osgedit/distinfo
index 03b0a7016ab3..10ce33e007ee 100644
--- a/graphics/osgedit/distinfo
+++ b/graphics/osgedit/distinfo
@@ -1 +1 @@
-MD5 (osgedit-0.3.0.tar.gz) = 4a6a6fe64e80db1d4e0e3f7aaf935997
+MD5 (osgedit-0.4.1.tar.gz) = aa9fce7244beb5d3652aa5c4d0ff9544
diff --git a/graphics/osgedit/files/patch-Makefile.in b/graphics/osgedit/files/patch-Makefile.in
index e1902bdde0fc..4634cacbaefa 100644
--- a/graphics/osgedit/files/patch-Makefile.in
+++ b/graphics/osgedit/files/patch-Makefile.in
@@ -1,6 +1,19 @@
---- Makefile.in.orig Fri Jan 24 13:35:24 2003
-+++ Makefile.in Fri Jan 24 13:35:53 2003
-@@ -380,10 +380,10 @@
+--- Makefile.in.orig Wed Jul 16 02:27:40 2003
++++ Makefile.in Sun Sep 7 03:04:13 2003
+@@ -88,10 +88,10 @@
+
+
+ icon_DATA = osgedit.png
+-icondir = $(DESTDIR)$(datadir)/pixmaps
++icondir = $(DESTDIR)$(datadir)/gnome/pixmaps
+
+ util_DATA = osgedit.desktop
+-utildir = $(DESTDIR)$(datadir)/applications
++utildir = $(DESTDIR)$(datadir)/gnome/applications
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = config.h
+@@ -425,10 +425,10 @@
install-data-local:
@$(NORMAL_INSTALL)
if test -d $(srcdir)/pixmaps; then \
diff --git a/graphics/osgedit/files/patch-po::Makefile.in.in b/graphics/osgedit/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..c58deed8235f
--- /dev/null
+++ b/graphics/osgedit/files/patch-po::Makefile.in.in
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig Sat Sep 6 17:12:03 2003
++++ po/Makefile.in.in Sat Sep 6 17:12:18 2003
+@@ -27,7 +27,7 @@
+ exec_prefix = @exec_prefix@
+ datadir = @datadir@
+ libdir = @libdir@
+-localedir = $(libdir)/locale
++localedir = $(datadir)/locale
+ gnulocaledir = $(datadir)/locale
+ gettextsrcdir = $(datadir)/glib-2.0/gettext/po
+ subdir = po
diff --git a/graphics/osgedit/files/patch-src::editable::entities::edstateset.cc b/graphics/osgedit/files/patch-src::editable::entities::edstateset.cc
new file mode 100644
index 000000000000..93cf2a046864
--- /dev/null
+++ b/graphics/osgedit/files/patch-src::editable::entities::edstateset.cc
@@ -0,0 +1,8 @@
+--- src/editable/entities/edstateset.cc.orig Sat Sep 6 14:05:01 2003
++++ src/editable/entities/edstateset.cc Sat Sep 6 14:05:19 2003
+@@ -1,3 +1,5 @@
++#include <stdio.h>
++
+ #include <osg/Texture2D>
+ #include <osg/TextureCubeMap>
+ #include <editable/entityfactory.h>
diff --git a/graphics/osgedit/files/patch-src::editable::view::gtkedmatrix.cc b/graphics/osgedit/files/patch-src::editable::view::gtkedmatrix.cc
new file mode 100644
index 000000000000..fa2afb15516d
--- /dev/null
+++ b/graphics/osgedit/files/patch-src::editable::view::gtkedmatrix.cc
@@ -0,0 +1,7 @@
+--- src/editable/view/gtkedmatrix.cc.orig Sat Sep 6 14:09:46 2003
++++ src/editable/view/gtkedmatrix.cc Sat Sep 6 14:10:06 2003
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <iostream>
+ #include <gtk/gtkframe.h>
+ #include <gtk/gtktable.h>
diff --git a/graphics/osgedit/pkg-plist b/graphics/osgedit/pkg-plist
index 5a5af8866e21..6687af7d34b9 100644
--- a/graphics/osgedit/pkg-plist
+++ b/graphics/osgedit/pkg-plist
@@ -1,6 +1,8 @@
bin/osgedit
share/locale/es/LC_MESSAGES/osgedit.mo
share/locale/gl/LC_MESSAGES/osgedit.mo
+share/gnome/applications/osgedit.desktop
+share/gnome/pixmaps/osgedit.png
share/gnome/pixmaps/osgedit/billboard.png
share/gnome/pixmaps/osgedit/box.png
share/gnome/pixmaps/osgedit/center.png
@@ -15,9 +17,11 @@ share/gnome/pixmaps/osgedit/logo.png
share/gnome/pixmaps/osgedit/move.png
share/gnome/pixmaps/osgedit/node.png
share/gnome/pixmaps/osgedit/orbit.png
+share/gnome/pixmaps/osgedit/projection.png
share/gnome/pixmaps/osgedit/rotate.png
share/gnome/pixmaps/osgedit/scale.png
share/gnome/pixmaps/osgedit/select.png
+share/gnome/pixmaps/osgedit/sequence.png
share/gnome/pixmaps/osgedit/sphere.png
share/gnome/pixmaps/osgedit/switch.png
share/gnome/pixmaps/osgedit/transform.png