aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-09-24 15:51:36 +0800
committererwin <erwin@FreeBSD.org>2003-09-24 15:51:36 +0800
commit16358d1e19002f79bb8c45d009723b9c45001516 (patch)
tree32d21ba63e4faa08e89ef2802b5311ad65c080ef
parent0b9ac2c81d0cc1f45fa9292482d60de539652081 (diff)
downloadfreebsd-ports-gnome-16358d1e19002f79bb8c45d009723b9c45001516.tar.gz
freebsd-ports-gnome-16358d1e19002f79bb8c45d009723b9c45001516.tar.zst
freebsd-ports-gnome-16358d1e19002f79bb8c45d009723b9c45001516.zip
Add p5-Image-Imlib2
Image::Imlib2 is a Perl port of Imlib2, a graphics library that does image file loading and saving as well as manipulation, arbitrary polygon support, etc. It does ALL of these operations FAST. It allows you to create colour images using a large number of graphics primitives, and output the images in a range of formats. PR: 56701 Submitted by: erwin
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Image-Imlib2/Makefile25
-rw-r--r--graphics/p5-Image-Imlib2/distinfo1
-rw-r--r--graphics/p5-Image-Imlib2/files/patch-Build.PL11
-rw-r--r--graphics/p5-Image-Imlib2/pkg-descr8
-rw-r--r--graphics/p5-Image-Imlib2/pkg-plist6
6 files changed, 52 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 839cbd793c4c..fd12be011e03 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -253,6 +253,7 @@
SUBDIR += p5-GraphViz-Data-Structure
SUBDIR += p5-Graphics-ColorNames
SUBDIR += p5-Image-Grab
+ SUBDIR += p5-Image-Imlib2
SUBDIR += p5-Image-Info
SUBDIR += p5-Image-Size
SUBDIR += p5-Imager
diff --git a/graphics/p5-Image-Imlib2/Makefile b/graphics/p5-Image-Imlib2/Makefile
new file mode 100644
index 000000000000..eaea8f094dcb
--- /dev/null
+++ b/graphics/p5-Image-Imlib2/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Apache-Filter
+# Date created: September 11th, 2003
+# Whom: Erwin Lansing <erwin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-Imlib2
+PORTVERSION= 0.12
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Image
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@freebsd.org
+COMMENT= Perl interface to the Imlib2 image library
+
+LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2
+
+PERL_CONFIGURE= yes
+
+MAN3= Image::Imlib2.3
+
+.include "../../devel/p5-Module-Build/inc.build.mk"
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Imlib2/distinfo b/graphics/p5-Image-Imlib2/distinfo
new file mode 100644
index 000000000000..6739b005380d
--- /dev/null
+++ b/graphics/p5-Image-Imlib2/distinfo
@@ -0,0 +1 @@
+MD5 (Image-Imlib2-0.12.tar.gz) = 76685491b7453f89ad2bfe28d09d8703
diff --git a/graphics/p5-Image-Imlib2/files/patch-Build.PL b/graphics/p5-Image-Imlib2/files/patch-Build.PL
new file mode 100644
index 000000000000..b5689945c284
--- /dev/null
+++ b/graphics/p5-Image-Imlib2/files/patch-Build.PL
@@ -0,0 +1,11 @@
+--- Build.PL.orig Thu Sep 11 15:09:42 2003
++++ Build.PL Thu Sep 11 15:09:48 2003
+@@ -30,7 +30,7 @@
+ 'Test::More' => '0.01',
+ },
+ extra_linker_flags => $libs,
+- cc_flags => $cflags,
++ extra_compiler_flags => $cflags,
+ c_source => './lib/Image',
+ );
+ $build->create_build_script;
diff --git a/graphics/p5-Image-Imlib2/pkg-descr b/graphics/p5-Image-Imlib2/pkg-descr
new file mode 100644
index 000000000000..a8e01c27412f
--- /dev/null
+++ b/graphics/p5-Image-Imlib2/pkg-descr
@@ -0,0 +1,8 @@
+Image::Imlib2 is a Perl port of Imlib2, a graphics library
+that does image file loading and saving as well as manipulation,
+arbitrary polygon support, etc. It does ALL of these operations
+FAST. It allows you to create colour images using a large number
+of graphics primitives, and output the images in a range of formats.
+
+
+WWW: http://search.cpan.org/dist/Image-Imlib2
diff --git a/graphics/p5-Image-Imlib2/pkg-plist b/graphics/p5-Image-Imlib2/pkg-plist
new file mode 100644
index 000000000000..ab493b5b1817
--- /dev/null
+++ b/graphics/p5-Image-Imlib2/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Imlib2/Imlib2.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Imlib2/Imlib2.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Image/Imlib2.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Imlib2
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Image 2>/dev/null || true