aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-11 01:39:41 +0800
committerbapt <bapt@FreeBSD.org>2013-09-11 01:39:41 +0800
commit1a6e8b97280f666d15ef6ef197cd1a171c02a220 (patch)
tree4693fd012c4c6d933e0daa1aeff8b0a83b9b3c75
parent31367baab81ff752e42424634ea704d1b30f3978 (diff)
downloadfreebsd-ports-gnome-1a6e8b97280f666d15ef6ef197cd1a171c02a220.tar.gz
freebsd-ports-gnome-1a6e8b97280f666d15ef6ef197cd1a171c02a220.tar.zst
freebsd-ports-gnome-1a6e8b97280f666d15ef6ef197cd1a171c02a220.zip
Add an explicit dependency on pkgconf
-rw-r--r--audio/ocp/Makefile2
-rw-r--r--graphics/pornview/Makefile1
-rw-r--r--net-p2p/valknut/Makefile12
-rw-r--r--security/razorback-dispatcher/Makefile12
4 files changed, 9 insertions, 18 deletions
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index 57bcdacfbb91..ec326b84cb52 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= id3tag:${PORTSDIR}/audio/libid3tag \
ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
-USES= ncurses gmake
+USES= ncurses gmake pkgconfig
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
index e05d10be2fa1..5fc7e2e694a8 100644
--- a/graphics/pornview/Makefile
+++ b/graphics/pornview/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= exif:${PORTSDIR}/graphics/libexif \
xcb-render-util:${PORTSDIR}/x11/xcb-util-renderutil
USE_XORG= x11 xi xext xinerama
+USES= pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk2
diff --git a/net-p2p/valknut/Makefile b/net-p2p/valknut/Makefile
index 2000168e022f..2309da4d3ffb 100644
--- a/net-p2p/valknut/Makefile
+++ b/net-p2p/valknut/Makefile
@@ -1,11 +1,5 @@
-# ex: ts=8
-# New ports collection makefile for: dcgui
-# Date created: Wed 10 Jul 2002
-# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
-# Amar Takhar <verm@drunkmonk.net> et al
-#
+# Created by: Sverrir Valgeirsson <e96sv@yahoo.se>
# $FreeBSD$
-#
PORTNAME= valknut
PORTVERSION= 0.4.9
@@ -26,8 +20,8 @@ MAN1= valknut.1
USE_QT4= corelib gui network qt3support \
moc_build uic_build rcc_build linguist_build
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= gmake perl5 pkgconfig
+USE_PERL5= build
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CFLAGS+= -I${QT_INCDIR}
diff --git a/security/razorback-dispatcher/Makefile b/security/razorback-dispatcher/Makefile
index f7638cd8c4e7..7209d1d71b93 100644
--- a/security/razorback-dispatcher/Makefile
+++ b/security/razorback-dispatcher/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: razorback-dispatcher
-# Date created: 2011/06/8
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
-#
PORTNAME= dispatcher
PORTVERSION= 0.5.0
@@ -27,9 +23,7 @@ OPTIONS_DEFINE= DEBUG ASSERT ACTIVEMQ
ASSERT_DESC= Enable Asserts
ACTIVEMQ_DESC= ActiveMQ runs locally
-.include <bsd.port.options.mk>
-
-USES= pathfix
+USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_MYSQL= yes
@@ -41,6 +35,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
USERS?= razorback
GROUPS?= razorback
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.endif