aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-29 06:36:14 +0800
committermiwi <miwi@FreeBSD.org>2008-06-29 06:36:14 +0800
commit1df596d5d1cbb02dff233969dfb8710a09b5333a (patch)
tree29a67d3a9cbbb1575c9f4ce765fef77756cf2c78
parent9dd350e9c46ef046ec81cdc3d3b4faa88264be37 (diff)
downloadfreebsd-ports-gnome-1df596d5d1cbb02dff233969dfb8710a09b5333a.tar.gz
freebsd-ports-gnome-1df596d5d1cbb02dff233969dfb8710a09b5333a.tar.zst
freebsd-ports-gnome-1df596d5d1cbb02dff233969dfb8710a09b5333a.zip
This is a plugin package for Nagios. Quoting from the
snmp4nagios home page: SNMP4Nagios is a package of Nagios plugins which use SNMP to query hosts. While some of the plugins use standard MIBs, most are designed for vendor specific agents. Unlike other Nagios plugins, they are able to scan hosts for objects which can be monitored. They also can keep performance logs and draw plots of these using Tobias Oetiker's RRDTool. Currently devices by Brocade, Cisco, Compaq/HP and Network Appliance as well as computers running Microsoft Windows or Net-SNMP and uninterruptable power supplies are supported. WWW: http://snmp4nagios.sourceforge.net/ PR: ports/124954 Submitted by: Ryan Steinmetz
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/snmp4nagios/Makefile53
-rw-r--r--net-mgmt/snmp4nagios/distinfo3
-rw-r--r--net-mgmt/snmp4nagios/pkg-descr16
-rw-r--r--net-mgmt/snmp4nagios/pkg-message2
-rw-r--r--net-mgmt/snmp4nagios/pkg-plist58
6 files changed, 133 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index b7a0f3337c28..554cfd2f70dc 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -232,6 +232,7 @@
SUBDIR += slate
SUBDIR += smokeping
SUBDIR += snmp++
+ SUBDIR += snmp4nagios
SUBDIR += snmptt
SUBDIR += softflowd
SUBDIR += spectools
diff --git a/net-mgmt/snmp4nagios/Makefile b/net-mgmt/snmp4nagios/Makefile
new file mode 100644
index 000000000000..95f4757b11e5
--- /dev/null
+++ b/net-mgmt/snmp4nagios/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: snmp4nagios
+# Date created: 22 June 2008
+# Whom: Ryan Steinmetz
+#
+# $FreeBSD$
+#
+
+PORTNAME= SNMP4Nagios
+PORTVERSION= 0.4
+CATEGORIES= net-mgmt
+MASTER_SITES= SFE/snmp4nagios
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= Vendor specific SNMP plugins for Nagios
+
+BUILD_DEPENDS= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp
+RUN_DEPENDS= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp
+
+GNU_CONFIGURE= yes
+
+NAGIOSWWWDIR?= www/nagios
+NAGIOSDIR?= /var/spool/nagios
+
+OPTIONS= RRDTOOL "Build with rrdtool support" OFF
+
+CONFIGURE_ARGS= --sbindir=${PREFIX}/${NAGIOSWWWDIR}/cgi-bin \
+ --bindir=${PREFIX}/libexec/nagios \
+ --libexecdir=${PREFIX}/libexec/nagios \
+ --datadir=${PREFIX}/share \
+ --sysconfdir=${PREFIX}/etc/nagios \
+ --localstatedir=${NAGIOSDIR} \
+ --with-rrddir=${NAGIOSDIR}/snmp4nagios/rrd \
+ --with-pngdir=${NAGIOSDIR}/snmp4nagios/png \
+ --prefix=${PREFIX}
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RRDTOOL)
+LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
+CONFIGURE_ARGS+=--with-rrd
+PLIST_SUB+= RRD=""
+.else
+CONFIGURE_ARGS+=--with-rrd=no
+PLIST_SUB+= RRD="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/snmp4nagios/distinfo b/net-mgmt/snmp4nagios/distinfo
new file mode 100644
index 000000000000..cd4416c581e5
--- /dev/null
+++ b/net-mgmt/snmp4nagios/distinfo
@@ -0,0 +1,3 @@
+MD5 (SNMP4Nagios-0.4.tar.gz) = 4e98f0f26f80136861dcc17ec7dba519
+SHA256 (SNMP4Nagios-0.4.tar.gz) = 6c2e91ede8a4dc1cdb79c38e80092fb9d2bc6fed5a2a8c899d0bcf0431ce0f04
+SIZE (SNMP4Nagios-0.4.tar.gz) = 235167
diff --git a/net-mgmt/snmp4nagios/pkg-descr b/net-mgmt/snmp4nagios/pkg-descr
new file mode 100644
index 000000000000..e9edbb4a6719
--- /dev/null
+++ b/net-mgmt/snmp4nagios/pkg-descr
@@ -0,0 +1,16 @@
+This is a plugin package for Nagios. Quoting from the
+snmp4nagios home page:
+
+SNMP4Nagios is a package of Nagios plugins which use SNMP
+to query hosts. While some of the plugins use standard MIBs,
+most are designed for vendor specific agents.
+
+Unlike other Nagios plugins, they are able to scan hosts for
+objects which can be monitored. They also can keep performance
+logs and draw plots of these using Tobias Oetiker's RRDTool.
+
+Currently devices by Brocade, Cisco, Compaq/HP and Network Appliance
+as well as computers running Microsoft Windows or Net-SNMP
+and uninterruptable power supplies are supported.
+
+WWW: http://snmp4nagios.sourceforge.net/
diff --git a/net-mgmt/snmp4nagios/pkg-message b/net-mgmt/snmp4nagios/pkg-message
new file mode 100644
index 000000000000..c97cfd5f8ff5
--- /dev/null
+++ b/net-mgmt/snmp4nagios/pkg-message
@@ -0,0 +1,2 @@
+If this port is no longer being used, you may clean up
+/var/spool/nagios/snmp4nagios/ manually.
diff --git a/net-mgmt/snmp4nagios/pkg-plist b/net-mgmt/snmp4nagios/pkg-plist
new file mode 100644
index 000000000000..76ea83115f14
--- /dev/null
+++ b/net-mgmt/snmp4nagios/pkg-plist
@@ -0,0 +1,58 @@
+libexec/nagios/check_brocade_fan
+libexec/nagios/check_brocade_overall
+libexec/nagios/check_brocade_port
+libexec/nagios/check_brocade_psu
+libexec/nagios/check_brocade_temp
+libexec/nagios/check_cisco_cpuusage
+libexec/nagios/check_cisco_fan
+libexec/nagios/check_cisco_if_load
+libexec/nagios/check_cisco_mem
+libexec/nagios/check_cisco_pix_conns
+libexec/nagios/check_cisco_psu
+libexec/nagios/check_cisco_temp
+libexec/nagios/check_cisco_voltage
+libexec/nagios/check_cisco_vpn_conns
+libexec/nagios/check_cisco_vpn_cpuusage
+libexec/nagios/check_cisco_vpn_fan
+libexec/nagios/check_cisco_vpn_temp
+libexec/nagios/check_cisco_vpn_thru
+libexec/nagios/check_cisco_vpn_voltage
+libexec/nagios/check_cpq_fan
+libexec/nagios/check_cpq_fcaaccel
+libexec/nagios/check_cpq_fcaeac
+libexec/nagios/check_cpq_fcahctrl
+libexec/nagios/check_cpq_fcalogdrv
+libexec/nagios/check_cpq_fcaphydrv
+libexec/nagios/check_cpq_fcaspare
+libexec/nagios/check_cpq_ida
+libexec/nagios/check_cpq_phydrv
+libexec/nagios/check_cpq_temp
+libexec/nagios/check_cpq_thermal
+libexec/nagios/check_if_by_snmp
+libexec/nagios/check_mail_server
+libexec/nagios/check_netapp_battery
+libexec/nagios/check_netapp_du
+libexec/nagios/check_netapp_fans
+libexec/nagios/check_netapp_ops
+libexec/nagios/check_netapp_overall
+libexec/nagios/check_netapp_psus
+libexec/nagios/check_netapp_raiddrv
+libexec/nagios/check_netapp_spare
+libexec/nagios/check_netapp_temp
+libexec/nagios/check_netapp_vol
+libexec/nagios/check_storage_by_snmp
+libexec/nagios/check_ucd_lms_fan
+libexec/nagios/check_ucd_lms_temp
+libexec/nagios/check_ucd_lms_voltage
+libexec/nagios/check_ucd_snmp_cpu
+libexec/nagios/check_ucd_snmp_load
+libexec/nagios/check_ucd_snmp_mem
+libexec/nagios/check_ups_alarms
+libexec/nagios/check_ups_battery
+libexec/nagios/check_ups_bypass
+libexec/nagios/check_ups_input
+libexec/nagios/check_ups_output
+libexec/nagios/check_ups_outputs
+libexec/nagios/check_winf_cpuusage
+libexec/nagios/check_winf_mem
+@dirrmtry libexec/nagios