aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-07-30 10:24:17 +0800
committerclsung <clsung@FreeBSD.org>2007-07-30 10:24:17 +0800
commit1e3e9a6db8cfa2bbb8dc0d3ad77f34642ebcbe0d (patch)
tree4fd6b734a77a578fa3f924e2d4327efb828fb936
parentbdf3f33b465c2654b775784e012081944a92152b (diff)
downloadfreebsd-ports-gnome-1e3e9a6db8cfa2bbb8dc0d3ad77f34642ebcbe0d.tar.gz
freebsd-ports-gnome-1e3e9a6db8cfa2bbb8dc0d3ad77f34642ebcbe0d.tar.zst
freebsd-ports-gnome-1e3e9a6db8cfa2bbb8dc0d3ad77f34642ebcbe0d.zip
Search::Odeum is an interface to the Odeum API. Odeum is the inverted
index API which is a part of qdbm database library. WWW: http://search.cpan.org/dist/Search-Odeum/ PR: ports/114939 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Search-Odeum/Makefile28
-rw-r--r--textproc/p5-Search-Odeum/distinfo3
-rw-r--r--textproc/p5-Search-Odeum/pkg-descr4
-rw-r--r--textproc/p5-Search-Odeum/pkg-plist11
5 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7f25d390e27d..0e40cd882b5d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -477,6 +477,7 @@
SUBDIR += p5-SGMLSpm
SUBDIR += p5-SVG
SUBDIR += p5-Search-Estraier
+ SUBDIR += p5-Search-Odeum
SUBDIR += p5-Search-Saryer
SUBDIR += p5-Search-VectorSpace
SUBDIR += p5-Senna
diff --git a/textproc/p5-Search-Odeum/Makefile b/textproc/p5-Search-Odeum/Makefile
new file mode 100644
index 000000000000..33e6d25f7ace
--- /dev/null
+++ b/textproc/p5-Search-Odeum/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Search-Odeum
+# Date created: 2007-07-26
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Search-Odeum
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Search
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl interface to the Odeum inverted index API
+
+LIB_DEPENDS= qdbm:${PORTSDIR}/databases/qdbm
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+PERL_CONFIGURE= yes
+
+MAN3= Search::Odeum.3 \
+ Search::Odeum::Document.3 \
+ Search::Odeum::Result.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Search-Odeum/distinfo b/textproc/p5-Search-Odeum/distinfo
new file mode 100644
index 000000000000..abf022849de8
--- /dev/null
+++ b/textproc/p5-Search-Odeum/distinfo
@@ -0,0 +1,3 @@
+MD5 (Search-Odeum-0.02.tar.gz) = 52fe4b7d73a557b1cd7953f268c01980
+SHA256 (Search-Odeum-0.02.tar.gz) = 34d5784bc45afa3811d7c8f96ef1b60f93ae1624a5864e8e1b40dd115a565f6c
+SIZE (Search-Odeum-0.02.tar.gz) = 36293
diff --git a/textproc/p5-Search-Odeum/pkg-descr b/textproc/p5-Search-Odeum/pkg-descr
new file mode 100644
index 000000000000..8f066c445a8c
--- /dev/null
+++ b/textproc/p5-Search-Odeum/pkg-descr
@@ -0,0 +1,4 @@
+Search::Odeum is an interface to the Odeum API. Odeum is the inverted
+index API which is a part of qdbm database library.
+
+WWW: http://search.cpan.org/dist/Search-Odeum/
diff --git a/textproc/p5-Search-Odeum/pkg-plist b/textproc/p5-Search-Odeum/pkg-plist
new file mode 100644
index 000000000000..ca0e83108039
--- /dev/null
+++ b/textproc/p5-Search-Odeum/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum/Document.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum/Result.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum/Odeum.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum/Odeum.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Search