aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-26 04:52:05 +0800
committeraaron <aaron@FreeBSD.org>2006-05-26 04:52:05 +0800
commit1e8f1d0959342efae774cf3d0a6becb13030215a (patch)
treeadaf1a2860cefb1d6ef4a0c5ba5daf529096c383
parent6164624d7c2bed0a48ad971429b717863df77f85 (diff)
downloadfreebsd-ports-gnome-1e8f1d0959342efae774cf3d0a6becb13030215a.tar.gz
freebsd-ports-gnome-1e8f1d0959342efae774cf3d0a6becb13030215a.tar.zst
freebsd-ports-gnome-1e8f1d0959342efae774cf3d0a6becb13030215a.zip
Adding port math/p5-Math-Algebra-Symbols, Symbolic Algebra in Pure Perl.
Approved by: tobez (implicit)
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Algebra-Symbols/Makefile34
-rw-r--r--math/p5-Math-Algebra-Symbols/distinfo3
-rw-r--r--math/p5-Math-Algebra-Symbols/pkg-descr8
-rw-r--r--math/p5-Math-Algebra-Symbols/pkg-plist12
5 files changed, 58 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7acb2ed2da6e..5d5fe5e3f252 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -163,6 +163,7 @@
SUBDIR += p5-Date-Handler
SUBDIR += p5-Geo-Distance
SUBDIR += p5-Graph
+ SUBDIR += p5-Math-Algebra-Symbols
SUBDIR += p5-Math-Base85
SUBDIR += p5-Math-BaseCalc
SUBDIR += p5-Math-Bezier
diff --git a/math/p5-Math-Algebra-Symbols/Makefile b/math/p5-Math-Algebra-Symbols/Makefile
new file mode 100644
index 000000000000..800df81c63bd
--- /dev/null
+++ b/math/p5-Math-Algebra-Symbols/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Math-Algebra-Symbols
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Algebra-Symbols
+PORTVERSION= 1.21
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Symbolic Algebra in Pure Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Algebra::Symbols.3 \
+ Math::Algebra::Symbols::Sum.3 \
+ Math::Algebra::Symbols::Symbols.3 \
+ Math::Algebra::Symbols::Term.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= currently requires Perl 5.8. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Algebra-Symbols/distinfo b/math/p5-Math-Algebra-Symbols/distinfo
new file mode 100644
index 000000000000..355327e4c88c
--- /dev/null
+++ b/math/p5-Math-Algebra-Symbols/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Algebra-Symbols-1.21.tar.gz) = a4625a87722c53c5f3666b9ab7d79c9b
+SHA256 (Math-Algebra-Symbols-1.21.tar.gz) = 385fa7632e045c3d0734312535dca92575c3ab9bfa2988b2aceae3defcf5a25d
+SIZE (Math-Algebra-Symbols-1.21.tar.gz) = 107418
diff --git a/math/p5-Math-Algebra-Symbols/pkg-descr b/math/p5-Math-Algebra-Symbols/pkg-descr
new file mode 100644
index 000000000000..523d07dde86e
--- /dev/null
+++ b/math/p5-Math-Algebra-Symbols/pkg-descr
@@ -0,0 +1,8 @@
+This package supplies a set of functions and operators to manipulate
+operator expressions algebraically using the familiar Perl syntax.
+
+These expressions are constructed from "Symbols", "Operators", and
+"Functions", and processed via "Methods". For examples, see: "Examples".
+
+WWW: http://search.cpan.org/dist/Math-Algebra-Symbols
+Author: Philip R Brenan <philiprbrenan@yahoo.com>
diff --git a/math/p5-Math-Algebra-Symbols/pkg-plist b/math/p5-Math-Algebra-Symbols/pkg-plist
new file mode 100644
index 000000000000..e44484ec2f0a
--- /dev/null
+++ b/math/p5-Math-Algebra-Symbols/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/Math/Algebra/Symbols.pm
+%%SITE_PERL%%/Math/Algebra/Symbols/Sum.pm
+%%SITE_PERL%%/Math/Algebra/Symbols/Symbols.pm
+%%SITE_PERL%%/Math/Algebra/Symbols/Term.pm
+%%SITE_PERL%%/Math/Algebra/symbols.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Algebra/Symbols/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Algebra/Symbols
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Algebra
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/Math/Algebra/Symbols
+@dirrmtry %%SITE_PERL%%/Math/Algebra
+@dirrmtry %%SITE_PERL%%/Math