aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2011-11-11 23:47:43 +0800
committerclsung <clsung@FreeBSD.org>2011-11-11 23:47:43 +0800
commit1efe01a13b91d49f08f9f8811883c188608c4426 (patch)
tree2ce3e19db8a372474e9d7c9a65c5fcc4618ba059
parent8a122574b99300eb8fec569e2a4eb10f88c3a07e (diff)
downloadfreebsd-ports-gnome-1efe01a13b91d49f08f9f8811883c188608c4426.tar.gz
freebsd-ports-gnome-1efe01a13b91d49f08f9f8811883c188608c4426.tar.zst
freebsd-ports-gnome-1efe01a13b91d49f08f9f8811883c188608c4426.zip
fcitx-sunpinyin provides SunPinyin, a statistical language model based
input method engine, as a back-end to the Fcitx IM server. WWW: http://code.google.com/p/fcitx/ PR: ports/162466 Submitted by: maintainer (Zhihao Yuan) Feature safe: yes
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/fcitx-sunpinyin/Makefile30
-rw-r--r--chinese/fcitx-sunpinyin/distinfo2
-rw-r--r--chinese/fcitx-sunpinyin/files/patch-CMakeLists.txt11
-rw-r--r--chinese/fcitx-sunpinyin/files/patch-src_eim.cpp11
-rw-r--r--chinese/fcitx-sunpinyin/pkg-descr4
-rw-r--r--chinese/fcitx-sunpinyin/pkg-message7
-rw-r--r--chinese/fcitx-sunpinyin/pkg-plist13
8 files changed, 79 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 82eca55b3e18..0b15c97306c5 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -37,6 +37,7 @@
SUBDIR += eterm
SUBDIR += fcitx
SUBDIR += fcitx-configtool
+ SUBDIR += fcitx-sunpinyin
SUBDIR += fireflyttf
SUBDIR += font-std
SUBDIR += fortune
diff --git a/chinese/fcitx-sunpinyin/Makefile b/chinese/fcitx-sunpinyin/Makefile
new file mode 100644
index 000000000000..644f6208764b
--- /dev/null
+++ b/chinese/fcitx-sunpinyin/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: fcitx-sunpinyin
+# Date created: 10 Nov 2011
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fcitx-sunpinyin
+PORTVERSION= 0.3.2
+CATEGORIES= chinese x11
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= SunPinyin support for Fcitx
+
+LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
+ sunpinyin.3:${PORTSDIR}/chinese/sunpinyin
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_CMAKE= yes
+USE_GNOME= intltool
+INSTALLS_ICONS= yes
+
+PROJECTHOST= fcitx
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/chinese/fcitx-sunpinyin/distinfo b/chinese/fcitx-sunpinyin/distinfo
new file mode 100644
index 000000000000..584a37d06f9a
--- /dev/null
+++ b/chinese/fcitx-sunpinyin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fcitx-sunpinyin-0.3.2.tar.bz2) = e22c6b64224ac7d50d62574980eaa180c9857f35c87b7450a185cd8e906a3577
+SIZE (fcitx-sunpinyin-0.3.2.tar.bz2) = 43008
diff --git a/chinese/fcitx-sunpinyin/files/patch-CMakeLists.txt b/chinese/fcitx-sunpinyin/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..6b9bdbc1aea3
--- /dev/null
+++ b/chinese/fcitx-sunpinyin/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt~ 2011-09-29 01:58:59.000000000 -0500
++++ CMakeLists.txt 2011-11-10 23:22:41.804644040 -0600
+@@ -10,7 +10,7 @@ FIND_PACKAGE(Libintl REQUIRED)
+ FIND_PACKAGE(Gettext REQUIRED)
+ FIND_PACKAGE(Fcitx 4.1.2 REQUIRED)
+
+-PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.4" )
++PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.3" )
+
+ # uninstall target
+ configure_file(
diff --git a/chinese/fcitx-sunpinyin/files/patch-src_eim.cpp b/chinese/fcitx-sunpinyin/files/patch-src_eim.cpp
new file mode 100644
index 000000000000..a0a37f83c4a9
--- /dev/null
+++ b/chinese/fcitx-sunpinyin/files/patch-src_eim.cpp
@@ -0,0 +1,11 @@
+--- src/eim.cpp.orig 2011-09-29 01:58:59.000000000 -0500
++++ src/eim.cpp 2011-11-11 02:25:11.839864988 -0600
+@@ -229,8 +229,6 @@ INPUT_RETURN_VALUE FcitxSunpinyinGetCand
+ (ppd.size() - ppd.caret() + 1) * sizeof(TWCHAR));
+ memcpy(sunpinyin->input_src, src, hzlen * sizeof(TWCHAR));
+
+- FcitxLog(INFO, "%d", ppd.candi_start());
+-
+ sunpinyin->front_src[ppd.caret()] = 0;
+ sunpinyin->end_src[ppd.size() - ppd.caret() + 1] = 0;
+ sunpinyin->input_src[hzlen] = 0;
diff --git a/chinese/fcitx-sunpinyin/pkg-descr b/chinese/fcitx-sunpinyin/pkg-descr
new file mode 100644
index 000000000000..9bec81fef891
--- /dev/null
+++ b/chinese/fcitx-sunpinyin/pkg-descr
@@ -0,0 +1,4 @@
+fcitx-sunpinyin provides SunPinyin, a statistical language model based
+input method engine, as a back-end to the Fcitx IM server.
+
+WWW: http://code.google.com/p/fcitx/
diff --git a/chinese/fcitx-sunpinyin/pkg-message b/chinese/fcitx-sunpinyin/pkg-message
new file mode 100644
index 000000000000..af2284019076
--- /dev/null
+++ b/chinese/fcitx-sunpinyin/pkg-message
@@ -0,0 +1,7 @@
+************************************************************************
+
+You probably need to remove the old configurations, i.e,
+ rm -fr $HOME/.config/fcitx
+before switching to the fcitx-sunpinyin back-end!
+
+************************************************************************
diff --git a/chinese/fcitx-sunpinyin/pkg-plist b/chinese/fcitx-sunpinyin/pkg-plist
new file mode 100644
index 000000000000..53f7b88bd1f2
--- /dev/null
+++ b/chinese/fcitx-sunpinyin/pkg-plist
@@ -0,0 +1,13 @@
+lib/fcitx/fcitx-sunpinyin.so
+share/fcitx/addon/fcitx-sunpinyin.conf
+share/fcitx/configdesc/fcitx-sunpinyin.desc
+share/fcitx/skin/classic/sunpinyin.png
+share/fcitx/skin/dark/sunpinyin.png
+share/fcitx/skin/default/sunpinyin.png
+share/icons/hicolor/128x128/apps/fcitx-sunpinyin.png
+share/icons/hicolor/16x16/apps/fcitx-sunpinyin.png
+share/icons/hicolor/22x22/apps/fcitx-sunpinyin.png
+share/icons/hicolor/24x24/apps/fcitx-sunpinyin.png
+share/icons/hicolor/32x32/apps/fcitx-sunpinyin.png
+share/icons/hicolor/48x48/apps/fcitx-sunpinyin.png
+share/locale/zh_CN/LC_MESSAGES/fcitx-sunpinyin.mo