aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2012-04-01 04:51:40 +0800
committeracm <acm@FreeBSD.org>2012-04-01 04:51:40 +0800
commit1f4f9e2820efdb9461b602131472c384329e9333 (patch)
treec5891fddc8568f3fdae8766150e0eb825e9e235f
parent5a5d8fa582dc300f1b8c9a39e945d8773dd41bd1 (diff)
downloadfreebsd-ports-gnome-1f4f9e2820efdb9461b602131472c384329e9333.tar.gz
freebsd-ports-gnome-1f4f9e2820efdb9461b602131472c384329e9333.tar.zst
freebsd-ports-gnome-1f4f9e2820efdb9461b602131472c384329e9333.zip
- Fix build with png and jepg support. They were not detected correctly and it
could cause problems with apps that depends of Irrlicht Feature safe: yes
-rw-r--r--x11-toolkits/irrlicht/Makefile10
-rw-r--r--x11-toolkits/irrlicht/files/patch-source-Irrlicht_Makefile2
2 files changed, 6 insertions, 6 deletions
diff --git a/x11-toolkits/irrlicht/Makefile b/x11-toolkits/irrlicht/Makefile
index 0903352a0761..0f5038543f70 100644
--- a/x11-toolkits/irrlicht/Makefile
+++ b/x11-toolkits/irrlicht/Makefile
@@ -27,11 +27,6 @@ PLIST_SUB+= SHARED_LIB_VER=${SHARED_LIB_VER}
SUB_FILES= pkg-message
BUILD_WRKSRC= ${WRKSRC}/source/Irrlicht
-CPPFLAGS+= -DNO_IRR_USE_NON_SYSTEM_JPEG_LIB_ \
- -DNO_IRR_USE_NON_SYSTEM_LIB_PNG_ \
- -DNO_IRR_USE_NON_SYSTEM_ZLIB_ \
- -DNO_IRR_COMPILE_WITH_BZIP2_
-
SHARED_LIB_VER= 1
EXAMPLEDIRS= 01.HelloWorld 02.Quake3Map 03.CustomSceneNode 04.Movement 05.UserInterface \
06.2DGraphics 07.Collision 08.SpecialFX 09.Meshviewer 10.Shaders \
@@ -73,6 +68,11 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
${WRKSRC}/source/Irrlicht/CImageLoaderPNG.cpp
+ @${REINPLACE_CMD} -e '/#define.*_IRR_USE_NON_SYSTEM_JPEG_LIB_/ d' \
+ -e '/#define.*_IRR_USE_NON_SYSTEM_LIB_PNG_/ d' \
+ -e '/#define.*_IRR_USE_NON_SYSTEM_ZLIB_/ d' \
+ -e '/#define.*_IRR_USE_NON_SYSTEM_BZLIB_/ d' \
+ ${WRKSRC}/include/IrrCompileConfig.h
.if !defined(HAVE_JOYSTICK)
@${REINPLACE_CMD} -e '/define.*_IRR_COMPILE_WITH_JOYSTICK_EVENTS_/ d' \
${WRKSRC}/include/IrrCompileConfig.h
diff --git a/x11-toolkits/irrlicht/files/patch-source-Irrlicht_Makefile b/x11-toolkits/irrlicht/files/patch-source-Irrlicht_Makefile
index e6a2e49c0706..fafa3fb438fc 100644
--- a/x11-toolkits/irrlicht/files/patch-source-Irrlicht_Makefile
+++ b/x11-toolkits/irrlicht/files/patch-source-Irrlicht_Makefile
@@ -23,7 +23,7 @@
$(IRRVIDEOOBJ) $(IRRSWRENDEROBJ) $(IRRIOOBJ) $(IRROTHEROBJ) \
- $(IRRGUIOBJ) $(ZLIBOBJ) $(JPEGLIBOBJ) $(LIBPNGOBJ) $(LIBAESGM) \
- $(BZIP2OBJ) $(EXTRAOBJ)
-+ $(IRRGUIOBJ) $(ZLIBOBJ) $(LIBAESGM) $(EXTRAOBJ)
++ $(IRRGUIOBJ) $(LIBAESGM) $(EXTRAOBJ)
###############
#Compiler flags