aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2005-03-15 01:09:49 +0800
committernobutaka <nobutaka@FreeBSD.org>2005-03-15 01:09:49 +0800
commit1f86a61b77b674a822a9bfb80be9d72fad62027f (patch)
tree2ccf2b91881c71b45725d6dad1655a913f55f45b
parent6c58d54e091fd3ca94465a593ff7f2da1c43676f (diff)
downloadfreebsd-ports-gnome-1f86a61b77b674a822a9bfb80be9d72fad62027f.tar.gz
freebsd-ports-gnome-1f86a61b77b674a822a9bfb80be9d72fad62027f.tar.zst
freebsd-ports-gnome-1f86a61b77b674a822a9bfb80be9d72fad62027f.zip
Add dd_rescue, a dd tool suitable for rescuing data from a medium with errors.
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/dd_rescue/Makefile26
-rw-r--r--sysutils/dd_rescue/distinfo2
-rw-r--r--sysutils/dd_rescue/files/patch-Makefile12
-rw-r--r--sysutils/dd_rescue/files/patch-dd_rescue.c12
-rw-r--r--sysutils/dd_rescue/pkg-descr10
-rw-r--r--sysutils/dd_rescue/pkg-plist3
7 files changed, 66 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index dffe6129d975..dce400fd3b67 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -90,6 +90,7 @@
SUBDIR += dar
SUBDIR += dc42wrap
SUBDIR += dcfldd
+ SUBDIR += dd_rescue
SUBDIR += deleted
SUBDIR += detach
SUBDIR += detox
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
new file mode 100644
index 000000000000..293e6e98e2d9
--- /dev/null
+++ b/sysutils/dd_rescue/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dd_rescue
+# Date created: 14 March 2005
+# Whom: MANTANI Nobutaka <nobutaka@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dd_rescue
+PORTVERSION= 1.11
+CATEGORIES= sysutils
+MASTER_SITES= http://www.garloff.de/kurt/linux/ddrescue/
+
+MAINTAINER= nobutaka@freebsd.org
+COMMENT= A dd tool suitable for rescuing data from a medium with errors
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= default
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dd_rescue ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.dd_rescue ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/dd_rescue/distinfo b/sysutils/dd_rescue/distinfo
new file mode 100644
index 000000000000..8826b7eb2738
--- /dev/null
+++ b/sysutils/dd_rescue/distinfo
@@ -0,0 +1,2 @@
+MD5 (dd_rescue-1.11.tar.gz) = 1fdd3716d5e8e33de66552efb176fe61
+SIZE (dd_rescue-1.11.tar.gz) = 17259
diff --git a/sysutils/dd_rescue/files/patch-Makefile b/sysutils/dd_rescue/files/patch-Makefile
new file mode 100644
index 000000000000..be2e34499e79
--- /dev/null
+++ b/sysutils/dd_rescue/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Fri Oct 22 16:38:03 2004
++++ Makefile Tue Mar 15 01:00:23 2005
+@@ -6,9 +6,7 @@
+
+ DESTDIR =
+
+-CC = gcc
+ RPM_OPT_FLAGS = -O2 -Wall -g
+-CFLAGS = $(RPM_OPT_FLAGS) $(EXTRA_CFLAGS)
+ DEFINES = -DVERSION=\"$(VERSION)\"
+ INSTALL = install
+ INSTALLFLAGS = -s
diff --git a/sysutils/dd_rescue/files/patch-dd_rescue.c b/sysutils/dd_rescue/files/patch-dd_rescue.c
new file mode 100644
index 000000000000..99594b66653b
--- /dev/null
+++ b/sysutils/dd_rescue/files/patch-dd_rescue.c
@@ -0,0 +1,12 @@
+--- dd_rescue.c.orig Mon Feb 14 09:47:10 2005
++++ dd_rescue.c Tue Mar 15 00:59:42 2005
+@@ -717,7 +717,8 @@
+ ipos = 0;
+
+ #ifdef O_DIRECT
+- if (posix_memalign(mp, sysconf(_SC_PAGESIZE), softbs)) {
++ buf = malloc(softbs);
++ if (!buf) {
+ fplog(stderr, "dd_rescue: (fatal): allocation of aligned buffer failed!\n");
+ cleanup(); exit(18);
+ }
diff --git a/sysutils/dd_rescue/pkg-descr b/sysutils/dd_rescue/pkg-descr
new file mode 100644
index 000000000000..d59ca191dee9
--- /dev/null
+++ b/sysutils/dd_rescue/pkg-descr
@@ -0,0 +1,10 @@
+dd_rescue is a dd tool with following features suitable for rescuing data from
+a medium with errors.
+
+- Don't abort on errors on the input file unless the user specify the maximum
+ error number.
+- Don't truncate the output file.
+- Can use two different block sizes for normal operation and the case of errors.
+- Can start from the end of the file and move backwards.
+
+WWW: http://www.garloff.de/kurt/linux/ddrescue/
diff --git a/sysutils/dd_rescue/pkg-plist b/sysutils/dd_rescue/pkg-plist
new file mode 100644
index 000000000000..16ef6f00b767
--- /dev/null
+++ b/sysutils/dd_rescue/pkg-plist
@@ -0,0 +1,3 @@
+bin/dd_rescue
+%%PORTDOCS%%%%DOCSDIR%%/README.dd_rescue
+%%PORTDOCS%%@dirrm %%DOCSDIR%%