aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-04-13 10:57:08 +0800
committerijliao <ijliao@FreeBSD.org>2004-04-13 10:57:08 +0800
commit1f8a723a7ec3ae9045455a809d2136c7430def85 (patch)
treebcee9dd99305bfd06e0bfb4f9aa4cd92100cb333
parent139e9b4ee5380c2f56185e187f7c2dc0b86baeac (diff)
downloadfreebsd-ports-gnome-1f8a723a7ec3ae9045455a809d2136c7430def85.tar.gz
freebsd-ports-gnome-1f8a723a7ec3ae9045455a809d2136c7430def85.tar.zst
freebsd-ports-gnome-1f8a723a7ec3ae9045455a809d2136c7430def85.zip
add teddy 1.81.5
Graphics Library for 3D Scenes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/teddy/Makefile47
-rw-r--r--graphics/teddy/distinfo2
-rw-r--r--graphics/teddy/files/patch-configure11
-rw-r--r--graphics/teddy/pkg-descr11
5 files changed, 72 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e769d0324fe3..8a0325b27bcb 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -401,6 +401,7 @@
SUBDIR += swftools
SUBDIR += synaesthesia
SUBDIR += tcm
+ SUBDIR += teddy
SUBDIR += tgif
SUBDIR += tgif-nls
SUBDIR += threeDS
diff --git a/graphics/teddy/Makefile b/graphics/teddy/Makefile
new file mode 100644
index 000000000000..aed94e07f6d2
--- /dev/null
+++ b/graphics/teddy/Makefile
@@ -0,0 +1,47 @@
+# ex:ts=8
+# Ports collection makefile for: teddy
+# Date created: Apr 13, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= teddy
+PORTVERSION= 1.81.5
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Teddy-${PORTVERSION}.src
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Graphics Library for 3D Scenes
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_ZIP= yes
+USE_SDL= sdl image mixer
+USE_GNOME= pkgconfig
+USE_GL= yes
+GNU_CONFIGURE= yes
+CFLAGS+= -I${X11BASE}/include ${PTHREAD_CFLAGS}
+USE_GMAKE= yes
+
+PLIST_FILES= lib/libTeddy.a libdata/pkgconfig/Teddy.pc
+
+post-extract:
+ @${CHMOD} +x ${WRKSRC}/configure
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/Teddy
+ cd ${WRKSRC} && ${TAR} cf - `${FIND} Teddy -name "*.h"` | \
+ (cd ${PREFIX}/include ; ${TAR} xfBp -)
+ @${FIND} ${PREFIX}/include/Teddy ! -type d | ${XARGS} ${CHMOD} 644
+ @${FIND} ${PREFIX}/include/Teddy ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/Teddy -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ ${INSTALL_DATA} ${WRKSRC}/libTeddy.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/Teddy.pc ${PREFIX}/libdata/pkgconfig
+
+.include <bsd.port.mk>
diff --git a/graphics/teddy/distinfo b/graphics/teddy/distinfo
new file mode 100644
index 000000000000..0c2e414e696a
--- /dev/null
+++ b/graphics/teddy/distinfo
@@ -0,0 +1,2 @@
+MD5 (Teddy-1.81.5.src.zip) = 6653bb2b030cf56ab618e6eab39a007d
+SIZE (Teddy-1.81.5.src.zip) = 1207931
diff --git a/graphics/teddy/files/patch-configure b/graphics/teddy/files/patch-configure
new file mode 100644
index 000000000000..a02afa8e57bb
--- /dev/null
+++ b/graphics/teddy/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Mon Dec 2 15:48:44 2002
++++ configure Tue Apr 13 09:54:17 2004
+@@ -1552,7 +1552,7 @@
+ fi
+
+ if test "x$PKG_CONFIG" != "xno" ; then
+- PKGDIR="`which pkg-config | sed s/bin\\\\/pkg-/lib\\\\/pkg/`"
++ PKGDIR="`which pkg-config | sed s/bin\\\\/pkg-/libdata\\\\/pkg/`"
+ else
+ PKGDIR="${prefix}/lib/pkgconfig"
+ if test "x$lib_do_shared" = "xyes"; then
diff --git a/graphics/teddy/pkg-descr b/graphics/teddy/pkg-descr
new file mode 100644
index 000000000000..838f1544d881
--- /dev/null
+++ b/graphics/teddy/pkg-descr
@@ -0,0 +1,11 @@
+Teddy is a 3D graphics library. The main purpose is to be a simple scene graph
+manager. Here is a brief list of main features:
+ * scene graph
+ * windowing system
+ * multiple scenes
+ * multiple cameras
+ * multiple camera windows
+ * LightWave objects
+ * LightWave scenes
+
+WWW: http://teddy.sourceforge.net/