aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2010-08-17 03:02:43 +0800
committerarved <arved@FreeBSD.org>2010-08-17 03:02:43 +0800
commit1fcf588c73220976ad7c435288593b7d7104774b (patch)
tree3e558ea0c23225b4c99fa7ce024cfcb146a3e044
parent3d4cb64622e6e0dd40e12d06f59e8c519d1cc411 (diff)
downloadfreebsd-ports-gnome-1fcf588c73220976ad7c435288593b7d7104774b.tar.gz
freebsd-ports-gnome-1fcf588c73220976ad7c435288593b7d7104774b.tar.zst
freebsd-ports-gnome-1fcf588c73220976ad7c435288593b7d7104774b.zip
Add x2goclient, QTversion of the x2go terminalserverclient
-rw-r--r--net/Makefile1
-rw-r--r--net/x2goclient/Makefile42
-rw-r--r--net/x2goclient/distinfo3
-rw-r--r--net/x2goclient/pkg-descr3
4 files changed, 49 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d9c17e7eabea..f1893c3ef36d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1141,6 +1141,7 @@
SUBDIR += wpa_gui
SUBDIR += wping
SUBDIR += x11vnc
+ SUBDIR += x2goclient
SUBDIR += x2goclient-cli
SUBDIR += xbone
SUBDIR += xbone-gui
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
new file mode 100644
index 000000000000..c22527964a58
--- /dev/null
+++ b/net/x2goclient/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: x2goclient
+# Date created: 2010-08-16
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= x2goclient
+DISTVERSION= 3.01-5
+CATEGORIES= net
+MASTER_SITES= http://x2go.obviously-nice.de/deb/pool-lenny/x2goclient/
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= The x2go perl client
+
+LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client
+RUN_DEPENDS= nxproxy:${PORTSDIR}/net/nxproxy \
+ x2goclient-cli:${PORTSDIR}/net/x2goclient-cli
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+PLIST_FILES= bin/x2goclient
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S,-5,,}
+USE_QT_VER= 4
+QT_COMPONENTS= gui network svg qmake_build moc_build uic_build rcc_build
+USE_OPENLDAP= yes
+
+post-patch:
+ cd ${WRKSRC}; ${REINPLACE_CMD} -e "s,Q_OS_LINUX,Q_OS_FREEBSD," \
+ embedwidget.cpp onmainwindow.cpp ongetpass.cpp \
+ clicklineedit.cpp embedwidget.h clicklineedit.h
+ ${REINPLACE_CMD} -e "s,#include <linux/fs.h>,," \
+ ${WRKSRC}/onmainwindow.cpp
+ ${REINPLACE_CMD} -e "s,linux,freebsd," ${WRKSRC}/x2goclient.pro
+
+do-configure:
+ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${QMAKE}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/x2goclient ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/x2goclient/distinfo b/net/x2goclient/distinfo
new file mode 100644
index 000000000000..f4aaecc7f085
--- /dev/null
+++ b/net/x2goclient/distinfo
@@ -0,0 +1,3 @@
+MD5 (x2goclient_3.01-5.tar.gz) = 7d089fc3ad14b4cd0bf460a53641333d
+SHA256 (x2goclient_3.01-5.tar.gz) = ce671a628b17614bdcf443bd5ff22f644ceca1dad634c8823fcad8438a3751e3
+SIZE (x2goclient_3.01-5.tar.gz) = 10274153
diff --git a/net/x2goclient/pkg-descr b/net/x2goclient/pkg-descr
new file mode 100644
index 000000000000..0cafcc020b0d
--- /dev/null
+++ b/net/x2goclient/pkg-descr
@@ -0,0 +1,3 @@
+QT client for x2go
+
+WWW: http://www.x2go.org/