aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-07-08 15:21:04 +0800
committervs <vs@FreeBSD.org>2004-07-08 15:21:04 +0800
commit2049e92365d474fe3a8f004e4df695752c04beb8 (patch)
treecf24490c4a028924266a10029cb42fe4a50c5387
parent46fd19b54d49f84836e30bbc2f3a054683bd4594 (diff)
downloadfreebsd-ports-gnome-2049e92365d474fe3a8f004e4df695752c04beb8.tar.gz
freebsd-ports-gnome-2049e92365d474fe3a8f004e4df695752c04beb8.tar.zst
freebsd-ports-gnome-2049e92365d474fe3a8f004e4df695752c04beb8.zip
Don't try to use lang/chicken if present.
PR: ports/64142 Submitted by: Kimura Fuyuki Approved by: maintainer timeout
-rw-r--r--devel/swig13/Makefile4
-rw-r--r--devel/swig20/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 064f85288911..e2d3bee24811 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -95,6 +95,7 @@ PLIST_SUB+= WANT_SWIG_JAVA="@comment "
CONFIGURE_ARGS += --without-java
.endif
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/${DISTNAME:U}
USE_LIBTOOL_VER= 13
@@ -108,6 +109,9 @@ PLIST_SUB+= VER="${VER}"
BROKEN= "Build fails on sparc64"
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/' ${WRKSRC}/configure
+
post-install:
# A separate swig13-runtime port might be nice
@(cd ${INSTALL_WRKSRC}/Runtime && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
index 064f85288911..e2d3bee24811 100644
--- a/devel/swig20/Makefile
+++ b/devel/swig20/Makefile
@@ -95,6 +95,7 @@ PLIST_SUB+= WANT_SWIG_JAVA="@comment "
CONFIGURE_ARGS += --without-java
.endif
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/${DISTNAME:U}
USE_LIBTOOL_VER= 13
@@ -108,6 +109,9 @@ PLIST_SUB+= VER="${VER}"
BROKEN= "Build fails on sparc64"
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/' ${WRKSRC}/configure
+
post-install:
# A separate swig13-runtime port might be nice
@(cd ${INSTALL_WRKSRC}/Runtime && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})