aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-02 06:34:14 +0800
committermiwi <miwi@FreeBSD.org>2008-06-02 06:34:14 +0800
commit21e8df526e3a088235fce34a0fa72b7f60399b30 (patch)
tree3e6e54547f7447b19a272c3e941a955d0043b741
parent0ee379ed966562f7eb65971f11a5b3e4debc9b45 (diff)
downloadfreebsd-ports-gnome-21e8df526e3a088235fce34a0fa72b7f60399b30.tar.gz
freebsd-ports-gnome-21e8df526e3a088235fce34a0fa72b7f60399b30.tar.zst
freebsd-ports-gnome-21e8df526e3a088235fce34a0fa72b7f60399b30.zip
pyexiv2 is a python binding to exiv2, the C++ library for manipulation of
EXIF and IPTC image metadata. It is a python module that allows your python scripts to read and write metadata (EXIF, IPTC, thumbnail) embedded in image files (JPEG, TIFF, ...). It is designed as a high level interface to the functionalities offered by exiv2 (and is built on top of it). Using python's built-in data types and standard modules, it provides easy manipulation of image metadata. WWW: http://tilloy.net/dev/pyexiv2/ PR: ports/124193 Submitted by: Denis Barov <dindin at dindin.ru>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-exiv2/Makefile37
-rw-r--r--graphics/py-exiv2/distinfo3
-rw-r--r--graphics/py-exiv2/pkg-descr10
-rw-r--r--graphics/py-exiv2/pkg-plist2
5 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 539c74401f40..b244203a4a5e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -624,6 +624,7 @@
SUBDIR += py-chart
SUBDIR += py-editobj
SUBDIR += py-exif
+ SUBDIR += py-exiv2
SUBDIR += py-freeimagepy
SUBDIR += py-gd
SUBDIR += py-gdchart
diff --git a/graphics/py-exiv2/Makefile b/graphics/py-exiv2/Makefile
new file mode 100644
index 000000000000..4e1f5c4db53b
--- /dev/null
+++ b/graphics/py-exiv2/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-exiv2
+# Date created: 2008-06-01
+# Whom: Denis Barov <dindin@dindin.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exiv2
+PORTVERSION= 0.1.2
+CATEGORIES= graphics python
+MASTER_SITES= http://tilloy.net/dev/pyexiv2/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= dindin@dindin.ru
+COMMENT= Python bindings for exiv2
+
+LIB_DEPENDS= exiv2.3:${PORTSDIR}/graphics/exiv2\
+ boost_python.4:${PORTSDIR}/devel/boost-python
+
+WRKSRC= ${WRKDIR}/py${PORTNAME}
+USE_PYTHON= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_SCONS= yes
+USE_LDCONFIG= yes
+SCONS_ENV+= PREFIX=${PREFIX} CPPPATH=${PREFIX}/inlude LIBPATH=${PREFIX}/lib
+SCONS_BUILDENV= ${SCONS_ENV}
+SCONS_ARGS+= prefix=${PREFIX} use_env=1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|python_inc_path\]|python_inc_path,\
+ "${PREFIX}/include"\]|' -e 's|LIBS=libs|LIBS=libs,\
+ LIBPATH=\"${PREFIX}/lib\"|'\
+ ${WRKSRC}/src/SConscript
+
+.include <bsd.port.mk>
diff --git a/graphics/py-exiv2/distinfo b/graphics/py-exiv2/distinfo
new file mode 100644
index 000000000000..2a54229515eb
--- /dev/null
+++ b/graphics/py-exiv2/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyexiv2-0.1.2.tar.bz2) = 246dae9b4eca5d2fe2a4e3762e13fac1
+SHA256 (pyexiv2-0.1.2.tar.bz2) = b28109f0607b5c3f020e73274a540e5f19ce8b164a9953d0ff2f9229764d7ae2
+SIZE (pyexiv2-0.1.2.tar.bz2) = 35796
diff --git a/graphics/py-exiv2/pkg-descr b/graphics/py-exiv2/pkg-descr
new file mode 100644
index 000000000000..e0c60d649185
--- /dev/null
+++ b/graphics/py-exiv2/pkg-descr
@@ -0,0 +1,10 @@
+pyexiv2 is a python binding to exiv2, the C++ library for manipulation of
+EXIF and IPTC image metadata. It is a python module that allows your python
+scripts to read and write metadata (EXIF, IPTC, thumbnail) embedded in image
+files (JPEG, TIFF, ...).
+
+It is designed as a high level interface to the functionalities offered by
+exiv2 (and is built on top of it). Using python's built-in data types and
+standard modules, it provides easy manipulation of image metadata.
+
+WWW: http://tilloy.net/dev/pyexiv2/
diff --git a/graphics/py-exiv2/pkg-plist b/graphics/py-exiv2/pkg-plist
new file mode 100644
index 000000000000..65351d01ff70
--- /dev/null
+++ b/graphics/py-exiv2/pkg-plist
@@ -0,0 +1,2 @@
+%%PYTHON_SITELIBDIR%%/libpyexiv2.so
+%%PYTHON_SITELIBDIR%%/pyexiv2.py