aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-02-26 14:27:37 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-02-26 14:27:37 +0800
commit22746070ff82e50bd5cc00d448dbced9aeb8db32 (patch)
tree0d834cd2c89feb5f25a34226688dcfca5cadc631
parentb542b52df1f4df2ecd90a9726b46a4e67f8528ac (diff)
downloadfreebsd-ports-gnome-22746070ff82e50bd5cc00d448dbced9aeb8db32.tar.gz
freebsd-ports-gnome-22746070ff82e50bd5cc00d448dbced9aeb8db32.tar.zst
freebsd-ports-gnome-22746070ff82e50bd5cc00d448dbced9aeb8db32.zip
This module provides conversions between commonly used ways to express
colors. It provides conversions between color spaces such as RGB and HSV, and it provides ways to look up colors by a name. This class provides a base for subclasses which represent particular color values in particular spaces. The base class provides methods to represent the color in a few convenient forms, though subclasses may provide more specific details for the space in question. WWW: http://search.cpan.org/dist/Convert-Color/
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Convert-Color/Makefile34
-rw-r--r--graphics/p5-Convert-Color/distinfo2
-rw-r--r--graphics/p5-Convert-Color/pkg-descr10
-rw-r--r--graphics/p5-Convert-Color/pkg-plist16
5 files changed, 63 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d31a3b91b4b5..3ecd5849e791 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -615,6 +615,7 @@
SUBDIR += p5-Color-Palette
SUBDIR += p5-Color-Rgb
SUBDIR += p5-Color-Scheme
+ SUBDIR += p5-Convert-Color
SUBDIR += p5-GD
SUBDIR += p5-GD-Arrow
SUBDIR += p5-GD-Barcode
diff --git a/graphics/p5-Convert-Color/Makefile b/graphics/p5-Convert-Color/Makefile
new file mode 100644
index 000000000000..98402ec204f3
--- /dev/null
+++ b/graphics/p5-Convert-Color/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Convert::Color
+# Date created: 26 Feb 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Convert-Color
+PORTVERSION= 0.07
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for color space conversions and named lookups
+
+RUN_DEPENDS= \
+ p5-List-UtilsBy>0:${PORTSDIR}/devel/p5-List-UtilsBy
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Convert::Color.3 \
+ Convert::Color::CMY.3 \
+ Convert::Color::CMYK.3 \
+ Convert::Color::HSL.3 \
+ Convert::Color::HSV.3 \
+ Convert::Color::RGB.3 \
+ Convert::Color::RGB16.3 \
+ Convert::Color::RGB8.3 \
+ Convert::Color::VGA.3 \
+ Convert::Color::X11.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Convert-Color/distinfo b/graphics/p5-Convert-Color/distinfo
new file mode 100644
index 000000000000..b2c19e23382f
--- /dev/null
+++ b/graphics/p5-Convert-Color/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Convert-Color-0.07.tar.gz) = d9a015c5e6a06fbb655f11b55c35c54fc940736521fea2e1ca4f1c8bb9db6cfb
+SIZE (Convert-Color-0.07.tar.gz) = 32387
diff --git a/graphics/p5-Convert-Color/pkg-descr b/graphics/p5-Convert-Color/pkg-descr
new file mode 100644
index 000000000000..c9b021790570
--- /dev/null
+++ b/graphics/p5-Convert-Color/pkg-descr
@@ -0,0 +1,10 @@
+This module provides conversions between commonly used ways to express
+colors. It provides conversions between color spaces such as RGB and
+HSV, and it provides ways to look up colors by a name.
+
+This class provides a base for subclasses which represent particular
+color values in particular spaces. The base class provides methods to
+represent the color in a few convenient forms, though subclasses may
+provide more specific details for the space in question.
+
+WWW: http://search.cpan.org/dist/Convert-Color/
diff --git a/graphics/p5-Convert-Color/pkg-plist b/graphics/p5-Convert-Color/pkg-plist
new file mode 100644
index 000000000000..73a24b34f211
--- /dev/null
+++ b/graphics/p5-Convert-Color/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Convert/Color/.packlist
+%%SITE_PERL%%/Convert/Color.pm
+%%SITE_PERL%%/Convert/Color/CMY.pm
+%%SITE_PERL%%/Convert/Color/CMYK.pm
+%%SITE_PERL%%/Convert/Color/HSL.pm
+%%SITE_PERL%%/Convert/Color/HSV.pm
+%%SITE_PERL%%/Convert/Color/HueBased.pm
+%%SITE_PERL%%/Convert/Color/RGB.pm
+%%SITE_PERL%%/Convert/Color/RGB16.pm
+%%SITE_PERL%%/Convert/Color/RGB8.pm
+%%SITE_PERL%%/Convert/Color/VGA.pm
+%%SITE_PERL%%/Convert/Color/X11.pm
+@dirrm %%SITE_PERL%%/Convert/Color
+@dirrmtry %%SITE_PERL%%/Convert
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Convert/Color
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Convert