aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-04-24 16:00:28 +0800
committerclsung <clsung@FreeBSD.org>2007-04-24 16:00:28 +0800
commit22b41420edc5bf092873fe170f89ca92e004bde2 (patch)
treef0e076be7500c27da33db7a07f0871ba287c5f4b
parentfc1ad93062d90acc3bcf04844d75fffc91883467 (diff)
downloadfreebsd-ports-gnome-22b41420edc5bf092873fe170f89ca92e004bde2.tar.gz
freebsd-ports-gnome-22b41420edc5bf092873fe170f89ca92e004bde2.tar.zst
freebsd-ports-gnome-22b41420edc5bf092873fe170f89ca92e004bde2.zip
Add aespipe , an AES encrypting or decrypting pipe.
PR: ports/112056 Submitted by: Ekkehard 'Ekki' Gehm <gehm at physik.tu-berlin.de>
-rw-r--r--security/Makefile1
-rw-r--r--security/aespipe/Makefile39
-rw-r--r--security/aespipe/distinfo3
-rw-r--r--security/aespipe/pkg-descr4
4 files changed, 47 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3fcb099acbef..c2de7775a2f2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -9,6 +9,7 @@
SUBDIR += aafid2
SUBDIR += acid
SUBDIR += aescrypt
+ SUBDIR += aespipe
SUBDIR += aide
SUBDIR += aimsniff
SUBDIR += altivore
diff --git a/security/aespipe/Makefile b/security/aespipe/Makefile
new file mode 100644
index 000000000000..2e94cb0ec44d
--- /dev/null
+++ b/security/aespipe/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: aespipe
+# Date created: 20 February 1007
+# Whom: Ekkehard 'Ekki' Gehm <gehm@physik.tu-berlin.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aespipe
+DISTVERSION= v2.3d
+CATEGORIES= security
+MASTER_SITES= http://loop-aes.sourceforge.net/${PORTNAME}/ \
+ http://koti.tnnet.fi/jari.ruusu/linux/
+
+MAINTAINER= gehm@physik.tu-berlin.de
+COMMENT= An AES encrypting or decrypting pipe
+
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+
+MAN1= aespipe.1
+
+USE_BZIP2= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=--mandir="${MANPREFIX}/man"
+PLIST_FILES= bin/aespipe
+
+.include <bsd.port.pre.mk>
+ALL_TARGET=
+.if ${ARCH} == amd64
+MAKE_ARGS= amd64
+.endif
+
+.if ${ARCH} == i386
+MAKE_ARGS= x86
+.endif
+
+post-build:
+ cd ${WRKSRC} && make tests
+.include <bsd.port.post.mk>
diff --git a/security/aespipe/distinfo b/security/aespipe/distinfo
new file mode 100644
index 000000000000..92fb23ac66ca
--- /dev/null
+++ b/security/aespipe/distinfo
@@ -0,0 +1,3 @@
+MD5 (aespipe-v2.3d.tar.bz2) = 9b5369ab2c0d5439b7cd09d61d6ef479
+SHA256 (aespipe-v2.3d.tar.bz2) = 70330cd0710446c9ddf8148a7713fd73f1dc5e0b13fc4d3c75590305b2e3f008
+SIZE (aespipe-v2.3d.tar.bz2) = 88550
diff --git a/security/aespipe/pkg-descr b/security/aespipe/pkg-descr
new file mode 100644
index 000000000000..4229a02d107d
--- /dev/null
+++ b/security/aespipe/pkg-descr
@@ -0,0 +1,4 @@
+aespipe program is AES encrypting or decrypting pipe. It reads from standard
+input and writes to standard output. It can be used to create and restore
+encrypted tar or cpio archives. It can be used to encrypt and decrypt
+loop-AES compatible encrypted disk images.