aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-03 03:26:42 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-03 03:26:42 +0800
commit238db35e9f24b1dabfcf0671639e38bb3f94a8c2 (patch)
tree4083537f4ef06269119176f690fcf394b74d35dc
parent52f6bc049c5248a2e9448ced4a11a609aae49e81 (diff)
downloadfreebsd-ports-gnome-238db35e9f24b1dabfcf0671639e38bb3f94a8c2.tar.gz
freebsd-ports-gnome-238db35e9f24b1dabfcf0671639e38bb3f94a8c2.tar.zst
freebsd-ports-gnome-238db35e9f24b1dabfcf0671639e38bb3f94a8c2.zip
IPAcco is a free software package that helps a network admin
to collect, visualize and analyze IP accounting data from the Cisco routers. Cisco routers themselves are capable of collecting IP accounting information . i.e. an unordered set of IP source-destination pairs along with a byte and packet counters corresponding to all network traffic flows that passed through the router's interfaces. These data can be a useful source for various analysis procedures and billing systems but by itself, in their raw form they are rather difficult to read and understand. In addition, a router cannot keep a lot of data . its memory is needed for purposes other than remembering what traffic, from what sources and where it forwarded two month ago. WWW: http://ipacco.sourceforge.net/ - Babak Farrokhi babak@farrokhi.net PR: ports/99451 Submitted by: Babak Farrokhi <babak@farrokhi.net>
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/ipacco/Makefile68
-rw-r--r--net-mgmt/ipacco/distinfo3
-rw-r--r--net-mgmt/ipacco/files/pkg-message.in20
-rw-r--r--net-mgmt/ipacco/pkg-descr18
-rw-r--r--net-mgmt/ipacco/pkg-plist59
6 files changed, 169 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 9fc2d0397e11..fb71a4eb4a06 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -63,6 +63,7 @@
SUBDIR += ifgraph
SUBDIR += iftop
SUBDIR += iog
+ SUBDIR += ipacco
SUBDIR += ipacctd
SUBDIR += ipaudit
SUBDIR += ipcad
diff --git a/net-mgmt/ipacco/Makefile b/net-mgmt/ipacco/Makefile
new file mode 100644
index 000000000000..bc5414eb8a8e
--- /dev/null
+++ b/net-mgmt/ipacco/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: ipacco
+# Date created: 25 June 2006
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipacco
+PORTVERSION= 0.2.0.1
+CATEGORIES= net-mgmt www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ipacco
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Web based tool to analyze Cisco IP accounting data
+
+RUN_DEPENDS= ${LOCALBASE}/include/tclExtend.h:${PORTSDIR}/lang/tclX \
+ ${TCL_LIBDIR}/mysqltcl:${PORTSDIR}/databases/mysqltcl \
+ ${LOCALBASE}/lib/tcllib1.7/pkgIndex.tcl:${PORTSDIR}/devel/tcllib
+
+NO_BUILD= yes
+USE_PHP= mysql gd
+USE_TCL= yes
+
+IPACCO?= www/${PORTNAME}
+IPACCO_WEB= ${PREFIX}/${IPACCO}
+PLIST_SUB+= IPACCO_WEB=${IPACCO}
+SUB_LIST+= IPACCO_WEB=${IPACCO} \
+ PORTDOCS=${PORTDOCS} \
+ PORTNAME=${PORTNAME}
+
+SUB_FILES= pkg-message
+
+.if !defined(NOPORTDOCS)
+PORTDOCS1= INSTALL.html INSTALL.txt RELNOTES.html RELNOTES.txt
+PORTDOCS2= README.html README.txt LICENSE CreateDB.sql
+.endif
+
+pre-install:
+ @${FIND} ${WRKSRC} -name '*.bak' -type f -print0 | ${XARGS} -0 ${RM} -f
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/tclsh|${TCLSH}|' \
+ ${WRKSRC}/datapump/ipacco-datapump.tcl
+ @${REINPLACE_CMD} -e 's|\<?=|\<?php print|g' \
+ ${WRKSRC}/html/*.php
+
+do-install:
+ -@${MKDIR} ${IPACCO_WEB}
+ @${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ @${CP} -R ${WRKSRC}/html/* ${IPACCO_WEB}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${IPACCO_WEB}
+ @${INSTALL_DATA} ${WRKSRC}/datapump/ipacco-datapump.cfg \
+ ${PREFIX}/etc/${PORTNAME}
+ @${INSTALL_SCRIPT} ${WRKSRC}/datapump/ipacco-datapump.tcl \
+ ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS1}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+.endfor
+.for f in ${PORTDOCS2}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/ipacco/distinfo b/net-mgmt/ipacco/distinfo
new file mode 100644
index 000000000000..c37c96d87f31
--- /dev/null
+++ b/net-mgmt/ipacco/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipacco-0.2.0.1.tar.gz) = 4413b19275c3f0357e0d3e3d5cbdac45
+SHA256 (ipacco-0.2.0.1.tar.gz) = 8d91d783ea534f46c928f77d262962ccfb6e3ecd522c02f0262ac348bcc11636
+SIZE (ipacco-0.2.0.1.tar.gz) = 65754
diff --git a/net-mgmt/ipacco/files/pkg-message.in b/net-mgmt/ipacco/files/pkg-message.in
new file mode 100644
index 000000000000..1f444d718593
--- /dev/null
+++ b/net-mgmt/ipacco/files/pkg-message.in
@@ -0,0 +1,20 @@
+
+--------------------------------------------------
+
+1- Import database schema to your mysql:
+ mysql -u root -p < %%DOCSDIR%%%%PORTDOCS%%/CreateDB.sql
+
+2- Configure mysql parameters in
+ %%PREFIX%%/etc/%%PORTNAME%%/ipacco-datapump.cfg
+ and
+ %%PREFIX%%/%%IPACCO_WEB%%/SiteDefs.php
+
+3- Read the instructions and configure your cisco routers:
+ %%DOCSDIR%%/README.txt
+
+4- Add datapump agent to your /etc/crontab file:
+ */5 * * * * root %%PREFIX%%/sbin/ipacco-datapump.tcl \
+ -c %%PREFIX%%/etc/%%PORTNAME%%/ipacco-datapump.cfg > /dev/null 2>&1
+
+--------------------------------------------------
+
diff --git a/net-mgmt/ipacco/pkg-descr b/net-mgmt/ipacco/pkg-descr
new file mode 100644
index 000000000000..44010e371407
--- /dev/null
+++ b/net-mgmt/ipacco/pkg-descr
@@ -0,0 +1,18 @@
+IPAcco is a free software package that helps a network admin
+to collect, visualize and analyze IP accounting data from the
+Cisco routers.
+Cisco routers themselves are capable of collecting IP accounting
+information . i.e. an unordered set of IP source-destination
+pairs along with a byte and packet counters corresponding to all
+network traffic flows that passed through the router's interfaces.
+These data can be a useful source for various analysis procedures
+and billing systems but by itself, in their raw form they are
+rather difficult to read and understand. In addition, a router
+cannot keep a lot of data . its memory is needed for purposes
+other than remembering what traffic, from what sources and where
+it forwarded two month ago.
+
+WWW: http://ipacco.sourceforge.net/
+
+- Babak Farrokhi
+babak@farrokhi.net
diff --git a/net-mgmt/ipacco/pkg-plist b/net-mgmt/ipacco/pkg-plist
new file mode 100644
index 000000000000..dbb69a505485
--- /dev/null
+++ b/net-mgmt/ipacco/pkg-plist
@@ -0,0 +1,59 @@
+etc/ipacco/ipacco-datapump.cfg
+sbin/ipacco-datapump.tcl
+%%PORTDOCS%%%%DOCSDIR%%/CreateDB.sql
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.html
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/RELNOTES.html
+%%PORTDOCS%%%%DOCSDIR%%/RELNOTES.txt
+%%IPACCO_WEB%%/AddrCondition.php
+%%IPACCO_WEB%%/AddrFilter.php
+%%IPACCO_WEB%%/AddrGraph.php
+%%IPACCO_WEB%%/BrightnessPicker.php
+%%IPACCO_WEB%%/BrightnessSelector.php
+%%IPACCO_WEB%%/ByAddress.php
+%%IPACCO_WEB%%/ByTime.php
+%%IPACCO_WEB%%/ChangeSettings.php
+%%IPACCO_WEB%%/ColorBrightnessPicker.php
+%%IPACCO_WEB%%/ColorPicker.php
+%%IPACCO_WEB%%/ColorSelector.php
+%%IPACCO_WEB%%/Colors.php
+%%IPACCO_WEB%%/Globals.php
+%%IPACCO_WEB%%/Help.php
+%%IPACCO_WEB%%/IPAcco.css
+%%IPACCO_WEB%%/MainMenu.php
+%%IPACCO_WEB%%/PageBottom.php
+%%IPACCO_WEB%%/PageHeader.php
+%%IPACCO_WEB%%/PageMiddle.php
+%%IPACCO_WEB%%/PageTop.php
+%%IPACCO_WEB%%/ServerError.php
+%%IPACCO_WEB%%/Settings.php
+%%IPACCO_WEB%%/SiteDefs.php
+%%IPACCO_WEB%%/TimeGraph.php
+%%IPACCO_WEB%%/TimeSelector.php
+%%IPACCO_WEB%%/Utils.php
+%%IPACCO_WEB%%/help/AddressFiltering.html
+%%IPACCO_WEB%%/help/AddressGraph.html
+%%IPACCO_WEB%%/help/Overview.html
+%%IPACCO_WEB%%/help/Settings.html
+%%IPACCO_WEB%%/help/StatusPage.html
+%%IPACCO_WEB%%/help/TimeGraph.html
+%%IPACCO_WEB%%/help/TimeNavigation.html
+%%IPACCO_WEB%%/images/ArrowLeftButton.png
+%%IPACCO_WEB%%/images/ArrowLeftButtonDisabled.png
+%%IPACCO_WEB%%/images/ArrowRightButton.png
+%%IPACCO_WEB%%/images/ColorPicker.png
+%%IPACCO_WEB%%/images/MinusButton.png
+%%IPACCO_WEB%%/images/MinusButtonDisabled.png
+%%IPACCO_WEB%%/images/PlusButton.png
+%%IPACCO_WEB%%/images/php-power-black.gif
+%%IPACCO_WEB%%/images/poweredbymysql-88.png
+%%IPACCO_WEB%%/index.html
+%%IPACCO_WEB%%/index.php
+@dirrm %%IPACCO_WEB%%/images
+@dirrm %%IPACCO_WEB%%/help
+@dirrmtry %%IPACCO_WEB%%
+@dirrm etc/ipacco
+%%PORTDOCS%%@dirrm %%DOCSDIR%%