aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-02 23:20:05 +0800
committermiwi <miwi@FreeBSD.org>2014-02-02 23:20:05 +0800
commit23e4b9a68f3fbe803911a33381a3801ed45c4816 (patch)
tree38ca8eed91a0c1110a8b9ee4c1d0b377c7bfc16e
parenta164ca0372b1a8e972f781b01b0696bd7c30d498 (diff)
downloadfreebsd-ports-gnome-23e4b9a68f3fbe803911a33381a3801ed45c4816.tar.gz
freebsd-ports-gnome-23e4b9a68f3fbe803911a33381a3801ed45c4816.tar.zst
freebsd-ports-gnome-23e4b9a68f3fbe803911a33381a3801ed45c4816.zip
- Stage support
- Convert to USES
-rw-r--r--dns/libbind/Makefile6
-rw-r--r--dns/libbind/pkg-plist12
-rw-r--r--mail/pop3lite/Makefile5
-rw-r--r--mail/pop3lite/pkg-plist2
-rw-r--r--math/dieharder/Makefile3
-rw-r--r--math/dieharder/pkg-plist2
-rw-r--r--math/spar/Makefile3
-rw-r--r--math/spar/pkg-plist1
8 files changed, 18 insertions, 16 deletions
diff --git a/dns/libbind/Makefile b/dns/libbind/Makefile
index 58b18a320e1a..1ab55e6bfaaa 100644
--- a/dns/libbind/Makefile
+++ b/dns/libbind/Makefile
@@ -20,7 +20,6 @@ CONFIGURE_ARGS= --localstatedir=/var --with-randomdev=/dev/random
OPTIONS_DEFINE= IPV6 THREADS
OPTIONS_DEFAULT= IPV6 THREADS
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MIPV6}
@@ -35,11 +34,6 @@ CONFIGURE_ARGS+= --enable-threads
CONFIGURE_ARGS+= --disable-threads
.endif
-MAN3= getaddrinfo.3 gethostbyname.3 getipnodebyname.3 getnameinfo.3 \
- getnetent.3 hesiod.3 inet_cidr.3 resolver.3 tsig.3
-MAN5= resolver.5 irs.conf.5
-MAN7= hostname.7
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
diff --git a/dns/libbind/pkg-plist b/dns/libbind/pkg-plist
index acb4cd3ad2cc..5254d83beb16 100644
--- a/dns/libbind/pkg-plist
+++ b/dns/libbind/pkg-plist
@@ -23,6 +23,18 @@ include/bind/res_update.h
include/bind/resolv.h
include/bind/sys/bitypes.h
lib/libbind.a
+man/man3/getaddrinfo.3.gz
+man/man3/gethostbyname.3.gz
+man/man3/getipnodebyname.3.gz
+man/man3/getnameinfo.3.gz
+man/man3/getnetent.3.gz
+man/man3/hesiod.3.gz
+man/man3/inet_cidr.3.gz
+man/man3/resolver.3.gz
+man/man3/tsig.3.gz
+man/man5/irs.conf.5.gz
+man/man5/resolver.5.gz
+man/man7/hostname.7.gz
@dirrm include/bind/arpa
@dirrm include/bind/isc
@dirrm include/bind/sys
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index 45fc9cdf8921..d1e8e57c20f1 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -12,17 +12,14 @@ COMMENT= A flexible, modular RFC-compliant POP3 daemon
USE_AUTOTOOLS= libtool libltdl
USE_GNOME= glib12
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN5= pop3lite.conf.5
-MAN8= pop3lite.8
INFO= pop3lite-admin
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/configure
diff --git a/mail/pop3lite/pkg-plist b/mail/pop3lite/pkg-plist
index fe97d6aaee99..ff48c7209a6f 100644
--- a/mail/pop3lite/pkg-plist
+++ b/mail/pop3lite/pkg-plist
@@ -67,6 +67,8 @@ share/doc/pop3lite/modules/PAM
share/doc/pop3lite/modules/SABOTAGE
share/doc/pop3lite/modules/USERCONF
share/doc/pop3lite/modules/VHOST
+man/man5/pop3lite.conf.5.gz
+man/man8/pop3lite.8.gz
@dirrm include/pop3lite
@dirrm lib/pop3lite
@dirrm share/doc/pop3lite/modules
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index 931a73292cab..d6cd7b8624c3 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -22,10 +22,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-MAN1= dieharder.1
-MAN3= libdieharder.3
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
diff --git a/math/dieharder/pkg-plist b/math/dieharder/pkg-plist
index 3c868b83edf0..3c0bc0137a0b 100644
--- a/math/dieharder/pkg-plist
+++ b/math/dieharder/pkg-plist
@@ -50,4 +50,6 @@ lib/libdieharder.a
lib/libdieharder.la
lib/libdieharder.so
lib/libdieharder.so.3
+man/man1/dieharder.1.gz
+man/man3/libdieharder.3.gz
@dirrm include/dieharder
diff --git a/math/spar/Makefile b/math/spar/Makefile
index db9647551705..966314e3c05d 100644
--- a/math/spar/Makefile
+++ b/math/spar/Makefile
@@ -15,9 +15,6 @@ GNU_CONFIGURE= yes
USE_CSTD= gnu89
USE_LDCONFIG= yes
-MAN1= spar.1
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
diff --git a/math/spar/pkg-plist b/math/spar/pkg-plist
index 2fe3edee8849..7fd31032808d 100644
--- a/math/spar/pkg-plist
+++ b/math/spar/pkg-plist
@@ -42,6 +42,7 @@ lib/spar/zsolve_q.a
lib/spar/zsolve_q.la
lib/spar/zsolve_q.so
share/spar/modules_config
+man/man1/spar.1.gz
@dirrm include/spar
@dirrm lib/spar
@dirrm share/spar