aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-08-21 22:10:16 +0800
committerjkh <jkh@FreeBSD.org>1994-08-21 22:10:16 +0800
commit249e6a4e9c9a78f0be51b68171e2d0e048af391f (patch)
treef95d6835012b6845180e42141538f78ef69c6d6f
parentf30c6bcbfac8e07b5d16fcb120d52182ce0a9b9e (diff)
downloadfreebsd-ports-gnome-249e6a4e9c9a78f0be51b68171e2d0e048af391f.tar.gz
freebsd-ports-gnome-249e6a4e9c9a78f0be51b68171e2d0e048af391f.tar.zst
freebsd-ports-gnome-249e6a4e9c9a78f0be51b68171e2d0e048af391f.zip
Make any local configuration file unconditional. That is, if one exists
then run it even if GNU configure is to be run later. Submitted by: jkh
-rw-r--r--Mk/bsd.port.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index afb7777f915c..870ba1162a36 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id$
+# $Id: bsd.port.mk,v 1.1 1994/08/21 13:12:57 jkh Exp $
#
# Supported Variables and their behaviors:
@@ -103,13 +103,6 @@ configure: extract
patch -d ${WRKSRC} --quiet -E -p0 < $$i; \
done; \
fi
-.if defined(GNU_CONFIGURE)
-.if !defined(GNU_CONFIGURE_ARGS)
- @(cd ${WRKSRC}; ./configure i386--freebsd)
-.else !defined(GNU_CONFIGURE_ARGS)
- @(cd ${WRKSRC}; ./configure ${GNU_CONFIGURE_ARGS})
-.endif
-.endif
# We have a small convention for our local configure scripts, which
# is that ${.CURDIR} and the package working directory get passed as
# command-line arguments since all other methods are a little
@@ -117,6 +110,13 @@ configure: extract
@if [ -f ${SCRIPTDIR}/configure ]; then \
sh ${SCRIPTDIR}/configure ${.CURDIR} ${WRKSRC}; \
fi
+.if defined(GNU_CONFIGURE)
+.if !defined(GNU_CONFIGURE_ARGS)
+ @(cd ${WRKSRC}; ./configure i386--freebsd)
+.else !defined(GNU_CONFIGURE_ARGS)
+ @(cd ${WRKSRC}; ./configure ${GNU_CONFIGURE_ARGS})
+.endif
+.endif
.endif
.if !target(extract)