aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-08-04 03:12:16 +0800
committerlofi <lofi@FreeBSD.org>2007-08-04 03:12:16 +0800
commit25086e8b495b2303f160865d5de098c8003588b2 (patch)
tree9a184564a2fe2aaff193e8e3c1fcb5c2d11c0fb2
parent4c1a32ee349744502fc285d0893dd968eb6affac (diff)
downloadfreebsd-ports-gnome-25086e8b495b2303f160865d5de098c8003588b2.tar.gz
freebsd-ports-gnome-25086e8b495b2303f160865d5de098c8003588b2.tar.zst
freebsd-ports-gnome-25086e8b495b2303f160865d5de098c8003588b2.zip
Use QMAKEFLAGS to deuglify this port just a bit.
-rw-r--r--audio/last.fm/Makefile8
-rw-r--r--audio/last.fm/files/patch-configure33
2 files changed, 6 insertions, 35 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index c4a0ebb23f0a..f1b503a46326 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -33,10 +33,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GCC=4.2+
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|bash|sh|g' -e 's|qmake|${QMAKE}|g' \
+ -E -e 's|(.*"CONFIG-=debug")|\1 ${QMAKEFLAGS}|g' \
+ ${WRKSRC}/configure
+
post-build:
cd ${WRKSRC}/src/output/RtAudio && \
- ${QMAKE} -spec freebsd-g++ "QMAKE_CXX=${CXX}" "QMAKE_LINK=${CXX}" \
- "QMAKE_LINK_SHLIB=${CXX}" && make
+ ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} && make
${REINPLACE_CMD} -e 's|`dirname $$0`|${DATADIR}|g' \
${WRKSRC}/bin/last.fm
diff --git a/audio/last.fm/files/patch-configure b/audio/last.fm/files/patch-configure
deleted file mode 100644
index 59c31d6fee07..000000000000
--- a/audio/last.fm/files/patch-configure
+++ /dev/null
@@ -1,33 +0,0 @@
---- configure.orig 2007-07-05 18:41:23.000000000 +0200
-+++ configure 2007-08-03 00:10:40.000000000 +0200
-@@ -1,10 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
- echo -e '\E[0;34m'"\033[1mLast.fm-1.1.3 Configure\033[0m"
-
- echo "Checking for qmake..."
-
--qmake -v &> /dev/null
-+qmake-qt4 -v &> /dev/null
- if [[ $? = 127 ]]; then
- ################################################################################
- echo
-@@ -19,7 +19,7 @@
- # QMake version 2.01a
- # Using Qt version 4.2.2 in /opt/qt/4.2.2/lib
-
--qmake -v | grep '^Using Qt version 4.2' --color=never &> /dev/null
-+qmake-qt4 -v | grep '^Using Qt version 4.2' --color=never &> /dev/null
-
- if [[ $? > 0 ]]; then
- ################################################################################
-@@ -40,7 +40,7 @@
-
- echo "Generating Makefiles..."
-
--qmake -config release -after "CONFIG-=debug"
-+qmake-qt4 -config release -after "CONFIG-=debug" "INCLUDEPATH+=${X11BASE}/include" "QMAKE_CXXFLAGS+=-fPIC" "QMAKE_CXX=${CXX}" "QMAKE_LINK=${CXX}" "QMAKE_LINK_SHLIB=${CXX}"
-
- echo
- echo "Good, your configure is finished. Now type 'make'"