aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2008-11-04 16:36:54 +0800
committerlth <lth@FreeBSD.org>2008-11-04 16:36:54 +0800
commit269ab706ccfe45b9fa592b559eff8bc68b77e056 (patch)
treea16cbd45fc8dd699d578966f9ae20d91b5e8063a
parent6f8a6fd27552a2305597099df06a31c619f3b932 (diff)
downloadfreebsd-ports-gnome-269ab706ccfe45b9fa592b559eff8bc68b77e056.tar.gz
freebsd-ports-gnome-269ab706ccfe45b9fa592b559eff8bc68b77e056.tar.zst
freebsd-ports-gnome-269ab706ccfe45b9fa592b559eff8bc68b77e056.zip
Add p5-DBD-PgLite 0.09, PostgreSQL emulation mode for SQLite.
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBD-PgLite/Makefile30
-rw-r--r--databases/p5-DBD-PgLite/distinfo3
-rw-r--r--databases/p5-DBD-PgLite/pkg-descr6
-rw-r--r--databases/p5-DBD-PgLite/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7222ae6caa5b..023bec576235 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -256,6 +256,7 @@
SUBDIR += p5-DBD-ODBC
SUBDIR += p5-DBD-Oracle
SUBDIR += p5-DBD-Pg
+ SUBDIR += p5-DBD-PgLite
SUBDIR += p5-DBD-PgPP
SUBDIR += p5-DBD-PgSPI
SUBDIR += p5-DBD-SQLite
diff --git a/databases/p5-DBD-PgLite/Makefile b/databases/p5-DBD-PgLite/Makefile
new file mode 100644
index 000000000000..4b2034af9d19
--- /dev/null
+++ b/databases/p5-DBD-PgLite/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: databases/p5-DBD-PgLite
+# Date created: 03 November 2008
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-PgLite
+PORTVERSION= 0.09
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= PostgreSQL emulation mode for SQLite
+
+RUN_DEPENDS= p5-DBD-SQLite>=1.0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-Storable>=2.0:${PORTSDIR}/devel/p5-Storable \
+ p5-MIME-Base64>=2.0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Text-Iconv>=1.0:${PORTSDIR}/converters/p5-Text-Iconv \
+ p5-Digest-MD5>=2.0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-DBI>=1.30:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBD::PgLite.3 \
+ DBD::PgLite::MirrorPgToSQLite.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-PgLite/distinfo b/databases/p5-DBD-PgLite/distinfo
new file mode 100644
index 000000000000..4a2ef0eb83c9
--- /dev/null
+++ b/databases/p5-DBD-PgLite/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBD-PgLite-0.09.tar.gz) = 4088712dda27f33bfb5f251414fab48d
+SHA256 (DBD-PgLite-0.09.tar.gz) = 058bb509db5d04d33d1edbc93c49091abe1175136897ac3526f618cbbe8b179e
+SIZE (DBD-PgLite-0.09.tar.gz) = 40502
diff --git a/databases/p5-DBD-PgLite/pkg-descr b/databases/p5-DBD-PgLite/pkg-descr
new file mode 100644
index 000000000000..93f00be90439
--- /dev/null
+++ b/databases/p5-DBD-PgLite/pkg-descr
@@ -0,0 +1,6 @@
+The module automatically and transparently transforms a broad range of
+SQL statements typical of PostgreSQL into a form suitable for use in
+SQLite. This involves both (a) parsing and filtering of the SQL; and
+(b) the addition of several PostgreSQL-compatible functions to SQLite.
+
+WWW: http://search.cpan.org/dist/DBD-PgLite/
diff --git a/databases/p5-DBD-PgLite/pkg-plist b/databases/p5-DBD-PgLite/pkg-plist
new file mode 100644
index 000000000000..45bd82614035
--- /dev/null
+++ b/databases/p5-DBD-PgLite/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DBD/PgLite.pm
+%%SITE_PERL%%/DBD/PgLite/MirrorPgToSQLite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/PgLite/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/PgLite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD
+@dirrmtry %%SITE_PERL%%/DBD/PgLite
+@dirrmtry %%SITE_PERL%%/DBD