aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-06-14 06:57:53 +0800
committersat <sat@FreeBSD.org>2007-06-14 06:57:53 +0800
commit299d5f82fe6f51ad754ee032491c6e1fbf499c3b (patch)
tree542ae2e2093e9f21d99760bf28ecaacc953fdb1b
parent6d99f444262c02f9709eebc2c0ab419efd2055d3 (diff)
downloadfreebsd-ports-gnome-299d5f82fe6f51ad754ee032491c6e1fbf499c3b.tar.gz
freebsd-ports-gnome-299d5f82fe6f51ad754ee032491c6e1fbf499c3b.tar.zst
freebsd-ports-gnome-299d5f82fe6f51ad754ee032491c6e1fbf499c3b.zip
- Set explicit paths for configure for faster execution and
non-standard-path-proofness Reported by: pointyhat via kris
-rw-r--r--net-mgmt/zabbix/Makefile13
-rw-r--r--net-mgmt/zabbix2/Makefile13
2 files changed, 16 insertions, 10 deletions
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index 012b175458b0..4861802f8ae1 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -28,7 +28,10 @@ USE_GMAKE= yes
USE_PHP= gd snmp sockets pcre bcmath
USE_RC_SUBR= zabbix_server.sh
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-agent --enable-server --with-net-snmp --with-jabber
+CONFIGURE_ARGS= --disable-agent --enable-server \
+ --with-net-snmp=${LOCALBASE}/bin/net-snmp-config \
+ --with-curl=${LOCALBASE}/bin/curl-config \
+ --with-jabber=${LOCALBASE}
MAKE_ARGS= ARCH=freebsd
SUB_FILES= pkg-message
@@ -36,7 +39,7 @@ SUB_FILES= pkg-message
.ifndef WITHOUT_LDAP
USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-ldap
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls \
sasl2.2:${PORTSDIR}/security/cyrus-sasl2
.endif
@@ -45,13 +48,13 @@ RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
.ifndef WITHOUT_MYSQL
USE_PHP+= mysql
-CONFIGURE_ARGS+=--with-mysql
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/bin/mysql_config
.elifdef WITH_PGSQL
USE_PHP+= pgsql
-CONFIGURE_ARGS+=--with-pgsql
+CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/bin/pg_config
.elifdef WITH_SQLITE
USE_PHP+= sqlite
-CONFIGURE_ARGS+=--with-sqlite
+CONFIGURE_ARGS+=--with-sqlite=${LOCALBASE}
.else
IGNORE= zabbix needs a database backend
.endif
diff --git a/net-mgmt/zabbix2/Makefile b/net-mgmt/zabbix2/Makefile
index 012b175458b0..4861802f8ae1 100644
--- a/net-mgmt/zabbix2/Makefile
+++ b/net-mgmt/zabbix2/Makefile
@@ -28,7 +28,10 @@ USE_GMAKE= yes
USE_PHP= gd snmp sockets pcre bcmath
USE_RC_SUBR= zabbix_server.sh
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-agent --enable-server --with-net-snmp --with-jabber
+CONFIGURE_ARGS= --disable-agent --enable-server \
+ --with-net-snmp=${LOCALBASE}/bin/net-snmp-config \
+ --with-curl=${LOCALBASE}/bin/curl-config \
+ --with-jabber=${LOCALBASE}
MAKE_ARGS= ARCH=freebsd
SUB_FILES= pkg-message
@@ -36,7 +39,7 @@ SUB_FILES= pkg-message
.ifndef WITHOUT_LDAP
USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-ldap
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls \
sasl2.2:${PORTSDIR}/security/cyrus-sasl2
.endif
@@ -45,13 +48,13 @@ RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
.ifndef WITHOUT_MYSQL
USE_PHP+= mysql
-CONFIGURE_ARGS+=--with-mysql
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/bin/mysql_config
.elifdef WITH_PGSQL
USE_PHP+= pgsql
-CONFIGURE_ARGS+=--with-pgsql
+CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/bin/pg_config
.elifdef WITH_SQLITE
USE_PHP+= sqlite
-CONFIGURE_ARGS+=--with-sqlite
+CONFIGURE_ARGS+=--with-sqlite=${LOCALBASE}
.else
IGNORE= zabbix needs a database backend
.endif