aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-10 06:43:57 +0800
committermiwi <miwi@FreeBSD.org>2008-11-10 06:43:57 +0800
commit29b62b4c73c27e2e8f12ba742f8bbfd8ac90e6dc (patch)
tree0f119db1293de0df9a992fc4edbdfd9ed5629989
parent9585d28a4d004edf434248de85ef03275a6bdfb3 (diff)
downloadfreebsd-ports-gnome-29b62b4c73c27e2e8f12ba742f8bbfd8ac90e6dc.tar.gz
freebsd-ports-gnome-29b62b4c73c27e2e8f12ba742f8bbfd8ac90e6dc.tar.zst
freebsd-ports-gnome-29b62b4c73c27e2e8f12ba742f8bbfd8ac90e6dc.zip
Grit is a Ruby library for extracting information from a git repository in
an object oriented manner. Grit gives you object model access to your git repository. Once you have created a repository object, you can traverse it to find parent commit(s), trees, blobs, etc. This is the GitHub version of the grit gem called mojombo-grit. WWW: http://grit.rubyforge.org/ PR: ports/128736 Submitted by: Daniel Roethlisberger <daniel at roe.ch>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-mojombo-grit/Makefile32
-rw-r--r--devel/rubygem-mojombo-grit/distinfo3
-rw-r--r--devel/rubygem-mojombo-grit/pkg-descr8
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c45fb6fa3311..74d814d362ff 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2415,6 +2415,7 @@
SUBDIR += rubygem-json_pure
SUBDIR += rubygem-linecache
SUBDIR += rubygem-mocha
+ SUBDIR += rubygem-mojombo-grit
SUBDIR += rubygem-needle
SUBDIR += rubygem-open4
SUBDIR += rubygem-parsetree
diff --git a/devel/rubygem-mojombo-grit/Makefile b/devel/rubygem-mojombo-grit/Makefile
new file mode 100644
index 000000000000..c497dafcf364
--- /dev/null
+++ b/devel/rubygem-mojombo-grit/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: rubygem-mojombo-grit
+# Date created: 2008-11-05
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+
+PORTNAME= mojombo-grit
+PORTVERSION= 0.9.4
+CATEGORIES= devel rubygems
+MASTER_SITES= http://gems.github.com/${MASTER_SITE_SUBDIR}/
+MASTER_SITE_SUBDIR= gems
+
+MAINTAINER= daniel@roe.ch
+COMMENT= An object-oriented ruby library to access git repositories
+
+BUILD_DEPENDS= rubygem-open4>=0.0.0:${PORTSDIR}/devel/rubygem-open4 \
+ rubygem-diff-lcs>=0.0.0:${PORTSDIR}/textproc/rubygem-diff-lcs \
+ rubygem-mime-types>=0.0.0:${PORTSDIR}/misc/rubygem-mime-types
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-mojombo-grit/distinfo b/devel/rubygem-mojombo-grit/distinfo
new file mode 100644
index 000000000000..17618784ef6d
--- /dev/null
+++ b/devel/rubygem-mojombo-grit/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/mojombo-grit-0.9.4.gem) = a47d6821bb7a93b1e1823798e96bc952
+SHA256 (rubygem/mojombo-grit-0.9.4.gem) = 86540ca9d85d0941c354b72007c4eb471540c79a275337e6c100cef8654683d3
+SIZE (rubygem/mojombo-grit-0.9.4.gem) = 44544
diff --git a/devel/rubygem-mojombo-grit/pkg-descr b/devel/rubygem-mojombo-grit/pkg-descr
new file mode 100644
index 000000000000..ff3d734710a3
--- /dev/null
+++ b/devel/rubygem-mojombo-grit/pkg-descr
@@ -0,0 +1,8 @@
+Grit is a Ruby library for extracting information from a git repository in
+an object oriented manner. Grit gives you object model access to your git
+repository. Once you have created a repository object, you can traverse it
+to find parent commit(s), trees, blobs, etc.
+
+This is the GitHub version of the grit gem called mojombo-grit.
+
+WWW: http://grit.rubyforge.org/