aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2006-04-15 21:30:40 +0800
committervs <vs@FreeBSD.org>2006-04-15 21:30:40 +0800
commit2a4fa94b97e41d60f8b257ee191171f87e0df1ea (patch)
tree6d6cd761bcee7b2d40e7a5d3cf4fd847b960ad41
parentcb1bbbc727245ef8b0de7a1c575c2d61019aa72f (diff)
downloadfreebsd-ports-gnome-2a4fa94b97e41d60f8b257ee191171f87e0df1ea.tar.gz
freebsd-ports-gnome-2a4fa94b97e41d60f8b257ee191171f87e0df1ea.tar.zst
freebsd-ports-gnome-2a4fa94b97e41d60f8b257ee191171f87e0df1ea.zip
Update to 2.2.0. nhc support seems broken atm.
PR: ports/95587 Submitted by: Václav Haisman
-rw-r--r--devel/hs-drift/Makefile7
-rw-r--r--devel/hs-drift/distinfo6
-rw-r--r--devel/hs-drift/files/patch-src::GenUtil.hs11
3 files changed, 7 insertions, 17 deletions
diff --git a/devel/hs-drift/Makefile b/devel/hs-drift/Makefile
index ff90ac344316..b7cb8f425b30 100644
--- a/devel/hs-drift/Makefile
+++ b/devel/hs-drift/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= drift
-PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= devel haskell
MASTER_SITES= http://repetae.net/john/computer/haskell/DrIFT/drop/
PKGNAMEPREFIX= hs-
@@ -24,9 +23,11 @@ OPTIONS= NHC98 "Build with nhc98" off \
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
.else
BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
+BROKEN= Does not build
.endif
-HAS_CONFIGURE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
INFO= drift
PLIST_FILES= bin/DrIFT bin/drift-ghc
diff --git a/devel/hs-drift/distinfo b/devel/hs-drift/distinfo
index df0ffb3f19bf..765515371324 100644
--- a/devel/hs-drift/distinfo
+++ b/devel/hs-drift/distinfo
@@ -1,3 +1,3 @@
-MD5 (DrIFT-2.1.0.tar.gz) = 14d7ca6264412cb0f69f14e96e8c89c6
-SHA256 (DrIFT-2.1.0.tar.gz) = 7202d4692a4e4df03c8498ab15006ce3b0a8182e0b29db691d46d5ccd1d48c95
-SIZE (DrIFT-2.1.0.tar.gz) = 240714
+MD5 (DrIFT-2.2.0.tar.gz) = 403f8449d763df40a3bdc6b027de1845
+SHA256 (DrIFT-2.2.0.tar.gz) = ae24a61a4ca2f81e9f033ce6cc08b2f5f5239de11c53aa677b3de62da4f97406
+SIZE (DrIFT-2.2.0.tar.gz) = 252043
diff --git a/devel/hs-drift/files/patch-src::GenUtil.hs b/devel/hs-drift/files/patch-src::GenUtil.hs
deleted file mode 100644
index 2782535f8450..000000000000
--- a/devel/hs-drift/files/patch-src::GenUtil.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/GenUtil.hs.orig Thu Dec 2 09:16:02 2004
-+++ src/GenUtil.hs Thu Dec 2 09:16:33 2004
-@@ -85,7 +85,7 @@
- import Monad
- import qualified IO
- import qualified System
--import Random(StdGen, newStdGen, randomR)
-+import Random(StdGen, newStdGen, Random(randomR))
- import Time
-
- {-# SPECIALIZE snub :: [String] -> [String] #-}