aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-09-03 16:12:21 +0800
committerdinoex <dinoex@FreeBSD.org>2002-09-03 16:12:21 +0800
commit2c25984f45d79fb6b3c5b7d420f2f6983a940c5e (patch)
tree3924a14f60b7e59531692e54e27131ab30171179
parent7e47e006fe0ce4e86c4ae59812d74348500d4984 (diff)
downloadfreebsd-ports-gnome-2c25984f45d79fb6b3c5b7d420f2f6983a940c5e.tar.gz
freebsd-ports-gnome-2c25984f45d79fb6b3c5b7d420f2f6983a940c5e.tar.zst
freebsd-ports-gnome-2c25984f45d79fb6b3c5b7d420f2f6983a940c5e.zip
Support APACHE_PORT to build with desired apache13* port.
Reviewed by: knu
-rw-r--r--www/mod_ruby/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index 3eebd17ac2c7..24872b47d25e 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -13,9 +13,9 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
LIB_DEPENDS= eruby.09:${PORTSDIR}/textproc/eruby
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
USE_RUBY= yes
.if !defined(NOPORTDOCS)
@@ -23,6 +23,7 @@ USE_RUBY_RD= yes
.endif
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
CONFIGURE_ARGS= --with-apxs="${APXS}" \
--enable-eruby=yes \