aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2010-07-03 22:15:17 +0800
committerarved <arved@FreeBSD.org>2010-07-03 22:15:17 +0800
commit2caba90e6e23ad5e42db57de72a4b5fd544f117d (patch)
tree5c3af51f7f90af2b7f3e44e0e3183b35f097df11
parent6fbf2fc9ed88ba6a49ab7299cc148a9aa14e284c (diff)
downloadfreebsd-ports-gnome-2caba90e6e23ad5e42db57de72a4b5fd544f117d.tar.gz
freebsd-ports-gnome-2caba90e6e23ad5e42db57de72a4b5fd544f117d.tar.zst
freebsd-ports-gnome-2caba90e6e23ad5e42db57de72a4b5fd544f117d.zip
Respect CXXFLAGS
Make port profit from MAKE_JOBS PR: 148109 Requested by: Anonymous <swell.k@gmail.com> Feature safe: yes
-rw-r--r--audio/ladspa/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
index f5baf9596435..5ec467b61bc0 100644
--- a/audio/ladspa/Makefile
+++ b/audio/ladspa/Makefile
@@ -23,13 +23,15 @@ USE_LDCONFIG= yes
PROGRAM_FILES= analyseplugin applyplugin listplugins
PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
PLUGIN_DIR?= ${PREFIX}/lib/ladspa/
+MAKEFILE= makefile
+ALL_TARGET= targets
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_JOBS_SAFE= yes
post-patch:
${REINPLACE_CMD} -e 's,-ldl,,; s,-O3,${CFLAGS},; \
- s,^CC,#CC,;s,^CPP,#CPP,;s,CPP,CXX,' ${WRKSRC}/src/makefile
-
-do-build:
- cd ${WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} -f makefile targets
+ s,^CC,#CC,;s,^CPP,#CPP,;s,CPP,CXX,; s,^CXXFLAGS.*=,CXXFLAGS+=,' \
+ ${WRKSRC}/src/makefile
do-install:
@${INSTALL_DATA} ${WRKSRC}/src/ladspa.h ${PREFIX}/include