aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2007-07-30 12:40:53 +0800
committerchinsan <chinsan@FreeBSD.org>2007-07-30 12:40:53 +0800
commit2d7ec6aea865699601fff973c159c09df07755a7 (patch)
tree24ff5a5c0e4808f3829757d54579138a6b1575c4
parente36be09afdeb3aa30aa4c7d11f74b6446525003c (diff)
downloadfreebsd-ports-gnome-2d7ec6aea865699601fff973c159c09df07755a7.tar.gz
freebsd-ports-gnome-2d7ec6aea865699601fff973c159c09df07755a7.tar.zst
freebsd-ports-gnome-2d7ec6aea865699601fff973c159c09df07755a7.zip
Add termatrix, emulates Matrix terminal's "green tears" effect.
Approved by: rafan (mentor, implicit)
-rw-r--r--misc/Makefile1
-rw-r--r--misc/termatrix/Makefile31
-rw-r--r--misc/termatrix/distinfo3
-rw-r--r--misc/termatrix/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index cddab5c52dae..9d5634445d0f 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -443,6 +443,7 @@
SUBDIR += telbook
SUBDIR += tellico
SUBDIR += tempcontrol
+ SUBDIR += termatrix
SUBDIR += terraform
SUBDIR += tet
SUBDIR += thailocale
diff --git a/misc/termatrix/Makefile b/misc/termatrix/Makefile
new file mode 100644
index 000000000000..e4fb12749aec
--- /dev/null
+++ b/misc/termatrix/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: termatrix
+# Date created: 2007/07/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= termatrix
+PORTVERSION= 0.2
+CATEGORIES= misc
+MASTER_SITES= LOCAL/chinsan \
+ http://lightless.org/files/
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Emulates Matrix terminal's "green tears" effect
+
+PLIST_FILES= bin/termatrix
+PORTDOCS= README
+
+do-build:
+ ${CC} ${CFLAGS} ${CPPFLAGS} -o ${WRKSRC}/termatrix \
+ ${WRKSRC}/termatrix.c ${LDFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/termatrix ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/termatrix/distinfo b/misc/termatrix/distinfo
new file mode 100644
index 000000000000..249037fb07ce
--- /dev/null
+++ b/misc/termatrix/distinfo
@@ -0,0 +1,3 @@
+MD5 (termatrix-0.2.tar.gz) = bd27aabb2d6b0ae8c23e02464249c042
+SHA256 (termatrix-0.2.tar.gz) = 284821c5bcf743426b7490497b65e7b3025f333eba36f07d8cc84f23f0f85e06
+SIZE (termatrix-0.2.tar.gz) = 8139
diff --git a/misc/termatrix/pkg-descr b/misc/termatrix/pkg-descr
new file mode 100644
index 000000000000..870789d1de36
--- /dev/null
+++ b/misc/termatrix/pkg-descr
@@ -0,0 +1,4 @@
+This little software emulates "The Matrix" on your VT-100 compatible
+terminal 8^).
+
+WWW: http://lightless.org/other/