aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-05-06 23:09:22 +0800
committermiwi <miwi@FreeBSD.org>2017-05-06 23:09:22 +0800
commit2fa2703496652e20738105e98b965e023e590e46 (patch)
treef334e9537dbfa0b914398e3ef77b37620171ab91
parent689a591922a09e44db9ea34d8c2f1471f04bb109 (diff)
downloadfreebsd-ports-gnome-2fa2703496652e20738105e98b965e023e590e46.tar.gz
freebsd-ports-gnome-2fa2703496652e20738105e98b965e023e590e46.tar.zst
freebsd-ports-gnome-2fa2703496652e20738105e98b965e023e590e46.zip
The primary goal of scriptine is to make it easy to write shell scripts with
python. Features: * Easy command creation. Each command is just a function. * Automatic option parsing * Automatic help text (--help) * Log handling (with -v, --verbose and -q, --quiet handling) * Testing scripts in dry-mode. * Easy execution of other shell scripts. * Convenient working with files and directories. WWW: https://pypi.python.org/pypi/scriptine PR: 208066 Submitted by: dbaio@bsd.com.br
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-scriptine/Makefile19
-rw-r--r--sysutils/py-scriptine/distinfo3
-rw-r--r--sysutils/py-scriptine/pkg-descr14
4 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index bb6c8e1c42c8..c2eec2aa6634 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -890,6 +890,7 @@
SUBDIR += py-ranger
SUBDIR += py-salt
SUBDIR += py-scandir
+ SUBDIR += py-scriptine
SUBDIR += py-shutilwhich
SUBDIR += py-stdiff
SUBDIR += py-supervisor
diff --git a/sysutils/py-scriptine/Makefile b/sysutils/py-scriptine/Makefile
new file mode 100644
index 000000000000..31296643c9ac
--- /dev/null
+++ b/sysutils/py-scriptine/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= scriptine
+PORTVERSION= 0.2.1
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@bsd.com.br
+COMMENT= Python shell scripts made easy
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USES= python:-2.7
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-scriptine/distinfo b/sysutils/py-scriptine/distinfo
new file mode 100644
index 000000000000..98e9384fcc40
--- /dev/null
+++ b/sysutils/py-scriptine/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1472312198
+SHA256 (scriptine-0.2.1.tar.gz) = 4de06ce9b37ebed2d27150f9fd18c574692263d04f2432a20c457837e2c01477
+SIZE (scriptine-0.2.1.tar.gz) = 32563
diff --git a/sysutils/py-scriptine/pkg-descr b/sysutils/py-scriptine/pkg-descr
new file mode 100644
index 000000000000..f5bb965a506c
--- /dev/null
+++ b/sysutils/py-scriptine/pkg-descr
@@ -0,0 +1,14 @@
+The primary goal of scriptine is to make it easy to write shell scripts with
+python.
+
+Features:
+
+ * Easy command creation. Each command is just a function.
+ * Automatic option parsing
+ * Automatic help text (--help)
+ * Log handling (with -v, --verbose and -q, --quiet handling)
+ * Testing scripts in dry-mode.
+ * Easy execution of other shell scripts.
+ * Convenient working with files and directories.
+
+WWW: https://pypi.python.org/pypi/scriptine