aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-18 01:11:56 +0800
committerpgj <pgj@FreeBSD.org>2012-02-18 01:11:56 +0800
commit2fde56952fb86530a2ba6a4f80f3354f9d05b1ca (patch)
treee16bcc941e672a4585b9d5668b5ea4553dd27df8
parent26768404c62e06b788e554aecc36078c5787f0ea (diff)
downloadfreebsd-ports-gnome-2fde56952fb86530a2ba6a4f80f3354f9d05b1ca.tar.gz
freebsd-ports-gnome-2fde56952fb86530a2ba6a4f80f3354f9d05b1ca.tar.zst
freebsd-ports-gnome-2fde56952fb86530a2ba6a4f80f3354f9d05b1ca.zip
Unplug your machine and restart and have your app recover to exactly
where it left off. Happstack-State spares you the need to deal with all the marshalling, consistency, and configuration headache that you would have if you used an external DBMS for this purpose. Its component model makes it easy to compose big applications from smaller reliable parts. Use event subscription to trigger IO actions and support comet-style or irc-bot applications. WWW: http://happstack.com/ Obtained from: FreeBSD Haskell
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-happstack-state/Makefile23
-rw-r--r--www/hs-happstack-state/distinfo2
-rw-r--r--www/hs-happstack-state/pkg-descr9
5 files changed, 36 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 62aeeda2ff35..816d0cd2e0fa 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -100,6 +100,7 @@ haddock_port= devel/hs-haddock # executable
happstack-data_port= www/hs-happstack-data
happstack-ixset_port= www/hs-happstack-ixset
happstack-server_port= www/hs-happstack-server
+happstack-state_port= www/hs-happstack-state
happstack-util_port= www/hs-happstack-util
happy_port= devel/hs-happy # executable
hashable_port= devel/hs-hashable
diff --git a/www/Makefile b/www/Makefile
index 09f587e6244b..997408eea842 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -284,6 +284,7 @@
SUBDIR += hs-happstack-data
SUBDIR += hs-happstack-ixset
SUBDIR += hs-happstack-server
+ SUBDIR += hs-happstack-state
SUBDIR += hs-happstack-util
SUBDIR += hs-heist
SUBDIR += hs-fastcgi
diff --git a/www/hs-happstack-state/Makefile b/www/hs-happstack-state/Makefile
new file mode 100644
index 000000000000..673e7988fb65
--- /dev/null
+++ b/www/hs-happstack-state/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hs-happstack-state
+# Date created: December 2, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= happstack-state
+PORTVERSION= 6.1.2
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Event-based distributed state
+
+LICENSE= BSD
+FILE_LICENSE= COPYING
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= binary happstack-data>=6.0 happstack-util>=6.0 hslogger>=1.0.2 \
+ mtl>=1.1 stm>=2.1.2.2 syb
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-happstack-state/distinfo b/www/hs-happstack-state/distinfo
new file mode 100644
index 000000000000..b326bb61eb98
--- /dev/null
+++ b/www/hs-happstack-state/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/happstack-state-6.1.2.tar.gz) = 1d8e684fdbea79bc9cb87055d2c783412f74e87be3eb857793b1695bcec8388d
+SIZE (cabal/happstack-state-6.1.2.tar.gz) = 34207
diff --git a/www/hs-happstack-state/pkg-descr b/www/hs-happstack-state/pkg-descr
new file mode 100644
index 000000000000..44b1e6666fe6
--- /dev/null
+++ b/www/hs-happstack-state/pkg-descr
@@ -0,0 +1,9 @@
+Unplug your machine and restart and have your app recover to exactly
+where it left off. Happstack-State spares you the need to deal with all
+the marshalling, consistency, and configuration headache that you would
+have if you used an external DBMS for this purpose. Its component model
+makes it easy to compose big applications from smaller reliable parts.
+Use event subscription to trigger IO actions and support comet-style or
+irc-bot applications.
+
+WWW: http://happstack.com/