aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-09-05 03:49:41 +0800
committerultima <ultima@FreeBSD.org>2017-09-05 03:49:41 +0800
commit2fe3e1d557090966653fe39b8959cc52d8d07ae5 (patch)
treecfa99c4d6e1c7c06b48b73e8412b1bf9d354917d
parent9c6e38a70ba93811b6f94baf00b0add4ac2bad58 (diff)
downloadfreebsd-ports-gnome-2fe3e1d557090966653fe39b8959cc52d8d07ae5.tar.gz
freebsd-ports-gnome-2fe3e1d557090966653fe39b8959cc52d8d07ae5.tar.zst
freebsd-ports-gnome-2fe3e1d557090966653fe39b8959cc52d8d07ae5.zip
Updated to 6.1.2, cleanup makefiles, add note in UPDATING
Upstream has set collation type for MySQL to be implicit and will cause issues when updating if tables are not set to utf8_unicode_ci. Approved by: lifanov (mentor, implicit)
-rw-r--r--UPDATING8
-rw-r--r--net-mgmt/ccnet-server/Makefile15
-rw-r--r--net-mgmt/ccnet-server/distinfo6
-rw-r--r--net-mgmt/seafile-server/Makefile23
-rw-r--r--net-mgmt/seafile-server/Makefile.include2
-rw-r--r--net-mgmt/seafile-server/distinfo6
-rw-r--r--net-mgmt/seafile-server/pkg-plist1
7 files changed, 36 insertions, 25 deletions
diff --git a/UPDATING b/UPDATING
index 9f8673632704..2ec2d38cb815 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20170904
+ AFFECTS: users of net-mgmt/seafile-server
+ AUTHOR: ultima@FreeBSD.org
+
+ Users using MySQL updating to 6.1.2 need to verify table's collation
+ are utf8_unicode_ci. Upstream has set collation type to be implicit
+ and will cause all libraries to disappear if set to incorrect collation.
+
20170828
AFFECTS: users of security/gnupg
AUTHOR: adamw@FreeBSD.org
diff --git a/net-mgmt/ccnet-server/Makefile b/net-mgmt/ccnet-server/Makefile
index b357eb31b726..fa12ea2743b6 100644
--- a/net-mgmt/ccnet-server/Makefile
+++ b/net-mgmt/ccnet-server/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= ccnet-server
-PORTVERSION= ${SEAFILE_VER}
DISTVERSIONPREFIX= v
+DISTVERSION= ${SEAFILE_VER}
DISTVERSIONSUFFIX= -server
CATEGORIES= net-mgmt devel
@@ -20,22 +20,25 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
libevent.so:devel/libevent \
libjansson.so:devel/jansson
-CONFLICT= ccnet-[0-9]*
-
+USES= autoreconf libtool localbase mysql:client pathfix \
+ pgsql pkgconfig python:-2.7 shebangfix ssl
USE_GITHUB= yes
GH_ACCOUNT= haiwen
-
-USES= autoreconf gettext libtool localbase mysql:client \
- pathfix pgsql pkgconfig python:-2.7 shebangfix ssl
USE_GNOME= glib20
USE_LDCONFIG= yes
USE_OPENLDAP= yes
+CONFLICT= ccnet-[0-9]*
+
CONFIGURE_ENV= SSL_CFLAGS="${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-ldap
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= NLS
+
+NLS_USES= gettext
+
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${SEABIN} ${STAGEDIR}${PREFIX}/${SEALIB}
${INSTALL_PROGRAM} ${STAGEDIR}${PREFIX}/bin/ccnet-init ${STAGEDIR}${PREFIX}/${SEABIN}
diff --git a/net-mgmt/ccnet-server/distinfo b/net-mgmt/ccnet-server/distinfo
index 0dd891d994bf..40e0faa92993 100644
--- a/net-mgmt/ccnet-server/distinfo
+++ b/net-mgmt/ccnet-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1498236981
-SHA256 (haiwen-ccnet-server-v6.1.1-server_GH0.tar.gz) = 1cb84c8155d348f14b5af6e085640f1b42c523210d0f01216f04b3ad6a0e047e
-SIZE (haiwen-ccnet-server-v6.1.1-server_GH0.tar.gz) = 211230
+TIMESTAMP = 1502839888
+SHA256 (haiwen-ccnet-server-v6.1.2-server_GH0.tar.gz) = 582a4c72b9af7463dbe6f5af5e1c51e3210de93bf92db42f47e43e3887d9b61a
+SIZE (haiwen-ccnet-server-v6.1.2-server_GH0.tar.gz) = 211617
diff --git a/net-mgmt/seafile-server/Makefile b/net-mgmt/seafile-server/Makefile
index 635ec785b427..9568b568230b 100644
--- a/net-mgmt/seafile-server/Makefile
+++ b/net-mgmt/seafile-server/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= seafile-server
-PORTVERSION= ${SEAFILE_VER}
DISTVERSIONPREFIX= v
+DISTVERSION= ${SEAFILE_VER}
DISTVERSIONSUFFIX= -server
CATEGORIES= net-mgmt
@@ -28,31 +28,31 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
CONFLICTS= seafile-[0-9]*
+USES= autoreconf iconv libarchive libtool localbase mysql \
+ pathfix pgsql pkgconfig python:-2.7 shebangfix sqlite ssl
USE_GITHUB= yes
GH_ACCOUNT= haiwen
-
-USES= autoreconf gettext iconv libarchive libtool mysql pathfix \
- pgsql pkgconfig python:-2.7 shebangfix sqlite ssl
USE_GNOME= glib20
+USE_LDCONFIG= yes
+USE_RC_SUBR= seafile
+
SHEBANG_FILES= scripts/*.sh scripts/upgrade/*.sh *.sh scripts/build/*.py \
scripts/*.py scripts/upgrade/*.py tools/seafile-admin
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
CONFIGURE_ENV= SSL_CFLAGS="${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
PATHFIX_MAKEFILEIN= Makefile.am
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/evhtp
-LDFLAGS+= -L${LOCALBASE}/lib
-
-USE_RC_SUBR= seafile
+CPPFLAGS+= -I${LOCALBASE}/include/evhtp
SUB_FILES= pkg-message
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= FUSE
+OPTIONS_DEFINE= FUSE NLS
+OPTIONS_DEFAULT= FUSE
+OPTIONS_EXCLUDE_DragonFly= FUSE
OPTIONS_SUB= yes
FUSE_DESC= Use file system in userspace
@@ -60,8 +60,7 @@ FUSE_DESC= Use file system in userspace
FUSE_CONFIGURE_ENABLE= fuse
FUSE_LIB_DEPENDS= libfuse.so:sysutils/fusefs-libs
-OPTIONS_DEFAULT= FUSE
-OPTIONS_EXCLUDE_DragonFly= FUSE
+NLS_USES= gettext
.include <bsd.port.options.mk>
diff --git a/net-mgmt/seafile-server/Makefile.include b/net-mgmt/seafile-server/Makefile.include
index 1f73faf6f55c..608449aa29ed 100644
--- a/net-mgmt/seafile-server/Makefile.include
+++ b/net-mgmt/seafile-server/Makefile.include
@@ -1,6 +1,6 @@
# $FreeBSD$
-SEAFILE_VER=6.1.1
+SEAFILE_VER=6.1.2
SEAHUB_VER=6.1.7
diff --git a/net-mgmt/seafile-server/distinfo b/net-mgmt/seafile-server/distinfo
index b9fddf5b66f9..648e99a1960f 100644
--- a/net-mgmt/seafile-server/distinfo
+++ b/net-mgmt/seafile-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1498236981
-SHA256 (haiwen-seafile-server-v6.1.1-server_GH0.tar.gz) = e939f0d374961372f9a8bf8f34f2da6f190e1bb67f5a9b793d20e584c347e2fe
-SIZE (haiwen-seafile-server-v6.1.1-server_GH0.tar.gz) = 697896
+TIMESTAMP = 1502839888
+SHA256 (haiwen-seafile-server-v6.1.2-server_GH0.tar.gz) = 6a724e2db9d304906b34be11cc3236b580914ed284b1ab5548e92357d76035a6
+SIZE (haiwen-seafile-server-v6.1.2-server_GH0.tar.gz) = 701524
diff --git a/net-mgmt/seafile-server/pkg-plist b/net-mgmt/seafile-server/pkg-plist
index 0af382ba8d81..b4611c00adb2 100644
--- a/net-mgmt/seafile-server/pkg-plist
+++ b/net-mgmt/seafile-server/pkg-plist
@@ -4,6 +4,7 @@ include/seafile/seafile-object.h
libdata/pkgconfig/libseafile.pc
%%SEAFILE_SERVER%%/breakpad.py
%%SEAFILE_SERVER%%/check_init_admin.py
+%%SEAFILE_SERVER%%/export-users.sh
%%SEAFILE_SERVER%%/migrate-to-ceph.sh
%%SEAFILE_SERVER%%/reset-admin.sh
%%SEAFILE_SERVER%%/seaf-cli-wrapper.sh