aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-15 05:09:27 +0800
committerantoine <antoine@FreeBSD.org>2014-01-15 05:09:27 +0800
commit303975671640e3466ebf1545707f7f9fb181184b (patch)
tree34bbdf701d24de53a66912c84b4580f3e2ae28c9
parent568fd1b17f58900f940e261b6d1309f4489a7207 (diff)
downloadfreebsd-ports-gnome-303975671640e3466ebf1545707f7f9fb181184b.tar.gz
freebsd-ports-gnome-303975671640e3466ebf1545707f7f9fb181184b.tar.zst
freebsd-ports-gnome-303975671640e3466ebf1545707f7f9fb181184b.zip
- Fix build with clang
- Add LICENSE PR: ports/185697 Submitted by: KATO Tsuguru
-rw-r--r--net/libsocketcpp/Makefile5
-rw-r--r--net/libsocketcpp/files/patch-src::tcpservertest.cpp9
2 files changed, 12 insertions, 2 deletions
diff --git a/net/libsocketcpp/Makefile b/net/libsocketcpp/Makefile
index 5fb14dc09245..8324f3febccf 100644
--- a/net/libsocketcpp/Makefile
+++ b/net/libsocketcpp/Makefile
@@ -7,10 +7,11 @@ CATEGORIES= net
MASTER_SITES= SF/libsocket/${PORTNAME}-stable/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A C++ wrapper library to the sockets
+COMMENT= C++ wrapper library to the sockets
+
+LICENSE= LGPL21 # (or later)
USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/net/libsocketcpp/files/patch-src::tcpservertest.cpp b/net/libsocketcpp/files/patch-src::tcpservertest.cpp
index 16f672f4dd4a..2dcdfc1a999a 100644
--- a/net/libsocketcpp/files/patch-src::tcpservertest.cpp
+++ b/net/libsocketcpp/files/patch-src::tcpservertest.cpp
@@ -1,5 +1,14 @@
--- src/tcpservertest.cpp.orig 2012-12-03 14:28:35.000000000 +0100
+++ src/tcpservertest.cpp 2012-12-03 14:28:46.000000000 +0100
+@@ -22,7 +22,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <unistd.h>
+ #include <sys/wait.h>
+ #include <sys/types.h>
@@ -30,6 +30,7 @@
#include "tcpsocket.h"