aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2011-06-07 22:11:18 +0800
committerculot <culot@FreeBSD.org>2011-06-07 22:11:18 +0800
commit31dad903a283fe20fedb14a074b88c5a5cbfbe35 (patch)
tree466db4c83051b469574f95b5947cbb86ab389051
parent9661426875878c4261eec9fe0c3ea8f43ef2753a (diff)
downloadfreebsd-ports-gnome-31dad903a283fe20fedb14a074b88c5a5cbfbe35.tar.gz
freebsd-ports-gnome-31dad903a283fe20fedb14a074b88c5a5cbfbe35.tar.zst
freebsd-ports-gnome-31dad903a283fe20fedb14a074b88c5a5cbfbe35.zip
- Update to 0.15
PR: ports/157570 Submitted by: Peter Jeremy <peterjeremy@acm.org> (maintainer)
-rw-r--r--devel/mspdebug/Makefile2
-rw-r--r--devel/mspdebug/distinfo4
-rw-r--r--devel/mspdebug/files/patch-Makefile48
-rw-r--r--devel/mspdebug/files/patch-bsl.c6
-rw-r--r--devel/mspdebug/files/patch-elf32.c6
-rw-r--r--devel/mspdebug/files/patch-olimex.c22
-rw-r--r--devel/mspdebug/files/patch-rf2500.c22
-rw-r--r--devel/mspdebug/files/patch-uif.c47
8 files changed, 26 insertions, 131 deletions
diff --git a/devel/mspdebug/Makefile b/devel/mspdebug/Makefile
index 22b8b5bd3b2f..e782a2e0d93a 100644
--- a/devel/mspdebug/Makefile
+++ b/devel/mspdebug/Makefile
@@ -7,7 +7,7 @@
# Based on the OpenBSD port by: Jasper Lievisse Adriaanse <jasper@openbsd.org>
PORTNAME= mspdebug
-PORTVERSION= 0.13
+PORTVERSION= 0.15
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}
diff --git a/devel/mspdebug/distinfo b/devel/mspdebug/distinfo
index 6a5845286e35..ba1fe26c8bbd 100644
--- a/devel/mspdebug/distinfo
+++ b/devel/mspdebug/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mspdebug-0.13.tar.gz) = 7f77cbe2bab245cf50647a2bd23e803fe22e2d21a2b0953e0551ebf3e72fc48e
-SIZE (mspdebug-0.13.tar.gz) = 91556
+SHA256 (mspdebug-0.15.tar.gz) = ffdb1cdb34b81fd2a5eccd1c115f7d785837ef708b4b8816eb7a7b28f529bacb
+SIZE (mspdebug-0.15.tar.gz) = 108076
diff --git a/devel/mspdebug/files/patch-Makefile b/devel/mspdebug/files/patch-Makefile
index 05afbed99c84..7df5ca9315e1 100644
--- a/devel/mspdebug/files/patch-Makefile
+++ b/devel/mspdebug/files/patch-Makefile
@@ -1,47 +1,17 @@
---- Makefile.orig 2010-11-09 08:40:57.000000000 +1100
-+++ Makefile 2011-02-05 12:36:25.710676671 +1100
-@@ -26,17 +26,27 @@
- READLINE_LIBS =
- else
- READLINE_CFLAGS = -DUSE_READLINE
-- READLINE_LIBS = -lreadline
-+ READLINE_LIBS = -lreadline -ltermcap
- endif
-
--# Mac OS X/MacPorts stuff
- UNAME := $(shell sh -c 'uname -s')
--ifeq ($(UNAME),Darwin)
-- MACPORTS_CFLAGS = -I/opt/local/include
-- MACPORTS_LDFLAGS = -L/opt/local/lib
-+ifeq ($(UNAME),Darwin) # Mac OS X/MacPorts stuff
-+ PORTS_CFLAGS = -I/opt/local/include
-+ PORTS_LDFLAGS = -L/opt/local/lib
- else
-- MACPORTS_CFLAGS =
-- MACPORTS_LDFLAGS =
-+ ifeq ($(UNAME),OpenBSD) # OpenBSD Ports stuff
-+ PORTS_CFLAGS = `pkg-config --cflags libelf libusb`
-+ PORTS_LDFLAGS = `pkg-config --libs libelf libusb`
-+ else
+--- Makefile.orig 2011-04-05 06:22:54.000000000 +1000
++++ Makefile 2011-06-04 06:02:31.347404317 +1000
+@@ -38,8 +38,14 @@
+ PORTS_CFLAGS = `pkg-config --cflags libelf libusb`
+ PORTS_LDFLAGS = `pkg-config --libs libelf libusb` -ltermcap
+ else
+ ifeq ($(UNAME),FreeBSD) # FreeBSD Ports stuff
+# This is only needed prior to FreeBSD 8.x to find libusb
+ PORTS_CFLAGS = -I${LOCALBASE}/include
+ PORTS_LDFLAGS = -L${LOCALBASE}/lib
+ else
-+ PORTS_CFLAGS =
-+ PORTS_LDFLAGS =
+ PORTS_CFLAGS =
+ PORTS_LDFLAGS =
+ endif
-+ endif
+ endif
endif
- MSPDEBUG_CFLAGS = -O1 -Wall -Wno-char-subscripts -ggdb
-@@ -60,7 +70,7 @@
- reader.o vector.o output_util.o expr.o fet_error.o binfile.o \
- fet_db.o usbutil.o titext.o srec.o device.o coff.o opdb.o output.o \
- cmddb.o stdcmd.o prog.o flash_bsl.o
-- $(CC) $(LDFLAGS) $(MACPORTS_LDFLAGS) -o $@ $^ -lusb $(READLINE_LIBS)
-+ $(CC) $(LDFLAGS) $(PORTS_LDFLAGS) -o $@ $^ -lusb $(READLINE_LIBS)
-
- .c.o:
-- $(CC) $(CFLAGS) $(MACPORTS_CFLAGS) $(READLINE_CFLAGS) $(MSPDEBUG_CFLAGS) -o $@ -c $*.c
-+ $(CC) $(CFLAGS) $(PORTS_CFLAGS) $(READLINE_CFLAGS) $(MSPDEBUG_CFLAGS) -o $@ -c $*.c
diff --git a/devel/mspdebug/files/patch-bsl.c b/devel/mspdebug/files/patch-bsl.c
index bda5972d68d0..76384d561db3 100644
--- a/devel/mspdebug/files/patch-bsl.c
+++ b/devel/mspdebug/files/patch-bsl.c
@@ -1,10 +1,10 @@
---- bsl.c.orig Mon Nov 8 22:40:57 2010
-+++ bsl.c Thu Dec 2 13:05:14 2010
+--- bsl.c.orig 2011-04-05 06:22:54.000000000 +1000
++++ bsl.c 2011-06-04 06:02:31.326405250 +1000
@@ -31,7 +31,7 @@
#include "output.h"
#include "fet_error.h"
--#ifdef __APPLE__
+-#if defined(__APPLE__) || defined(__OpenBSD__)
+#if defined(__APPLE__) || defined(__OpenBSD__) || defined(__FreeBSD__)
#define B460800 460800
#endif
diff --git a/devel/mspdebug/files/patch-elf32.c b/devel/mspdebug/files/patch-elf32.c
index 495fa2b52a6a..6c8121d3b01e 100644
--- a/devel/mspdebug/files/patch-elf32.c
+++ b/devel/mspdebug/files/patch-elf32.c
@@ -1,10 +1,10 @@
---- elf32.c.orig Wed Aug 4 04:08:43 2010
-+++ elf32.c Thu Aug 12 12:51:04 2010
+--- elf32.c.orig 2011-04-05 06:22:54.000000000 +1000
++++ elf32.c 2011-06-04 06:02:31.313405042 +1000
@@ -19,7 +19,7 @@
#include <stdlib.h>
#include <errno.h>
#include <string.h>
--#ifdef __APPLE__
+-#if defined(__APPLE__) || defined(__OpenBSD__)
+#if defined(__APPLE__) || defined(__OpenBSD__) || defined(__FreeBSD__)
#include <libelf.h>
#else
diff --git a/devel/mspdebug/files/patch-olimex.c b/devel/mspdebug/files/patch-olimex.c
index 7d8baf177953..65a940aaff41 100644
--- a/devel/mspdebug/files/patch-olimex.c
+++ b/devel/mspdebug/files/patch-olimex.c
@@ -1,5 +1,5 @@
---- olimex.c.orig 2010-11-09 08:40:57.000000000 +1100
-+++ olimex.c 2011-01-23 20:52:02.005008013 +1100
+--- olimex.c.orig 2011-04-05 06:22:54.000000000 +1000
++++ olimex.c 2011-06-04 06:06:10.536246571 +1000
@@ -20,6 +20,7 @@
#include <stdio.h>
#include <string.h>
@@ -8,21 +8,3 @@
#include "olimex.h"
#include "util.h"
-@@ -66,7 +67,7 @@
- static int open_interface(struct olimex_transport *tr,
- struct usb_device *dev, int ino)
- {
--#if !(defined (__APPLE__) || defined(WIN32))
-+#if defined(__linux__)
- int drv;
- char drName[256];
- #endif
-@@ -82,7 +83,7 @@
- return -1;
- }
-
--#if !(defined(__APPLE__) || defined(WIN32))
-+#if defined(__linux__)
- drv = usb_get_driver_np(tr->handle, tr->int_number, drName,
- sizeof(drName));
- printc(__FILE__" : driver %d\n", drv);
diff --git a/devel/mspdebug/files/patch-rf2500.c b/devel/mspdebug/files/patch-rf2500.c
index e1c90920bb3b..df95b8eaed5f 100644
--- a/devel/mspdebug/files/patch-rf2500.c
+++ b/devel/mspdebug/files/patch-rf2500.c
@@ -1,5 +1,5 @@
---- rf2500.c.orig 2010-11-09 08:40:57.000000000 +1100
-+++ rf2500.c 2011-01-23 20:51:40.771589070 +1100
+--- rf2500.c.orig 2011-04-05 06:22:54.000000000 +1000
++++ rf2500.c 2011-06-04 06:06:10.562246150 +1000
@@ -19,6 +19,7 @@
#include <stdio.h>
#include <string.h>
@@ -8,21 +8,3 @@
#include "rf2500.h"
#include "util.h"
-@@ -67,7 +68,7 @@
- return -1;
- }
-
--#if !(defined(__APPLE__) || defined(WIN32))
-+#if !(defined(__APPLE__) || defined(WIN32) || defined(__OpenBSD__) || defined(__FreeBSD__))
- if (usb_detach_kernel_driver_np(tr->handle, tr->int_number) < 0)
- pr_error("rf2500: warning: can't "
- "detach kernel driver");
-@@ -221,7 +222,7 @@
- #ifndef __APPLE__
- while (usb_bulk_read(tr->handle, USB_FET_IN_EP,
- buf, sizeof(buf),
-- 100) >= 0);
-+ 100) > 0);
- #endif
-
- return (transport_t)tr;
diff --git a/devel/mspdebug/files/patch-uif.c b/devel/mspdebug/files/patch-uif.c
index 107393be56d5..b1c1d873908f 100644
--- a/devel/mspdebug/files/patch-uif.c
+++ b/devel/mspdebug/files/patch-uif.c
@@ -1,50 +1,11 @@
---- uif.c.orig Mon Nov 8 22:40:57 2010
-+++ uif.c Thu Dec 2 13:05:36 2010
-@@ -25,7 +25,9 @@
- #include <unistd.h>
- #include <termios.h>
-
-+#if defined(__linux__)
- #include <linux/serial.h>
-+#endif
- #include <sys/ioctl.h>
- #include <fcntl.h>
-
-@@ -33,7 +35,7 @@
+--- uif.c.orig 2011-04-05 06:22:54.000000000 +1000
++++ uif.c 2011-06-04 06:02:31.284404600 +1000
+@@ -36,7 +36,7 @@
#include "util.h"
#include "output.h"
--#ifdef __APPLE__
+-#if defined(__APPLE__) || defined(__OpenBSD__)
+#if defined(__APPLE__) || defined(__OpenBSD__) || defined(__FreeBSD__)
#define B460800 460800
#define B500000 500000
#endif
-@@ -85,6 +87,7 @@ static void serial_destroy(transport_t tr_base)
- free(tr);
- }
-
-+#if defined(__linux__)
- static int open_olimex_iso(const char *device)
- {
- int fd = open(device, O_RDWR | O_NOCTTY);
-@@ -112,6 +115,7 @@ static int open_olimex_iso(const char *device)
-
- return fd;
- }
-+#endif
-
- transport_t uif_open(const char *device, uif_type_t type)
- {
-@@ -138,8 +142,12 @@ transport_t uif_open(const char *device, uif_type_t ty
- break;
-
- case UIF_TYPE_OLIMEX_ISO:
-+#if defined(__linux__)
- printc("Trying to open Olimex (ISO) on %s...\n", device);
- tr->serial_fd = open_olimex_iso(device);
-+#else
-+ printc_err("uif_open: ioctl TIOCSSERIAL not supported on this platform\n");
-+#endif
- break;
- }
-