aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-05-06 15:28:37 +0800
committermiwi <miwi@FreeBSD.org>2017-05-06 15:28:37 +0800
commit3281b4511a7f3fd2b9bb5adeac1f505b99a7dafe (patch)
tree45ebcc5e6b26916be0afdad247396c639005f554
parent07bc083635f0cf9d8e1ec8a2ce75737aa04af103 (diff)
downloadfreebsd-ports-gnome-3281b4511a7f3fd2b9bb5adeac1f505b99a7dafe.tar.gz
freebsd-ports-gnome-3281b4511a7f3fd2b9bb5adeac1f505b99a7dafe.tar.zst
freebsd-ports-gnome-3281b4511a7f3fd2b9bb5adeac1f505b99a7dafe.zip
A lightweight header-only library to create Python bindings of existing
C++ code. Its goals and syntax are similar to the excellent Boost.Python library by David Abrahams: to minimize boilerplate code in traditional extension modules by inferring type information using compile-time introspection. WWW: https://github.com/wjakob/pybind11 PR: 214685 Submitted by: Yuri Victorovich <yuri@rawbw.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pybind11/Makefile19
-rw-r--r--devel/py-pybind11/distinfo3
-rw-r--r--devel/py-pybind11/pkg-descr7
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fd5b68650a32..c0a0dce3fa11 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4541,6 +4541,7 @@
SUBDIR += py-py
SUBDIR += py-pyasn1
SUBDIR += py-pyasn1-modules
+ SUBDIR += py-pybind11
SUBDIR += py-pycadf
SUBDIR += py-pycalendar
SUBDIR += py-pycallgraph
diff --git a/devel/py-pybind11/Makefile b/devel/py-pybind11/Makefile
new file mode 100644
index 000000000000..aef9a4c44e3d
--- /dev/null
+++ b/devel/py-pybind11/Makefile
@@ -0,0 +1,19 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pybind11
+PORTVERSION= 1.8.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Seamless interoperability between C++11 and Python
+
+LICENSE= BSD3CLAUSE
+
+USES= python:2
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pybind11/distinfo b/devel/py-pybind11/distinfo
new file mode 100644
index 000000000000..37e1eadc1189
--- /dev/null
+++ b/devel/py-pybind11/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479626622
+SHA256 (pybind11-1.8.1.tar.gz) = 358d4b7d8c38cd1dde66064178c6bbaaa2c479a44e67e642820fe0f329a4fff8
+SIZE (pybind11-1.8.1.tar.gz) = 45860
diff --git a/devel/py-pybind11/pkg-descr b/devel/py-pybind11/pkg-descr
new file mode 100644
index 000000000000..c280f1330bf4
--- /dev/null
+++ b/devel/py-pybind11/pkg-descr
@@ -0,0 +1,7 @@
+A lightweight header-only library to create Python bindings of existing
+C++ code. Its goals and syntax are similar to the excellent Boost.Python
+library by David Abrahams: to minimize boilerplate code in traditional
+extension modules by inferring type information using compile-time
+introspection.
+
+WWW: https://github.com/wjakob/pybind11