aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-09-21 15:11:58 +0800
committerknu <knu@FreeBSD.org>2002-09-21 15:11:58 +0800
commit3388c2c333ec85f5bd12ddafb510e3a97c19c74e (patch)
tree560aec16c4e50fc081c39f439af4361d58a633f7
parent26a5decc21d5346ac279d24e9a5f550a5df7df86 (diff)
downloadfreebsd-ports-gnome-3388c2c333ec85f5bd12ddafb510e3a97c19c74e.tar.gz
freebsd-ports-gnome-3388c2c333ec85f5bd12ddafb510e3a97c19c74e.tar.zst
freebsd-ports-gnome-3388c2c333ec85f5bd12ddafb510e3a97c19c74e.zip
Use RUBY_SHIM18_PORT.
-rw-r--r--lang/ruby16_static/Makefile4
-rw-r--r--lang/ruby_static/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index 7e3c4105fc43..316229eb7c5e 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -30,7 +30,7 @@ _RUBY_PORTDIR= ${_PORTSDIR}/${RUBY_PORT}
LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.if ${RUBY_VER} < 1.7
-EXT_PORTS+= lang/ruby16-shim-ruby18
+EXT_PORTS+= ${RUBY_SHIM18_PORT}
.else
EXT_PORTS+= converters/ruby-iconv
.endif
@@ -99,7 +99,7 @@ do-extract:
while read extdir; do \
extdir=$${extdir%/extconf.rb}; \
case "$p" in \
- lang/ruby16-shim-ruby18) \
+ ${RUBY_SHIM18_PORT) \
m=$$(basename $$extdir); \
case $$extdir in \
*/racc/*) \
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index 7e3c4105fc43..316229eb7c5e 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -30,7 +30,7 @@ _RUBY_PORTDIR= ${_PORTSDIR}/${RUBY_PORT}
LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.if ${RUBY_VER} < 1.7
-EXT_PORTS+= lang/ruby16-shim-ruby18
+EXT_PORTS+= ${RUBY_SHIM18_PORT}
.else
EXT_PORTS+= converters/ruby-iconv
.endif
@@ -99,7 +99,7 @@ do-extract:
while read extdir; do \
extdir=$${extdir%/extconf.rb}; \
case "$p" in \
- lang/ruby16-shim-ruby18) \
+ ${RUBY_SHIM18_PORT) \
m=$$(basename $$extdir); \
case $$extdir in \
*/racc/*) \