aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-23 23:54:01 +0800
committerwill <will@FreeBSD.org>2003-06-23 23:54:01 +0800
commit349fa8200dff00964c88ed59b1ebcc9b54ef5c72 (patch)
tree556465ec38e6612cfca29bfcaf137860cca6458b
parentc01c1972090414166a271d2bf77f5935db2b6857 (diff)
downloadfreebsd-ports-gnome-349fa8200dff00964c88ed59b1ebcc9b54ef5c72.tar.gz
freebsd-ports-gnome-349fa8200dff00964c88ed59b1ebcc9b54ef5c72.tar.zst
freebsd-ports-gnome-349fa8200dff00964c88ed59b1ebcc9b54ef5c72.zip
Fix build on ia64.
Submitted by: marcel, MAINTAINER, bento (kris)
-rw-r--r--devel/elfsh/files/patch-elfsh::Makefile11
-rw-r--r--devel/elfsh/files/patch-libelfsh::Makefile11
2 files changed, 22 insertions, 0 deletions
diff --git a/devel/elfsh/files/patch-elfsh::Makefile b/devel/elfsh/files/patch-elfsh::Makefile
new file mode 100644
index 000000000000..6ec586d4501c
--- /dev/null
+++ b/devel/elfsh/files/patch-elfsh::Makefile
@@ -0,0 +1,11 @@
+--- elfsh/Makefile.orig Mon Jun 23 17:33:38 2003
++++ elfsh/Makefile Mon Jun 23 17:35:00 2003
+@@ -12,7 +12,7 @@
+ CC = gcc
+ NAME = elfsh
+ LDFLAGS = -L../libelfsh/ -lelfsh
+-CFLAGS = -Wall -Iinclude -I../libelfsh/include -g3 -O2
++CFLAGS += -Wall -Iinclude -I../libelfsh/include
+ RM = rm -f
+ NAME = elfsh
+
diff --git a/devel/elfsh/files/patch-libelfsh::Makefile b/devel/elfsh/files/patch-libelfsh::Makefile
new file mode 100644
index 000000000000..87cccf531c1d
--- /dev/null
+++ b/devel/elfsh/files/patch-libelfsh::Makefile
@@ -0,0 +1,11 @@
+--- libelfsh/Makefile.orig Mon Jun 23 17:36:25 2003
++++ libelfsh/Makefile Mon Jun 23 17:37:33 2003
+@@ -8,7 +8,7 @@
+ CC = gcc
+ RM = rm -f
+ AR = ar rc
+-CFLAGS = -Iinclude -Wall -g3 -O2
++CFLAGS += -Iinclude -Wall -fpic
+ SRC = dynamic.c dynsym.c elf.c fixup.c got.c hash.c \
+ interp.c pht.c plt.c section.c sht.c error.c \
+ stab.c symbol.c notes.c reloc.c functions.c \