aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 18:52:06 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 18:52:06 +0800
commit367b75a1231c1c471a020c080b64753c11b9c2d5 (patch)
tree608421a43162399273f8cd6166666d4361c3dc3c
parent7804ca7821ba29e3a18d2d3b4e568b090fdbd99b (diff)
downloadfreebsd-ports-gnome-367b75a1231c1c471a020c080b64753c11b9c2d5.tar.gz
freebsd-ports-gnome-367b75a1231c1c471a020c080b64753c11b9c2d5.tar.zst
freebsd-ports-gnome-367b75a1231c1c471a020c080b64753c11b9c2d5.zip
Add USES=libtool and remove USE_AUTOTOOLS
-rw-r--r--games/xpuyopuyo/Makefile8
-rw-r--r--games/xpuyopuyo/files/patch-ltmain.sh41
2 files changed, 3 insertions, 46 deletions
diff --git a/games/xpuyopuyo/Makefile b/games/xpuyopuyo/Makefile
index b026005611aa..25fd5584da43 100644
--- a/games/xpuyopuyo/Makefile
+++ b/games/xpuyopuyo/Makefile
@@ -10,18 +10,16 @@ MASTER_SITES= http://chaos2.org/xpuyopuyo/
MAINTAINER= ports@FreeBSD.org
COMMENT= Puzzle game, somewhat like Tetris
-USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-gnome
+USES= gmake libtool
USE_XORG= xpm
-USE_AUTOTOOLS= autoconf213
USE_GNOME= gtk12
-WANT_GNOME= yes
OPTIONS_DEFINE= MIKMOD ROTATE_FIXED AIBREED
ROTATE_FIXED_DESC= Fix position of one blob during rotation
AIBREED_DESC= Allow AI breeding
-CONFIGURE_ARGS+= --without-gnome
-
MIKMOD_LIB_DEPENDS= libmikmod.so:${PORTSDIR}/audio/libmikmod
MIKMOD_CONFIGURE_ON= --with-libmikmod-prefix=${LOCALBASE}
diff --git a/games/xpuyopuyo/files/patch-ltmain.sh b/games/xpuyopuyo/files/patch-ltmain.sh
deleted file mode 100644
index ae23433f8047..000000000000
--- a/games/xpuyopuyo/files/patch-ltmain.sh
+++ /dev/null
@@ -1,41 +0,0 @@
---- ltmain.sh.orig 2008-07-26 17:06:14.000000000 +0900
-+++ ltmain.sh 2008-07-26 17:06:24.000000000 +0900
-@@ -1710,6 +1710,38 @@
- lib=
- found=no
- case $deplib in
-+ -mt|-mthreads|-kthread|-Kthread|-pthread|-pthreads|--thread-safe|-threads)
-+ if test "$linkmode,$pass" = "prog,link"; then
-+ compile_deplibs="$deplib $compile_deplibs"
-+ finalize_deplibs="$deplib $finalize_deplibs"
-+ else
-+ compiler_flags="$compiler_flags $deplib"
-+ fi
-+
-+ case $linkmode in
-+ lib)
-+ deplibs="$deplib $deplibs"
-+ test "$pass" = conv && continue
-+ newdependency_libs="$deplib $newdependency_libs"
-+ ;;
-+ prog)
-+ if test "$pass" = conv; then
-+ deplibs="$deplib $deplibs"
-+ continue
-+ fi
-+ if test "$pass" = scan; then
-+ deplibs="$deplib $deplibs"
-+ else
-+ compile_deplibs="$deplib $compile_deplibs"
-+ finalize_deplibs="$deplib $finalize_deplibs"
-+ fi
-+ ;;
-+ *)
-+ ;;
-+ esac # linkmode
-+
-+ continue
-+ ;;
- -l*)
- if test $linkmode != lib && test $linkmode != prog; then
- $echo "$modename: warning: \`-l' is ignored for archives/objects" 1>&2