aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-09-18 19:42:02 +0800
committerijliao <ijliao@FreeBSD.org>2002-09-18 19:42:02 +0800
commit38c6dc2946be3f56c1535ba0dfa25d4dc9e68d56 (patch)
tree3f3dec16a65bc7da93b60617354cfc7d9ad6b429
parent787bdff2f7807fff2445effc384d07553c51c896 (diff)
downloadfreebsd-ports-gnome-38c6dc2946be3f56c1535ba0dfa25d4dc9e68d56.tar.gz
freebsd-ports-gnome-38c6dc2946be3f56c1535ba0dfa25d4dc9e68d56.tar.zst
freebsd-ports-gnome-38c6dc2946be3f56c1535ba0dfa25d4dc9e68d56.zip
add ocaml-pcre 4.28.3
Perl compatible regular expressions for Objective Caml PR: 37354 Submitted by: Henrik Motakef <henrik.motakef@web.de>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-pcre/Makefile29
-rw-r--r--devel/ocaml-pcre/distinfo1
-rw-r--r--devel/ocaml-pcre/pkg-comment1
-rw-r--r--devel/ocaml-pcre/pkg-descr6
-rw-r--r--devel/ocaml-pcre/pkg-plist7
6 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 05befe240795..779c7249c235 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -377,6 +377,7 @@
SUBDIR += nspr
SUBDIR += oaf
SUBDIR += ocaml-findlib
+ SUBDIR += ocaml-pcre
SUBDIR += ocamlweb
SUBDIR += omniORB
SUBDIR += openzz
diff --git a/devel/ocaml-pcre/Makefile b/devel/ocaml-pcre/Makefile
new file mode 100644
index 000000000000..15846df1f0f6
--- /dev/null
+++ b/devel/ocaml-pcre/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ocaml-pcre
+# Date created: 21 April 2002
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcre
+PORTVERSION= 4.28.3
+CATEGORIES= devel
+MASTER_SITES= http://www.ai.univie.ac.at/~markus/ocaml_sources/
+MASTER_SITE_SUBDIR= pcre-ocaml
+PKGNAMEPREFIX= ocaml-
+DISTNAME= pcre-ocaml-${PORTVERSION}
+
+MAINTAINER= henrik.motakef@web.de
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+USE_GMAKE= yes
+MAKE_ENV= OCAML_LIB_INSTALL="${PREFIX}/lib/ocaml/site-lib/pcre" \
+ INCDIRS="${LOCALBASE}/include" LIBDIRS="${LOCALBASE}/lib"
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/META ${PREFIX}/lib/ocaml/site-lib/pcre; \
+ ${ECHO_CMD} "${PREFIX}/lib/ocaml/site-lib/pcre" >> ${PREFIX}/lib/ocaml/ld.conf
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-pcre/distinfo b/devel/ocaml-pcre/distinfo
new file mode 100644
index 000000000000..16ee27f4cde8
--- /dev/null
+++ b/devel/ocaml-pcre/distinfo
@@ -0,0 +1 @@
+MD5 (pcre-ocaml-4.28.3.tar.gz) = 893a6f05297b158032a0156d0cbc7af1
diff --git a/devel/ocaml-pcre/pkg-comment b/devel/ocaml-pcre/pkg-comment
new file mode 100644
index 000000000000..aef62cbd3679
--- /dev/null
+++ b/devel/ocaml-pcre/pkg-comment
@@ -0,0 +1 @@
+Perl compatible regular expressions for Objective Caml
diff --git a/devel/ocaml-pcre/pkg-descr b/devel/ocaml-pcre/pkg-descr
new file mode 100644
index 000000000000..9e47750061c7
--- /dev/null
+++ b/devel/ocaml-pcre/pkg-descr
@@ -0,0 +1,6 @@
+Perl compatible regular expressions for Objective Caml.
+
+WWW: http://pcre-ocaml.sourceforge.net/
+
+- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/devel/ocaml-pcre/pkg-plist b/devel/ocaml-pcre/pkg-plist
new file mode 100644
index 000000000000..b1d1336cd1ec
--- /dev/null
+++ b/devel/ocaml-pcre/pkg-plist
@@ -0,0 +1,7 @@
+lib/ocaml/site-lib/pcre/META
+lib/ocaml/site-lib/pcre/dllpcre_stubs.so
+lib/ocaml/site-lib/pcre/libpcre_stubs.a
+lib/ocaml/site-lib/pcre/pcre.cma
+lib/ocaml/site-lib/pcre/pcre.cmi
+lib/ocaml/site-lib/pcre/pcre.mli
+@dirrm lib/ocaml/site-lib/pcre