aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-01-04 21:03:56 +0800
committersat <sat@FreeBSD.org>2007-01-04 21:03:56 +0800
commit3c443883d26650c2e1aae3d35a4cd52f130789ed (patch)
treec5b22625bbc9334ed3ba3816fe0fcb4a4e52d03f
parentce03e15743748ec2c885095efec1d0d90fc4d90e (diff)
downloadfreebsd-ports-gnome-3c443883d26650c2e1aae3d35a4cd52f130789ed.tar.gz
freebsd-ports-gnome-3c443883d26650c2e1aae3d35a4cd52f130789ed.tar.zst
freebsd-ports-gnome-3c443883d26650c2e1aae3d35a4cd52f130789ed.zip
Open Yhatzee is an open-source (free) version of the classic dice game
Yahtzee. Open Yahtzee is built to be OS portable, that means you can run it on many kinds of different operating systems and platforms. The portability is mainly achived via wxWidgets which also gives Open Yahtzee a native look on each platform. WWW: http://openyahtzee.sourceforge.net/ Author: Guy Rutenberg <guy+openyahtzee@sikumuna.co.il>
-rw-r--r--games/Makefile1
-rw-r--r--games/openyahtzee/Makefile28
-rw-r--r--games/openyahtzee/distinfo3
-rw-r--r--games/openyahtzee/pkg-descr8
4 files changed, 40 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 60ffa87c6f45..0ffeebe40ecb 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -505,6 +505,7 @@
SUBDIR += openglad
SUBDIR += openmortal
SUBDIR += openttd
+ SUBDIR += openyahtzee
SUBDIR += orbital_eunuchs_sniper
SUBDIR += p5-Algorithm-Pair-Best
SUBDIR += p5-Algorithm-Pair-Swiss
diff --git a/games/openyahtzee/Makefile b/games/openyahtzee/Makefile
new file mode 100644
index 000000000000..4a1aa25fe151
--- /dev/null
+++ b/games/openyahtzee/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: openyahtzee
+# Date created: 04 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenYahtzee
+PORTVERSION= 1.5.1
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Full-featured classic dice game Yahtzee
+
+GNU_CONFIGURE= yes
+USE_WX= yes
+USE_SQLITE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+PLIST_FILES= bin/${PORTNAME:L}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|' ${WRKSRC}/Makefile.in ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/games/openyahtzee/distinfo b/games/openyahtzee/distinfo
new file mode 100644
index 000000000000..b398eb7c874d
--- /dev/null
+++ b/games/openyahtzee/distinfo
@@ -0,0 +1,3 @@
+MD5 (OpenYahtzee-1.5.1.tar.gz) = 5bdbaafeb1722f56eb4dd8d2f46b38f6
+SHA256 (OpenYahtzee-1.5.1.tar.gz) = 4803b4a9aff5647ddb897184c7916c33bbbb3bd158a77c905fde60b93fad4402
+SIZE (OpenYahtzee-1.5.1.tar.gz) = 691680
diff --git a/games/openyahtzee/pkg-descr b/games/openyahtzee/pkg-descr
new file mode 100644
index 000000000000..883c8460a024
--- /dev/null
+++ b/games/openyahtzee/pkg-descr
@@ -0,0 +1,8 @@
+Open Yhatzee is an open-source (free) version of the classic dice game
+Yahtzee. Open Yahtzee is built to be OS portable, that means you can run
+it on many kinds of different operating systems and platforms. The
+portability is mainly achived via wxWidgets which also gives Open
+Yahtzee a native look on each platform.
+
+WWW: http://openyahtzee.sourceforge.net/
+Author: Guy Rutenberg <guy+openyahtzee@sikumuna.co.il>