aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-08-29 03:23:02 +0800
committerdinoex <dinoex@FreeBSD.org>2005-08-29 03:23:02 +0800
commit3c4fa711e5a2cf871dee4cb6228f88b2a48c70b9 (patch)
tree2300b212836ae9f206eda41dafdc8391ebe7df40
parentca83089c14e4412a4c9d5d10fdb96950742d3b57 (diff)
downloadfreebsd-ports-gnome-3c4fa711e5a2cf871dee4cb6228f88b2a48c70b9.tar.gz
freebsd-ports-gnome-3c4fa711e5a2cf871dee4cb6228f88b2a48c70b9.tar.zst
freebsd-ports-gnome-3c4fa711e5a2cf871dee4cb6228f88b2a48c70b9.zip
- cleanup Makefile location
Approved by: knu (implicit)
-rw-r--r--devel/ruby-gnustep/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index e6f1186793e6..7af4cb4ad900 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -18,12 +18,12 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= A Ruby interface to the GNUstep development environment
-BUILD_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
+BUILD_DEPENDS= ${SYSMAKEDIR}/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT} \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT} \
${BACKBUNDLEDIR}/libgnustep-back${BACKSUFFIX}:${PORTSDIR}/${GNUSTEP_BACK_PORT}
-RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
+RUN_DEPENDS= ${SYSMAKEDIR}/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT} \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT} \
${BACKBUNDLEDIR}/libgnustep-back${BACKSUFFIX}:${PORTSDIR}/${GNUSTEP_BACK_PORT}
@@ -52,10 +52,11 @@ GNUSTEP_LOCAL_ROOT= ${GNUSTEP_PREFIX}/Local
GNUSTEP_SYSTEM_ROOT= ${GNUSTEP_PREFIX}/System
GNUSTEP_NETWORK_ROOT= ${GNUSTEP_PREFIX}/Network
GNUSTEP_USER_ROOT= ${GNUSTEP_PREFIX}/Local/Users
-GNUSTEP_MAKEFILES= ${GNUSTEP_SYSTEM_ROOT}/Makefiles
+GNUSTEP_MAKEFILES= ${GNUSTEP_SYSTEM_ROOT}/Library/Makefiles
BACKBUNDLEDIR= ${GNUSTEP_PREFIX}/System/Library/Bundles/libgnustep-back${BACKSUFFIX}.bundle
SYSLIBDIR= ${GNUSTEP_PREFIX}/System/Library/Libraries
+SYSMAKEDIR= ${GNUSTEP_MAKEFILES}
COMBOLIBDIR= ${SYSLIBDIR}
MAKE_ENV+= GNUSTEP_FLATTENED=yes