aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2014-06-01 20:41:12 +0800
committerse <se@FreeBSD.org>2014-06-01 20:41:12 +0800
commit3cb272093d11cccd7f1b6ed13db54412fe416783 (patch)
tree7069d72cd2445f56dca1989744e7320462434afe
parent21450624760c5ece771262484f87dacb0d0028d0 (diff)
downloadfreebsd-ports-gnome-3cb272093d11cccd7f1b6ed13db54412fe416783.tar.gz
freebsd-ports-gnome-3cb272093d11cccd7f1b6ed13db54412fe416783.tar.zst
freebsd-ports-gnome-3cb272093d11cccd7f1b6ed13db54412fe416783.zip
Add support for staging and set license to 3-clause BSD.
Approved by: antoine (mentor)
-rw-r--r--security/phpsecinfo/Makefile15
-rw-r--r--security/phpsecinfo/pkg-plist2
2 files changed, 12 insertions, 5 deletions
diff --git a/security/phpsecinfo/Makefile b/security/phpsecinfo/Makefile
index f8ec73eb7b7e..54d22c516036 100644
--- a/security/phpsecinfo/Makefile
+++ b/security/phpsecinfo/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= LOCAL/chinsan
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP environment security auditing tool
+LICENSE= BSD3CLAUSE
+
USES= zip
USE_PHP= pcre
WANT_PHP_WEB= yes
@@ -17,17 +19,20 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-20070406
TEMP_PLIST= ${WRKDIR}/temp-pkg-plist
-NO_STAGE= yes
+PLIST_SUB= WWWOWN=${WWWOWN} \
+ WWWGRP=${WWWGRP}
+
do-install:
- @${MKDIR} ${WWWDIR}
- @${CP} -R ${WRKSRC}/ ${WWWDIR}/
- @${CHOWN} -R ${WWWOWN}:${WWWGROUP} ${WWWDIR}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ @${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}/
# This target is only meant to be used by the port maintainer.
x-generate-plist:
@make makesum extract
+ @${ECHO_CMD} "@owner %%WWWOWN%%" > ${TEMP_PLIST}
+ @${ECHO_CMD} "@group %%WWWGRP%%" >> ${TEMP_PLIST}
@cd ${WRKSRC} && ${FIND} -s . -type f | \
- ${SED} -e 's|^./||;s|^|%%WWWDIR%%/|' > ${TEMP_PLIST} \
+ ${SED} -e 's|^./||;s|^|%%WWWDIR%%/|' >> ${TEMP_PLIST} \
&& ${FIND} -d * -type d | \
${SED} -e 's|^|@dirrm %%WWWDIR%%/|' >> ${TEMP_PLIST} \
&& ${ECHO_CMD} "@dirrmtry %%WWWDIR%%" >> ${TEMP_PLIST}
diff --git a/security/phpsecinfo/pkg-plist b/security/phpsecinfo/pkg-plist
index 6ae93e5ef59b..9b200b8d6246 100644
--- a/security/phpsecinfo/pkg-plist
+++ b/security/phpsecinfo/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/CHANGELOG
%%WWWDIR%%/LICENSE
%%WWWDIR%%/PhpSecInfo/PhpSecInfo.php