aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-10-25 13:21:30 +0800
committerdanfe <danfe@FreeBSD.org>2005-10-25 13:21:30 +0800
commit3d9e0d21fca5833b95d5bf139d16dddd05940917 (patch)
tree8274494c326ae573e9802617b8d26f59396f4172
parent0a921c617b5ff6f20401c915b241a04fb6cf0c81 (diff)
downloadfreebsd-ports-gnome-3d9e0d21fca5833b95d5bf139d16dddd05940917.tar.gz
freebsd-ports-gnome-3d9e0d21fca5833b95d5bf139d16dddd05940917.tar.zst
freebsd-ports-gnome-3d9e0d21fca5833b95d5bf139d16dddd05940917.zip
- Stop looking for non-existent and non-needed tool
- Make PREFIX-clean Reported by: krismail
-rw-r--r--graphics/pho/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/pho/Makefile b/graphics/pho/Makefile
index 0f7cec0f2534..1d37801ba810 100644
--- a/graphics/pho/Makefile
+++ b/graphics/pho/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= A lightweight image viewer
USE_GMAKE= yes
+MAKE_ARGS= INSTALLPREFIX="${PREFIX}"
USE_REINPLACE= yes
WANT_GNOME= yes
@@ -23,8 +24,10 @@ OPTIONS= GTK1 "Build with legacy GTK version (1.2.x)" Off
.if defined(WITH_GTK1)
USE_GNOME= gdkpixbuf gtk12
+BAD_GTK= 2
.else
USE_GNOME= gtk20
+BAD_GTK= 1
.endif
post-patch:
@@ -33,9 +36,7 @@ post-patch:
s|$$(INSTALL) \(pho.1\)|${INSTALL_MAN} \1|; \
s|-g -O2|${CFLAGS}|; s|pho xpho$$|pho|' \
${WRKSRC}/Makefile
-.if defined(WITH_GTK1)
- @${REINPLACE_CMD} -e 's|^G2FLAGS|#&|' ${WRKSRC}/Makefile
-.endif
+ @${REINPLACE_CMD} -e 's|^G${BAD_GTK}FLAGS|#&|' ${WRKSRC}/Makefile
MAN1= pho.1
PLIST_FILES= bin/pho