aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-09-15 02:30:17 +0800
committergarga <garga@FreeBSD.org>2010-09-15 02:30:17 +0800
commit3db16003922d6e76640e6025e3977b91c0e12c30 (patch)
treeb387755d8a0e1f8c3e5285970dde0fb8f6848dfd
parentf61ae79232ec77816d59927cf223380bc054be80 (diff)
downloadfreebsd-ports-gnome-3db16003922d6e76640e6025e3977b91c0e12c30.tar.gz
freebsd-ports-gnome-3db16003922d6e76640e6025e3977b91c0e12c30.tar.zst
freebsd-ports-gnome-3db16003922d6e76640e6025e3977b91c0e12c30.zip
- Add optional SAMBA_PORT var and point it as default to net/samba34
- Bump necessary PORTREVISION
-rw-r--r--net/linneighborhood/Makefile6
-rw-r--r--net/xsmbrowser/Makefile8
-rw-r--r--print/apsfilter/Makefile6
-rw-r--r--security/saint/Makefile4
-rw-r--r--www/smb2www/Makefile8
5 files changed, 21 insertions, 11 deletions
diff --git a/net/linneighborhood/Makefile b/net/linneighborhood/Makefile
index 5a1d5fe835fb..dd208ad20dc7 100644
--- a/net/linneighborhood/Makefile
+++ b/net/linneighborhood/Makefile
@@ -7,14 +7,16 @@
PORTNAME= LinNeighborhood
PORTVERSION= 0.6.5
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= net
MASTER_SITES= http://www.bnro.de/~schmidjo/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ gui for browsing and mounting SMB filesystems
-RUN_DEPENDS= smbclient:${PORTSDIR}/net/samba3
+RUN_DEPENDS= smbclient:${PORTSDIR}/${SAMBA_PORT}
+
+SAMBA_PORT?= net/samba34
GNU_CONFIGURE= yes
USE_GETTEXT= yes
diff --git a/net/xsmbrowser/Makefile b/net/xsmbrowser/Makefile
index f407133e7699..47859c398c01 100644
--- a/net/xsmbrowser/Makefile
+++ b/net/xsmbrowser/Makefile
@@ -7,17 +7,19 @@
PORTNAME= xsmbrowser
PORTVERSION= 3.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://nuxo1.free.fr/logiciel_reseau/visu_reso/ \
http://mirror.uni-c.dk/gentoo/distfiles/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Tcl/Tk port of Windows' Network Neighborhood
+COMMENT= Tcl/Tk port of Windows Network Neighborhood
-RUN_DEPENDS= ${LOCALBASE}/bin/smbclient:${PORTSDIR}/net/samba3 \
+RUN_DEPENDS= ${LOCALBASE}/bin/smbclient:${PORTSDIR}/${SAMBA_PORT} \
${LOCALBASE}/bin/expectk:${PORTSDIR}/lang/expect
+SAMBA_PORT?= net/samba34
+
USE_PERL5_BUILD=yes
do-build:
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index d34e7768b3d2..4bc422333e65 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apsfilter
PORTVERSION= 7.2.8
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= print
MASTER_SITES= http://www.apsfilter.org/download/
@@ -20,6 +20,8 @@ USE_SUBMAKE= yes
SUB_FILES+= pkg-message
+SAMBA_PORT?= net/samba34
+
# special arrangement for package building, build stuff without X11
# to make memory footprint of apsfilter package smaller
.if defined(BATCH) && defined(PACKAGE_BUILDING)
@@ -98,7 +100,7 @@ RUN_DEPENDS+= wavplay:${PORTSDIR}/audio/wavplay
.endif
# all possible remote printing support
RUN_DEPENDS+= pap:${PORTSDIR}/net/netatalk
-RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
+RUN_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
.elif defined(BATCH)
#
# in normal batch/portbuilding mode (without building all)
diff --git a/security/saint/Makefile b/security/saint/Makefile
index e2d201d9607f..e0a8eee3d369 100644
--- a/security/saint/Makefile
+++ b/security/saint/Makefile
@@ -16,9 +16,11 @@ COMMENT= Security Administrator's Integrated Network Tool
BUILD_DEPENDS= nmap:${PORTSDIR}/security/nmap
.if defined(WITH_SAMBA)
-BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
+BUILD_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
.endif
+SAMBA_PORT?= net/samba34
+
USE_PERL5= yes
MANCOMPRESSED= no
MAN1= saint.1
diff --git a/www/smb2www/Makefile b/www/smb2www/Makefile
index 5866b757c49a..3d7d0519fc90 100644
--- a/www/smb2www/Makefile
+++ b/www/smb2www/Makefile
@@ -7,7 +7,7 @@
PORTNAME= smb2www
PORTVERSION= 0.0.980804
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SAMBA}
MASTER_SITE_SUBDIR= smb2www
@@ -16,8 +16,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/0.0.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Windows Network client that is accessible through a web browser
-RUN_DEPENDS= smbclient:${PORTSDIR}/net/samba3 \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= smbclient:${PORTSDIR}/${SAMBA_PORT} \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+SAMBA_PORT?= net/samba34
MAKE_JOBS_SAFE= yes