aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-02-02 21:53:51 +0800
committergabor <gabor@FreeBSD.org>2007-02-02 21:53:51 +0800
commit3e3ba1e60ca3af246725d6f0e1277304b81376c4 (patch)
treeaec0f57a5cf7c4bd41389b0278be0ccac30b7b32
parent4fbbba8ebba854528d473fd654c67fcb7fcff621 (diff)
downloadfreebsd-ports-gnome-3e3ba1e60ca3af246725d6f0e1277304b81376c4.tar.gz
freebsd-ports-gnome-3e3ba1e60ca3af246725d6f0e1277304b81376c4.tar.zst
freebsd-ports-gnome-3e3ba1e60ca3af246725d6f0e1277304b81376c4.zip
Tcl interface to AOLserver's caching API
AOLserver implements a C API for caching arbitrary data. This module provides a Tcl API on top of the C API. The module is only compatible with AOLserver 3.x using nsd8x, or AOLserver 4.x. WWW: http://www.aolserver.com/ - Martin Matuska martin@matuska.org PR: ports/105781 Submitted by: Martin Matuska <martin@matuska.org> Approved by: erwin (mentor)
-rw-r--r--www/Makefile1
-rw-r--r--www/aolserver-nscache/Makefile45
-rw-r--r--www/aolserver-nscache/distinfo3
-rw-r--r--www/aolserver-nscache/pkg-descr10
-rw-r--r--www/aolserver-nscache/pkg-plist3
5 files changed, 62 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5126d60f69ce..dd899e335fe6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -12,6 +12,7 @@
SUBDIR += amphetadesk
SUBDIR += analog
SUBDIR += aolserver
+ SUBDIR += aolserver-nscache
SUBDIR += aolserver-openacs-pg
SUBDIR += apache-contrib
SUBDIR += apache-forrest
diff --git a/www/aolserver-nscache/Makefile b/www/aolserver-nscache/Makefile
new file mode 100644
index 000000000000..45e6b53de00a
--- /dev/null
+++ b/www/aolserver-nscache/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: aolserver-nscache
+# Date created: 12 Oct 2006
+# Whom: Martin Matuska <martin@matuska.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aolserver-nscache
+PORTVERSION= 1.5
+CATEGORIES= databases www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aolserver
+DISTFILES= nscache-${PORTVERSION}.tar.gz
+DIST_SUBDIR= aolserver
+
+MAINTAINER= martin@matuska.org
+COMMENT= Tcl interface to AOLserver's caching API
+
+WRKSRC= ${WRKDIR}/nscache-${PORTVERSION}
+
+AOLSERVERBASE?= ${PREFIX}/aolserver
+BUILD_DEPENDS+= ${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+PLIST_SUB+= AOLSERVERBASE=${AOLSERVERBASE:S/${PREFIX}\///}
+
+USE_GMAKE= yes
+
+MAKE_ARGS= AOLSERVER=${AOLSERVERBASE}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog index.html
+.endif
+
+post-patch:
+ @ ${REINPLACE_CMD} -e 's|OBJS|MODOBJS|' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/aolserver-nscache/distinfo b/www/aolserver-nscache/distinfo
new file mode 100644
index 000000000000..1c5f4974abe3
--- /dev/null
+++ b/www/aolserver-nscache/distinfo
@@ -0,0 +1,3 @@
+MD5 (aolserver/nscache-1.5.tar.gz) = daa88717c214ff703d826e22e7447245
+SHA256 (aolserver/nscache-1.5.tar.gz) = 64a143a8e8043bdc58721c7f66c67a5c2c4d471406784558fd26fa171469a7a7
+SIZE (aolserver/nscache-1.5.tar.gz) = 14594
diff --git a/www/aolserver-nscache/pkg-descr b/www/aolserver-nscache/pkg-descr
new file mode 100644
index 000000000000..51f3bc26febd
--- /dev/null
+++ b/www/aolserver-nscache/pkg-descr
@@ -0,0 +1,10 @@
+Tcl interface to AOLserver's caching API
+
+AOLserver implements a C API for caching arbitrary data. This module provides
+a Tcl API on top of the C API. The module is only compatible with AOLserver 3.x
+using nsd8x, or AOLserver 4.x.
+
+WWW: http://www.aolserver.com/
+
+- Martin Matuska
+martin@matuska.org
diff --git a/www/aolserver-nscache/pkg-plist b/www/aolserver-nscache/pkg-plist
new file mode 100644
index 000000000000..039c318e6d15
--- /dev/null
+++ b/www/aolserver-nscache/pkg-plist
@@ -0,0 +1,3 @@
+%%AOLSERVERBASE%%/bin/nscache.so
+%%AOLSERVERBASE%%/lib/libnscache.a
+%%AOLSERVERBASE%%/lib/libnscache.so