aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2008-03-01 05:08:15 +0800
committerehaupt <ehaupt@FreeBSD.org>2008-03-01 05:08:15 +0800
commit3e7b0f7fdea98248a8ee021c6ffd0c257f2c51f9 (patch)
tree70ddf085005a266b214ccd6ca40386a5fd322522
parent9a23852eac7f71c4466db19ffb1d46d163d399a1 (diff)
downloadfreebsd-ports-gnome-3e7b0f7fdea98248a8ee021c6ffd0c257f2c51f9.tar.gz
freebsd-ports-gnome-3e7b0f7fdea98248a8ee021c6ffd0c257f2c51f9.tar.zst
freebsd-ports-gnome-3e7b0f7fdea98248a8ee021c6ffd0c257f2c51f9.zip
The upgrade of ports/security/vpnc to version 0.5.1 introduced some glitches
against the documented behaviour. In particular, the configuration files are not searched in the documented locations: /usr/local/etc/vpnc/*.conf is not searched at all, and /usr/local/etc/vpnc/default.conf is skipped, both in contrast to the documentation. PR: 121229 Submitted by: Helge Oldach <ports-security-vpnc-feb08@oldach.net>
-rw-r--r--security/vpnc/Makefile2
-rw-r--r--security/vpnc/files/patch-Makefile11
-rw-r--r--security/vpnc/files/patch-config.c5
3 files changed, 14 insertions, 4 deletions
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 89ec6d885d37..8fbc4863547a 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpnc
PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
http://critical.ch/distfiles/ \
diff --git a/security/vpnc/files/patch-Makefile b/security/vpnc/files/patch-Makefile
index 1f76965f4765..85eea5c9e12f 100644
--- a/security/vpnc/files/patch-Makefile
+++ b/security/vpnc/files/patch-Makefile
@@ -1,5 +1,5 @@
--- Makefile.orig 2007-09-06 22:05:15.000000000 +0200
-+++ Makefile 2008-02-27 19:17:28.000000000 +0100
++++ Makefile 2008-02-29 21:58:37.000000000 +0100
@@ -20,14 +20,14 @@
# $Id: Makefile 236 2007-09-05 20:40:59Z Joerg Mayer $
@@ -31,3 +31,12 @@
CFLAGS += $(shell libgcrypt-config --cflags)
CPPFLAGS += -DVERSION=\"$(VERSION)\" $(OPENSSL_GPL_VIOLATION)
LDFLAGS ?= -g
+@@ -74,7 +74,7 @@
+ ./makeman.pl
+
+ cisco-decrypt : cisco-decrypt.o config.o supp.o sysdep.o vpnc-debug.o
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ .depend: $(SRCS) $(BINSRCS)
+ $(CC) -MM $(SRCS) $(BINSRCS) $(CFLAGS) $(CPPFLAGS) > $@
diff --git a/security/vpnc/files/patch-config.c b/security/vpnc/files/patch-config.c
index 23dd0b636e1c..ad7e848fd562 100644
--- a/security/vpnc/files/patch-config.c
+++ b/security/vpnc/files/patch-config.c
@@ -20,16 +20,17 @@
char *realname;
- asprintf(&realname, "%s%s%s", index(name, '/') ? "" : "/etc/vpnc/", name, add_dot_conf ? ".conf" : "");
-+ asprintf(&realname, "%s%s%s", index(name, '/') ? "" : "%%PREFIX%%/etc/", name, add_dot_conf ? ".conf" : "");
++ asprintf(&realname, "%s%s%s", index(name, '/') ? "" : "%%PREFIX%%/etc/vpnc/", name, add_dot_conf ? ".conf" : "");
return realname;
}
-@@ -757,8 +757,7 @@
+@@ -757,8 +757,8 @@
}
if (!got_conffile) {
- read_config_file("/etc/vpnc/default.conf", config, 1);
- read_config_file("/etc/vpnc.conf", config, 1);
++ read_config_file("%%PREFIX%%/etc/vpnc/default.conf", config, 1);
+ read_config_file("%%PREFIX%%/etc/vpnc.conf", config, 1);
}