aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-06-17 23:49:22 +0800
committernork <nork@FreeBSD.org>2003-06-17 23:49:22 +0800
commit3f41a9a92ba8dfe045d3901c5d04ce2ed47c29b9 (patch)
treea1255c51d283bd54e5883d8a07ec0fc0b33521dd
parent0777fbfcdaf585f36171d8a4fd2f047a6200d71c (diff)
downloadfreebsd-ports-gnome-3f41a9a92ba8dfe045d3901c5d04ce2ed47c29b9.tar.gz
freebsd-ports-gnome-3f41a9a92ba8dfe045d3901c5d04ce2ed47c29b9.tar.zst
freebsd-ports-gnome-3f41a9a92ba8dfe045d3901c5d04ce2ed47c29b9.zip
Add pear-File_Find 0.2.0, a PEAR Class to facilitate the search
of filesystems. PR: ports/53328 Submitted by: Thierry Thomas <thierry@pompo.net>
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/pear-File_Find/Makefile28
-rw-r--r--sysutils/pear-File_Find/distinfo1
-rw-r--r--sysutils/pear-File_Find/pkg-descr5
-rw-r--r--sysutils/pear-File_Find/pkg-plist3
5 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 47851ea3cf76..e51753c5ce4b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -197,6 +197,7 @@
SUBDIR += pciutils
SUBDIR += pdumpfs
SUBDIR += pear-File
+ SUBDIR += pear-File_Find
SUBDIR += pear-Log
SUBDIR += penv
SUBDIR += perf
diff --git a/sysutils/pear-File_Find/Makefile b/sysutils/pear-File_Find/Makefile
new file mode 100644
index 000000000000..76d828d5ccd1
--- /dev/null
+++ b/sysutils/pear-File_Find/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pear-File_Find
+# Date created: 29 November 2002
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Find
+PORTVERSION= 0.2.0
+CATEGORIES= sysutils www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A PEAR Class to facilitate the search of filesystems
+
+BUILD_DEPENDS= ${PEARDIR}/File.php:${PORTSDIR}/sysutils/pear-File
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/Find.php ${PEARDIR}/File/Find.php
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pear-File_Find/distinfo b/sysutils/pear-File_Find/distinfo
new file mode 100644
index 000000000000..cf5255db456f
--- /dev/null
+++ b/sysutils/pear-File_Find/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/File_Find-0.2.0.tgz) = 6560a5dc0d750f959b00d4aefc427fb6
diff --git a/sysutils/pear-File_Find/pkg-descr b/sysutils/pear-File_Find/pkg-descr
new file mode 100644
index 000000000000..ae3407388f28
--- /dev/null
+++ b/sysutils/pear-File_Find/pkg-descr
@@ -0,0 +1,5 @@
+PEAR::File_Find, created as a replacement for its Perl counterpart, also named
+File_Find, is a directory searcher, which handles, globbing, recursive
+directory searching, as well as a slew of other cool features.
+
+WWW: http://pear.php.net/package-info.php?package=File_Find
diff --git a/sysutils/pear-File_Find/pkg-plist b/sysutils/pear-File_Find/pkg-plist
new file mode 100644
index 000000000000..e785fa8126c1
--- /dev/null
+++ b/sysutils/pear-File_Find/pkg-plist
@@ -0,0 +1,3 @@
+%%PEARDIR%%/File/Find.php
+%%PKGREGDIR%%/package.xml
+@dirrm %%PKGREGDIR%%