aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-05 18:53:21 +0800
committermiwi <miwi@FreeBSD.org>2006-08-05 18:53:21 +0800
commit4057a6c401aa138c6ba593351c3d959e88879c7f (patch)
tree0e64f0f062b008e9ba69a6deb7027b06c955f672
parent272d9f64eeb1dd985f3a66299a3aa06ebce8f3f7 (diff)
downloadfreebsd-ports-gnome-4057a6c401aa138c6ba593351c3d959e88879c7f.tar.gz
freebsd-ports-gnome-4057a6c401aa138c6ba593351c3d959e88879c7f.tar.zst
freebsd-ports-gnome-4057a6c401aa138c6ba593351c3d959e88879c7f.zip
RRD::Simple provides a simple interface to RRDTool's RRDs module. This
module does not currently offer fetch method that is available in the RRDs module. It does however create RRD files with a sensible set of default RRA (Round Robin Archive) definitions, and can dynamically add new data source names to an existing RRD file. This module is ideal for quick and simple storage of data within an RRD file if you do not need to, nor want to, bother defining custom RRA definitions. WWW: http://search.cpan.org/dist/RRD-Simple/ PR: ports/101073 Submitted by: chinsan <chinsan.tw(at)gmail.com> Approved by: krion (mentor)
-rw-r--r--databases/p5-RRD-Simple/Makefile33
-rw-r--r--databases/p5-RRD-Simple/distinfo3
-rw-r--r--databases/p5-RRD-Simple/pkg-descr11
-rw-r--r--databases/p5-RRD-Simple/pkg-plist3
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-RRD-Simple/Makefile33
-rw-r--r--net/p5-RRD-Simple/distinfo3
-rw-r--r--net/p5-RRD-Simple/pkg-descr11
-rw-r--r--net/p5-RRD-Simple/pkg-plist3
9 files changed, 101 insertions, 0 deletions
diff --git a/databases/p5-RRD-Simple/Makefile b/databases/p5-RRD-Simple/Makefile
new file mode 100644
index 000000000000..62e59d8e8263
--- /dev/null
+++ b/databases/p5-RRD-Simple/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: RRD-Simple
+# Date created: 2006/07/21
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RRD-Simple
+PORTVERSION= 1.39
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NI/NICOLAW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Simple interface to create and store data in RRD files
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Deep.pm:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Pod>=0.90:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/net/rrdtool
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+MAN3= RRD::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-RRD-Simple/distinfo b/databases/p5-RRD-Simple/distinfo
new file mode 100644
index 000000000000..0d1970e9caa1
--- /dev/null
+++ b/databases/p5-RRD-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (RRD-Simple-1.39.tar.gz) = 5a9a90877b4a99da15eac0eb52729773
+SHA256 (RRD-Simple-1.39.tar.gz) = 63fa04de7adc62d3228d310a0ab37054e696d683d75447e00b7018bd85caf1de
+SIZE (RRD-Simple-1.39.tar.gz) = 242513
diff --git a/databases/p5-RRD-Simple/pkg-descr b/databases/p5-RRD-Simple/pkg-descr
new file mode 100644
index 000000000000..d717d6080f12
--- /dev/null
+++ b/databases/p5-RRD-Simple/pkg-descr
@@ -0,0 +1,11 @@
+RRD::Simple provides a simple interface to RRDTool's RRDs module. This module
+does not currently offer fetch method that is available in the RRDs module.
+
+It does however create RRD files with a sensible set of default RRA (Round
+Robin Archive) definitions, and can dynamically add new data source names to an
+existing RRD file.
+
+This module is ideal for quick and simple storage of data within an RRD file if
+you do not need to, nor want to, bother defining custom RRA definitions.
+
+WWW: http://search.cpan.org/dist/RRD-Simple/
diff --git a/databases/p5-RRD-Simple/pkg-plist b/databases/p5-RRD-Simple/pkg-plist
new file mode 100644
index 000000000000..498c3844b62c
--- /dev/null
+++ b/databases/p5-RRD-Simple/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/RRD/Simple.pm
+@dirrmtry %%SITE_PERL%%/RRD
diff --git a/net/Makefile b/net/Makefile
index 9bcf1afa2beb..984f342e2b6a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -501,6 +501,7 @@
SUBDIR += p5-Parallel-Pvm
SUBDIR += p5-PlRPC
SUBDIR += p5-RPC-XML
+ SUBDIR += p5-RRD-Simple
SUBDIR += p5-ResourcePool-Resource-Net-LDAP
SUBDIR += p5-ResourcePool-Resource-SOAP-Lite
SUBDIR += p5-SOAP
diff --git a/net/p5-RRD-Simple/Makefile b/net/p5-RRD-Simple/Makefile
new file mode 100644
index 000000000000..62e59d8e8263
--- /dev/null
+++ b/net/p5-RRD-Simple/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: RRD-Simple
+# Date created: 2006/07/21
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RRD-Simple
+PORTVERSION= 1.39
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NI/NICOLAW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Simple interface to create and store data in RRD files
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Deep.pm:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Pod>=0.90:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/net/rrdtool
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+MAN3= RRD::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-RRD-Simple/distinfo b/net/p5-RRD-Simple/distinfo
new file mode 100644
index 000000000000..0d1970e9caa1
--- /dev/null
+++ b/net/p5-RRD-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (RRD-Simple-1.39.tar.gz) = 5a9a90877b4a99da15eac0eb52729773
+SHA256 (RRD-Simple-1.39.tar.gz) = 63fa04de7adc62d3228d310a0ab37054e696d683d75447e00b7018bd85caf1de
+SIZE (RRD-Simple-1.39.tar.gz) = 242513
diff --git a/net/p5-RRD-Simple/pkg-descr b/net/p5-RRD-Simple/pkg-descr
new file mode 100644
index 000000000000..d717d6080f12
--- /dev/null
+++ b/net/p5-RRD-Simple/pkg-descr
@@ -0,0 +1,11 @@
+RRD::Simple provides a simple interface to RRDTool's RRDs module. This module
+does not currently offer fetch method that is available in the RRDs module.
+
+It does however create RRD files with a sensible set of default RRA (Round
+Robin Archive) definitions, and can dynamically add new data source names to an
+existing RRD file.
+
+This module is ideal for quick and simple storage of data within an RRD file if
+you do not need to, nor want to, bother defining custom RRA definitions.
+
+WWW: http://search.cpan.org/dist/RRD-Simple/
diff --git a/net/p5-RRD-Simple/pkg-plist b/net/p5-RRD-Simple/pkg-plist
new file mode 100644
index 000000000000..498c3844b62c
--- /dev/null
+++ b/net/p5-RRD-Simple/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/RRD/Simple.pm
+@dirrmtry %%SITE_PERL%%/RRD