aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2006-05-14 21:02:28 +0800
committervs <vs@FreeBSD.org>2006-05-14 21:02:28 +0800
commit433d4bd5b55f786b4af1c6ba5c16f71e17c55035 (patch)
tree7411b327c0f1a04c28d908b4474b5b5229970016
parentc98c99fa78a7f4caae23d05a08ac844da1830b85 (diff)
downloadfreebsd-ports-gnome-433d4bd5b55f786b4af1c6ba5c16f71e17c55035.tar.gz
freebsd-ports-gnome-433d4bd5b55f786b4af1c6ba5c16f71e17c55035.tar.zst
freebsd-ports-gnome-433d4bd5b55f786b4af1c6ba5c16f71e17c55035.zip
Enable build on FreeBSD7
Submitted by: Arseny Nasokin
-rw-r--r--devel/gccxml/Makefile4
-rw-r--r--devel/gccxml/files/patch-GCC::gcc::config.gcc10
-rw-r--r--devel/gccxml/files/patch-GCC::gcc::config::freebsd7.h25
3 files changed, 35 insertions, 4 deletions
diff --git a/devel/gccxml/Makefile b/devel/gccxml/Makefile
index 5e01982a6858..e6b804bc9852 100644
--- a/devel/gccxml/Makefile
+++ b/devel/gccxml/Makefile
@@ -40,8 +40,4 @@ do-configure:
BROKEN= "Build fails on alpha"
.endif
-.if ${OSVERSION} >= 700000
-BROKEN= "Configure needs updating"
-.endif
-
.include <bsd.port.post.mk>
diff --git a/devel/gccxml/files/patch-GCC::gcc::config.gcc b/devel/gccxml/files/patch-GCC::gcc::config.gcc
new file mode 100644
index 000000000000..2fd0b0bba722
--- /dev/null
+++ b/devel/gccxml/files/patch-GCC::gcc::config.gcc
@@ -0,0 +1,10 @@
+--- GCC/gcc/config.gcc.orig Thu Jan 22 23:50:26 2004
++++ GCC/gcc/config.gcc Sat May 13 16:27:18 2006
+@@ -475,6 +475,7 @@
+ *-*-freebsd4 | *-*-freebsd[4].*) fbsd_tm_file="freebsd4.h";;
+ *-*-freebsd5 | *-*-freebsd[5].*) fbsd_tm_file="freebsd5.h";;
+ *-*-freebsd6 | *-*-freebsd[6].*) fbsd_tm_file="freebsd6.h";;
++ *-*-freebsd7 | *-*-freebsd[7].*) fbsd_tm_file="freebsd7.h";;
+ *) echo 'Please update *-*-freebsd* in gcc/config.gcc'; exit 1;;
+ esac
+ tmake_file="t-slibgcc-elf-ver t-freebsd"
diff --git a/devel/gccxml/files/patch-GCC::gcc::config::freebsd7.h b/devel/gccxml/files/patch-GCC::gcc::config::freebsd7.h
new file mode 100644
index 000000000000..5d86d2926ca1
--- /dev/null
+++ b/devel/gccxml/files/patch-GCC::gcc::config::freebsd7.h
@@ -0,0 +1,25 @@
+--- /dev/null Sat May 13 16:25:00 2006
++++ GCC/gcc/config/freebsd7.h Sat May 13 16:28:29 2006
+@@ -0,0 +1,22 @@
++/* FreeBSD version number setting for FreeBSD 6.x systems.
++ Copyright (C) 2001 Free Software Foundation, Inc.
++ Contributed by David E. O'Brien <obrien@FreeBSD.org> and BSDi.
++
++This file is part of GNU CC.
++
++GNU CC is free software; you can redistribute it and/or modify
++it under the terms of the GNU General Public License as published by
++the Free Software Foundation; either version 2, or (at your option)
++any later version.
++
++GNU CC is distributed in the hope that it will be useful,
++but WITHOUT ANY WARRANTY; without even the implied warranty of
++MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++GNU General Public License for more details.
++
++You should have received a copy of the GNU General Public License
++along with GNU CC; see the file COPYING. If not, write to
++the Free Software Foundation, 59 Temple Place - Suite 330,
++Boston, MA 02111-1307, USA. */
++
++#define FBSD_MAJOR 7