aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-07-28 01:24:26 +0800
committermarcus <marcus@FreeBSD.org>2003-07-28 01:24:26 +0800
commit44c4ef6376bda64002f88a6367e5e37d6ef235f2 (patch)
treea10a86959154413ad236e05cbe63d50aa7926545
parentd5e79e7dc41ea5604e97b6a89f16b2f385df9c07 (diff)
downloadfreebsd-ports-gnome-44c4ef6376bda64002f88a6367e5e37d6ef235f2.tar.gz
freebsd-ports-gnome-44c4ef6376bda64002f88a6367e5e37d6ef235f2.tar.zst
freebsd-ports-gnome-44c4ef6376bda64002f88a6367e5e37d6ef235f2.zip
Fix install by generating the plist during the pre-install phase.
Reported by: bento via kris
-rw-r--r--textproc/bedic-data/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/textproc/bedic-data/Makefile b/textproc/bedic-data/Makefile
index a56241e78955..ced89bbd3b69 100644
--- a/textproc/bedic-data/Makefile
+++ b/textproc/bedic-data/Makefile
@@ -28,8 +28,10 @@ pre-fetch:
@${ECHO_MSG} "should be installed; currently, it is set to ${DICTIONARIES}"
@${ECHO_MSG} "Set it to one or more of the following: ${DICT_ALL}"
+pre-install:
+ @${ECHO_CMD} ${DICTIONARIES} | ${TR} ' ' '\n' | ${SED} 's,^,share/,' > ${PLIST}
+
do-install:
- ${ECHO_CMD} ${DICTIONARIES} | ${TR} ' ' '\n' | ${SED} 's,^,share/,' > ${PLIST}
${MKDIR} ${DICT_DIR}
${INSTALL} ${DICTIONARIES:S,^,${WRKSRC}/,} ${DICT_DIR}/