aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-12-07 14:19:29 +0800
committerclsung <clsung@FreeBSD.org>2006-12-07 14:19:29 +0800
commit44f87e4ab4f39bf6ada5625aca4cd1608ca7d34e (patch)
treee966ba026f021159004c755d8142ad8326608eb2
parent6ab055d9aa74294b2c971c2c343ae1772806089c (diff)
downloadfreebsd-ports-gnome-44f87e4ab4f39bf6ada5625aca4cd1608ca7d34e.tar.gz
freebsd-ports-gnome-44f87e4ab4f39bf6ada5625aca4cd1608ca7d34e.tar.zst
freebsd-ports-gnome-44f87e4ab4f39bf6ada5625aca4cd1608ca7d34e.zip
Add p5-CGI-Application-Plugin-Forward 1.06, support for forwarding
requests in CGI::Application. PR: ports/103379 Submitted by: George Hartzell <hartzell at alerce.com>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Application-Plugin-Forward/Makefile30
-rw-r--r--www/p5-CGI-Application-Plugin-Forward/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-Forward/pkg-descr6
-rw-r--r--www/p5-CGI-Application-Plugin-Forward/pkg-plist4
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 01d04da8ef3a..8fed1669b756 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -515,6 +515,7 @@
SUBDIR += p5-CGI-Application-Plugin-AutoRunmode
SUBDIR += p5-CGI-Application-Plugin-DBH
SUBDIR += p5-CGI-Application-Plugin-DevPopup
+ SUBDIR += p5-CGI-Application-Plugin-Forward
SUBDIR += p5-CGI-Application-Plugin-HTDot
SUBDIR += p5-CGI-Application-Plugin-Redirect
SUBDIR += p5-CGI-Application-Plugin-ValidateRM
diff --git a/www/p5-CGI-Application-Plugin-Forward/Makefile b/www/p5-CGI-Application-Plugin-Forward/Makefile
new file mode 100644
index 000000000000..ce19a7ab7da5
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Forward/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-Forward
+# Date created: 14 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-Forward
+PORTVERSION= 1.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Support for forwarding requests in CGI::Application
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CGI/Application/Plugin/AutoRunmode.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-AutoRunmode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::Forward.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-Forward/distinfo b/www/p5-CGI-Application-Plugin-Forward/distinfo
new file mode 100644
index 000000000000..8da3982f0097
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Forward/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-Forward-1.06.tar.gz) = 1593ec5a83a7e104e4b85f13cc729a8a
+SHA256 (CGI-Application-Plugin-Forward-1.06.tar.gz) = f350069f31db2dab65b68a1d4a1bdb854ece8b91f8bd43bf822b828151708f47
+SIZE (CGI-Application-Plugin-Forward-1.06.tar.gz) = 9525
diff --git a/www/p5-CGI-Application-Plugin-Forward/pkg-descr b/www/p5-CGI-Application-Plugin-Forward/pkg-descr
new file mode 100644
index 000000000000..3f46004b6e07
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Forward/pkg-descr
@@ -0,0 +1,6 @@
+The forward method passes control to another run mode and returns its
+output. This is equivalent to calling $self->$other_runmode, except
+that CGI::Application's internal value of the current run mode is
+updated.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-Forward/
diff --git a/www/p5-CGI-Application-Plugin-Forward/pkg-plist b/www/p5-CGI-Application-Plugin-Forward/pkg-plist
new file mode 100644
index 000000000000..080eeb04e88c
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Forward/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/CGI/Application/Plugin/Forward.pm
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application
+@dirrmtry %%SITE_PERL%%/CGI